aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-01-29 04:18:42 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-01-29 04:18:42 +0100
commit6965de36ee06bcaecace0233c44a2afcfd08c534 (patch)
tree4aaa616a5c9e96d0ed304132987f7891d58c667f
parentBuild glibc in stage1 with USE=multiarch (diff)
downloadreleng-6965de36.tar.gz
releng-6965de36.tar.bz2
releng-6965de36.zip
Enable s390 23.0 32bit builds
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--releases/specs/s390/s390/stage1-openrc-23.spec11
-rw-r--r--releases/specs/s390/s390/stage1-systemd-23.spec11
-rw-r--r--releases/specs/s390/s390/stage3-openrc-23.spec10
-rw-r--r--releases/specs/s390/s390/stage3-systemd-23.spec10
-rw-r--r--tools/catalyst-auto-s390.conf20
5 files changed, 61 insertions, 1 deletions
diff --git a/releases/specs/s390/s390/stage1-openrc-23.spec b/releases/specs/s390/s390/stage1-openrc-23.spec
new file mode 100644
index 00000000..b9f1e91d
--- /dev/null
+++ b/releases/specs/s390/s390/stage1-openrc-23.spec
@@ -0,0 +1,11 @@
+subarch: s390
+version_stamp: openrc-@TIMESTAMP@
+target: stage1
+rel_type: 23.0-default
+profile: default/linux/s390/23.0
+snapshot: @TIMESTAMP@
+source_subpath: 23.0-default/stage3-s390-openrc-latest
+update_seed: yes
+update_seed_command: --update --deep --newuse @world
+compression_mode: pixz
+portage_confdir: @REPO_DIR@/releases/portage/stages
diff --git a/releases/specs/s390/s390/stage1-systemd-23.spec b/releases/specs/s390/s390/stage1-systemd-23.spec
new file mode 100644
index 00000000..bf316dee
--- /dev/null
+++ b/releases/specs/s390/s390/stage1-systemd-23.spec
@@ -0,0 +1,11 @@
+subarch: s390
+version_stamp: systemd-@TIMESTAMP@
+target: stage1
+rel_type: 23.0-default
+profile: default/linux/s390/23.0/systemd
+snapshot: @TIMESTAMP@
+source_subpath: 23.0-default/stage3-s390-systemd-latest
+update_seed: yes
+update_seed_command: --update --deep --newuse @world
+compression_mode: pixz
+portage_confdir: @REPO_DIR@/releases/portage/stages
diff --git a/releases/specs/s390/s390/stage3-openrc-23.spec b/releases/specs/s390/s390/stage3-openrc-23.spec
new file mode 100644
index 00000000..d075c81c
--- /dev/null
+++ b/releases/specs/s390/s390/stage3-openrc-23.spec
@@ -0,0 +1,10 @@
+subarch: s390
+version_stamp: openrc-@TIMESTAMP@
+target: stage3
+rel_type: 23.0-default
+profile: default/linux/s390/23.0
+snapshot: @TIMESTAMP@
+source_subpath: 23.0-default/stage1-s390-openrc-@TIMESTAMP@
+compression_mode: pixz
+portage_confdir: @REPO_DIR@/releases/portage/stages
+binrepo_path: s390/binpackages/23.0/s390
diff --git a/releases/specs/s390/s390/stage3-systemd-23.spec b/releases/specs/s390/s390/stage3-systemd-23.spec
new file mode 100644
index 00000000..f7489afa
--- /dev/null
+++ b/releases/specs/s390/s390/stage3-systemd-23.spec
@@ -0,0 +1,10 @@
+subarch: s390
+version_stamp: systemd-@TIMESTAMP@
+target: stage3
+rel_type: 23.0-default
+profile: default/linux/s390/23.0/systemd
+snapshot: @TIMESTAMP@
+source_subpath: 23.0-default/stage1-s390-systemd-@TIMESTAMP@
+compression_mode: pixz
+portage_confdir: @REPO_DIR@/releases/portage/stages
+binrepo_path: s390/binpackages/23.0/s390
diff --git a/tools/catalyst-auto-s390.conf b/tools/catalyst-auto-s390.conf
index a9cbf249..5c5884d7 100644
--- a/tools/catalyst-auto-s390.conf
+++ b/tools/catalyst-auto-s390.conf
@@ -6,13 +6,23 @@ UPLOAD_KEY=/root/.ssh/id_rsa
SPECS_DIR=${REPO_DIR}/releases/specs/s390/s390
SUBARCH=s390
-SETS="openrc systemd_mu"
+SETS="
+ openrc
+ systemd_mu
+ openrc_23
+ systemd_23
+"
SET_openrc_SPECS="stage1-openrc.spec stage3-openrc.spec"
SET_openrc_OPTIONAL_SPECS="netboot/netboot.spec"
SET_systemd_mu_SPECS="stage1-systemd-mu.spec stage3-systemd-mu.spec"
+SET_openrc_23_SPECS="stage1-openrc-23.spec stage3-openrc-23.spec"
+
+SET_systemd_23_SPECS="stage1-systemd-23.spec stage3-systemd-23.spec"
+
+
KCONFIG_DIR=${REPO_DIR}/releases/kconfig/s390
update_symlinks() {
@@ -54,4 +64,12 @@ post_build() {
;;
esac
popd >/dev/null
+
+ pushd "${BUILD_SRCDIR_BASE}/builds/23.0-default" >/dev/null
+ case ${spec} in
+ stage3-systemd-23.spec)
+ upsync_binpackages "${BUILD_SRCDIR_BASE}/packages/23.0-default/stage3-s390" s390/23.0/s390
+ ;;
+ esac
+ popd >/dev/null
}