aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-04-04 10:34:33 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-04-04 10:34:33 +0200
commitf6f9506c1ea79c02b156090f3a18828170085daa (patch)
treef80d741fa03681fddfe3ecb4b891aa9129d238d7
parentapp-emulation/spike: drop stabilize-allarches from metadata (diff)
downloadriscv-f6f9506c1ea79c02b156090f3a18828170085daa.tar.gz
riscv-f6f9506c1ea79c02b156090f3a18828170085daa.tar.bz2
riscv-f6f9506c1ea79c02b156090f3a18828170085daa.zip
app-emulation/spike: add 1.1.0_p20240324
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--app-emulation/spike/Manifest1
-rw-r--r--app-emulation/spike/spike-1.1.0_p20240324.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-emulation/spike/Manifest b/app-emulation/spike/Manifest
index 5a0d0a6..c132c53 100644
--- a/app-emulation/spike/Manifest
+++ b/app-emulation/spike/Manifest
@@ -1 +1,2 @@
DIST spike-1.0.0.tar.gz 283500 BLAKE2B a25f5faad1fa76e131f2477c5c103a738a0a5c6a4bec0a147d9233acc3e9ef60d52621e83d54e4025fa50ab402a294564cfdf4244651c14dd1b852fe3d16becf SHA512 e5755fc2bb38d5cb11d340f612f82207f6f77599b4cd38206c70cdb211f43108694ce2807822bccb77de308bb78b60a23978de972c2c8394601712ff1153267c
+DIST spike-1.1.0_p20240324.tar.gz 511200 BLAKE2B c925a5e1775d3ffd0d14009a42a7d4d20bd4013e4b95c1ce4551ab6d55d5d3bb8b52df04f237c17d07a439925a7acf18500d2ca34f046e8870bce3b88fccef45 SHA512 6d9bd4f903962a29661cde2e1b26f1457db2fd3602079e433f24bc077c1188cba354570a8f0d2b0c2e1a24445346f4fe73618be7ff93f0962ffd060094956563
diff --git a/app-emulation/spike/spike-1.1.0_p20240324.ebuild b/app-emulation/spike/spike-1.1.0_p20240324.ebuild
new file mode 100644
index 0000000..4ce8063
--- /dev/null
+++ b/app-emulation/spike/spike-1.1.0_p20240324.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="The RISC-V ISA Simulator"
+HOMEPAGE="https://github.com/riscv-software-src/riscv-isa-sim"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/riscv-software-src/riscv-isa-sim.git"
+else
+ MY_COMMIT=3427b459f88d2334368a1abbdf5a3000957f08e8
+ if [[ -v MY_COMMIT ]]; then
+ SRC_URI="https://github.com/riscv-software-src/riscv-isa-sim/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/riscv-isa-sim-${MY_COMMIT}"
+ else
+ SRC_URI="https://github.com/riscv/riscv-isa-sim/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ fi
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="sys-apps/dtc"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e "/install_libs_dir/s:/lib:/$(get_libdir)/spike:g" \
+ Makefile.in || die
+}