aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-19 19:12:30 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-19 19:12:30 -0500
commit20d27a2064a5ea30cc8a2e8d91e7b64c15a982b3 (patch)
treea39a93adfe8dfd5ac7158b1ec05684479a0140f3
parentlibsandbox: tweak edge cases of realloc a bit (diff)
downloadsandbox-20d27a20.tar.gz
sandbox-20d27a20.tar.bz2
sandbox-20d27a20.zip
build: fix SB_SCHIZO automake conditional
The rework in commit 46fe624223cfe62fb6c2fbb609be42f2f1d1734b broke the set up of the SB_SCHIZO automake conditional for non-schizo builds as it was not updated to the new variable. This would cause the syscall table to always be empty and thus the ptrace code would never match. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 25711cc..64089d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,7 +88,7 @@ if test "x$enable_schizo" != "xno" ; then
fi
AC_SUBST(SB_SCHIZO_SETTINGS)
AC_SUBST(SB_SCHIZO_HEADERS)
-AM_CONDITIONAL([SB_SCHIZO], test "$SB_SCHIZO_SETTINGS" != "no")
+AM_CONDITIONAL([SB_SCHIZO], [test "x$enable_schizo" != "xno"])
dnl this test fills up the stack and then triggers a segfault ...
dnl but it's hard to wrap things without a stack, so let's ignore