aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-21 16:04:23 +0100
committerSam James <sam@gentoo.org>2023-08-05 05:32:14 +0100
commit4f42e1984227012797030839b5e757a6da147141 (patch)
tree9b6d3e534e97d7250b861338275a46c17e6446ac
parentRename multiple personalities feature (diff)
downloadsandbox-4f42e1984227012797030839b5e757a6da147141.tar.gz
sandbox-4f42e1984227012797030839b5e757a6da147141.tar.bz2
sandbox-4f42e1984227012797030839b5e757a6da147141.zip
configure.ac: cleanup error messages
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index e5e9722..bb4c52c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -294,18 +294,18 @@ if test x"$va_copy" != xva_copy ; then
)
fi
-dnl Verify people aren't doing stupid shit
+dnl Avoid footguns.
if test x"$enable_static" != xno ; then
- AC_MSG_ERROR([dont be a Kumba, building a libsandbox.a is stupid])
+ AC_MSG_ERROR([Building a static libsandbox.a is not supported])
fi
if test x"$enable_shared" != xyes ; then
- AC_MSG_ERROR([dont be a Kumba, omitting a libsandbox.so is stupid])
+ AC_MSG_ERROR([Omitting a libsandbox.so is not supported])
fi
if echo " $CFLAGS " | $EGREP ' -static ' >/dev/null 2>&1; then
- AC_MSG_ERROR([dont be a Kumba, using -static in CFLAGS is stupid])
+ AC_MSG_ERROR([Using -static in CFLAGS is not supported])
fi
if echo " $LDFLAGS " | $EGREP ' -static ' >/dev/null 2>&1; then
- AC_MSG_ERROR([dont be a Kumba, using -static in LDFLAGS is stupid])
+ AC_MSG_ERROR([Using -static in LDFLAGS is not supported])
fi
dnl Some libc's like those on bsd have dlopen() in libc, and not libdl