aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-12-01 10:40:09 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-12-01 10:40:09 +0000
commit64ed77f12830369e7ad8cf3d4753985d7145a87e (patch)
treec218377afb6de397efe6f6293031d611232c5c31
parentRename src/symbols.in to src/symbols.h.in. (diff)
downloadsandbox-64ed77f12830369e7ad8cf3d4753985d7145a87e.tar.gz
sandbox-64ed77f12830369e7ad8cf3d4753985d7145a87e.tar.bz2
sandbox-64ed77f12830369e7ad8cf3d4753985d7145a87e.zip
Cleanup local defines for egetcwd() and erealpath().
Signed-off-by: Martin Schlemmer <azarah@gentoo.org>
-rw-r--r--ChangeLog2
-rw-r--r--configure.ac2
-rw-r--r--src/canonicalize.c4
-rw-r--r--src/libsandbox.c4
-rw-r--r--src/sandbox.h4
-rw-r--r--src/sandbox_futils.c5
6 files changed, 11 insertions, 10 deletions
diff --git a/ChangeLog b/ChangeLog
index f0d4a19..8292a7f 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -24,6 +24,8 @@
Rename src/symbols.in to src/symbols.h.in.
+ Cleanup local defines for egetcwd() and erealpath().
+
28 Nov 2005; Martin Schlemmer <azarah@gentoo.org> configure.in, sandbox.c,
sandbox_fdutils.c:
diff --git a/configure.ac b/configure.ac
index 4142349..fd2a9cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_PREREQ([2.59])
-AC_INIT([sandbox], [1.2.14], [sandbox@gentoo.org])
+AC_INIT([sandbox], [1.2.15_alpha1], [sandbox@gentoo.org])
AM_INIT_AUTOMAKE
AC_CONFIG_HEADER([config.h])
diff --git a/src/canonicalize.c b/src/canonicalize.c
index 68737d9..beec9fa 100644
--- a/src/canonicalize.c
+++ b/src/canonicalize.c
@@ -34,12 +34,12 @@
#include "config.h"
#include "localdecls.h"
+#include "sandbox.h"
+
#ifndef __set_errno
# define __set_errno(val) errno = (val)
#endif
-extern char *egetcwd(char *, size_t);
-
/* Return the canonical absolute name of file NAME. A canonical name
does not contain any `.', `..' components nor any repeated path
separators ('/') or symlinks. All path components must exist. If
diff --git a/src/libsandbox.c b/src/libsandbox.c
index 4af7406..8005dc6 100644
--- a/src/libsandbox.c
+++ b/src/libsandbox.c
@@ -128,10 +128,6 @@ static int sb_path_size_warning = 0;
void __attribute__ ((constructor)) libsb_init(void);
void __attribute__ ((destructor)) libsb_fini(void);
-/* glibc modified realpath() function */
-extern char *erealpath(const char *, char *);
-extern char *egetcwd(char *, size_t);
-
static void *get_dlsym(const char *, const char *);
static int canonicalize(const char *, char *);
static char *filter_path(const char *, int);
diff --git a/src/sandbox.h b/src/sandbox.h
index aa9bc48..cd07230 100644
--- a/src/sandbox.h
+++ b/src/sandbox.h
@@ -104,6 +104,10 @@ int is_dir(const char *pathname, int follow_link);
long file_length(int fd);
#endif /* OUTSIDE_LIBSANDBOX */
+/* glibc modified realpath() function */
+char *erealpath(const char *, char *);
+char *egetcwd(char *, size_t);
+
#endif /* __SANDBOX_H__ */
// vim:noexpandtab noai:cindent ai
diff --git a/src/sandbox_futils.c b/src/sandbox_futils.c
index f71f087..1971b94 100644
--- a/src/sandbox_futils.c
+++ b/src/sandbox_futils.c
@@ -17,11 +17,10 @@
#include <fcntl.h>
#include <libgen.h>
-#include "sandbox.h"
#include "config.h"
+#include "localdecls.h"
-/* glibc modified getcwd() functions */
-char *egetcwd(char *, size_t);
+#include "sandbox.h"
void get_sandbox_lib(char *path)
{