aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-03-14 00:28:10 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-03-14 00:28:10 +0000
commit4173f398f0f7aec50773b851164af436dae9c6b8 (patch)
tree2bc49d1c23630cc47f33cf253811491e3712efe4 /Makefile.am
parentAlso rename the _init() and _fini() declarations. (diff)
downloadsandbox-4173f398f0f7aec50773b851164af436dae9c6b8.tar.gz
sandbox-4173f398f0f7aec50773b851164af436dae9c6b8.tar.bz2
sandbox-4173f398f0f7aec50773b851164af436dae9c6b8.zip
Seems -nostdlib was the problem with the constructor/destructor - remove it
from Makefile.am, and change the constructor/destructor names again. Signed-off-by: Martin Schlemmer <azarah@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5a04dad..7673ebd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,9 @@ dist_pkgdata_DATA = sandbox.bashrc
lib_LTLIBRARIES = libsandbox.la
libsandbox_la_SOURCES = libsandbox.c sandbox_futils.c localdecls.h
-libsandbox_la_LDFLAGS = -Wc,-nostdlib -Wc,-nodefaultlibs -lc -ldl
+# Do not add -nostdlib or -nostartfiles, as then our constructor
+# and destructor will not be executed ...
+libsandbox_la_LDFLAGS = -nodefaultlibs -lc -ldl
# We need -fexceptions here, else we do not catch exceptions
# (nptl/tst-cancelx4.c in glibc among others fails for wrapped functions).
libsandbox_la_CFLAGS = -fexceptions