aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-02 05:22:49 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-02 05:22:49 +0000
commitc519aea6404bd3dc7021fd7f994440e6744a2ee6 (patch)
tree1951ba9d78bcdd9b41d330d2e972c8f71b8abcde /Makefile.am
parentneed to include config.h (diff)
downloadsandbox-c519aea6404bd3dc7021fd7f994440e6744a2ee6.tar.gz
sandbox-c519aea6404bd3dc7021fd7f994440e6744a2ee6.tar.bz2
sandbox-c519aea6404bd3dc7021fd7f994440e6744a2ee6.zip
turn create-localdecls into semi-autotooled
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index c06ddae..1b8776a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
AUTOMAKE_OPTIONS = dist-bzip2 no-dist-gzip
dist_pkgdata_DATA = sandbox.bashrc
EXTRA_DIST = sandbox.bashrc canonicalize.c create-localdecls libctest.c
-AM_CFLAGS = -D_GNU_SOURCE -DPIC -fPIC -D_REENTRANT
+AM_CFLAGS = -D_GNU_SOURCE -DPIC -fPIC -D_REENTRANT -DLIBC_VERSION=\"$(LIBC_VERSION)\"
lib_LTLIBRARIES = libsandbox.la
libsandbox_la_SOURCES = libsandbox.c sandbox_futils.c localdecls.h
@@ -13,7 +13,3 @@ libsandbox_la_CFLAGS = -Wc,-nostdlib -D_REENTRANT -D_GNU_SOURCE \
bin_PROGRAMS = sandbox
sandbox_SOURCES = sandbox.c sandbox.h sandbox_futils.c getcwd.c
sandbox_CFLAGS = -DSANDBOX_BASHRC_PATH=\"$(pkgdatadir)\" -DLIBSANDBOX_PATH=\"$(libdir)\"
-
-BUILT_SOURCES = localdecls.h
-localdecls.h: Makefile
- ./create-localdecls