aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-12-05 13:55:37 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-12-05 13:55:37 +0000
commit4c4f1c8946916074c4ad9a60d8b76cc10827ffa3 (patch)
tree956abf14289c81bcdc6b2fe42e8aa68ce11c2ecb /configure.ac
parentCleanup RTLD defines. (diff)
downloadsandbox-4c4f1c8946916074c4ad9a60d8b76cc10827ffa3.tar.gz
sandbox-4c4f1c8946916074c4ad9a60d8b76cc10827ffa3.tar.bz2
sandbox-4c4f1c8946916074c4ad9a60d8b76cc10827ffa3.zip
Fix regex for newer uclibc that also matches /lib/ld-uClibc.so.0.
Signed-off-by: Martin Schlemmer <azarah@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3df677f..5735d2a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,7 +119,7 @@ AC_MSG_CHECKING([libc path])
echo "int main(void) { return 0; }" > libctest.c
$CC -Wall -o libctest libctest.c
LIBC_PATH=`$CC $CFLAGS -Wl,-verbose -o libctest libctest.c 2>&1 | \
- $AWK '/attempt to open/ { if (($4 ~ /libc\.so/) && ($5 == "succeeded")) LIBC = $4; }; END {print LIBC}'`
+ $AWK '/attempt to open/ { if (($4 ~ /\/libc\.so/) && ($5 == "succeeded")) LIBC = $4; }; END {print LIBC}'`
rm -f libctest.c
if test "$LIBC_PATH"x = x || ! test -r "$LIBC_PATH"; then
AC_MSG_ERROR([Unable to determine LIBC PATH])