aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-10 15:08:08 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-10 15:08:08 +0000
commit872108a8baacc8fda7688bb06353a91c3e048a34 (patch)
treeab98ed547c7fee2ca607fb13bcbb6769f4c458d6 /configure.ac
parentRelease sandbox-1.2.18.1 (diff)
downloadsandbox-872108a8baacc8fda7688bb06353a91c3e048a34.tar.gz
sandbox-872108a8baacc8fda7688bb06353a91c3e048a34.tar.bz2
sandbox-872108a8baacc8fda7688bb06353a91c3e048a34.zip
Rafal Rzepecki writes:
sandbox's configure script first finds readelf, then ignores the path found earlier when checking LIBC version. This leads (on my system) to configure failing with error `configure: error: Unable to determine LIBC VERSION'. http://bugs.gentoo.org/136284 Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e822d7e..9caee0d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,7 +145,7 @@ dnl the sed script at the end here looks funny but it's ok ...
dnl they're m4 escape sequences for left and right brackets
echo "int main(void) { return 0; }" > libctest.c
$CC -Wall -o libctest libctest.c
-LIBC_VERSION=`readelf -d libctest | grep NEEDED.*libc\\.so | $AWK '{print $NF}' | sed -e 's:\@<:@::' -e 's:\@:>@::'`
+LIBC_VERSION=`$READELF -d libctest | grep NEEDED.*libc\\.so | $AWK '{print $NF}' | sed -e 's:\@<:@::' -e 's:\@:>@::'`
rm -f libctest*
if test "$LIBC_VERSION"x = x ; then
AC_MSG_ERROR([Unable to determine LIBC VERSION])