aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2006-07-09 19:13:57 +0000
committerMartin Schlemmer <azarah@gentoo.org>2006-07-09 19:13:57 +0000
commitaf23d1cbc9351808befde8e61da51ce202eaaa64 (patch)
tree3aac0dab22ed88d4293bd28021e690ff2daf103e /configure.ac
parentReformat previous added code a bit, and add debug messages (diff)
downloadsandbox-af23d1cbc9351808befde8e61da51ce202eaaa64.tar.gz
sandbox-af23d1cbc9351808befde8e61da51ce202eaaa64.tar.bz2
sandbox-af23d1cbc9351808befde8e61da51ce202eaaa64.zip
As we are using a symbol map for libsandbox, its no longer needed
to have all the internal functions static, and thus we can break things out a bit and make the source layout more sane. Start by moving librcutil to libsbutil, and adding all the defines and helper functions needed by both libsandbox and sandbox. Signed-off-by: Martin Schlemmer <azarah@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cb70031..8c47148 100644
--- a/configure.ac
+++ b/configure.ac
@@ -193,11 +193,14 @@ if test x"$enable_multilib" != xno ; then
AC_DEFINE([SB_HAVE_MULTILIB], [1], [Have multilib enabled system])
fi
+SANDBOX_DEFINES='-DETCDIR="\"$(sysconfdir)\"" -DLIBSANDBOX_PATH="\"$(libdir)\"" -DSANDBOX_BASHRC_PATH="\"$(pkgdatadir)\""'
+AC_SUBST([SANDBOX_DEFINES])
+
AC_OUTPUT([
Makefile
scripts/Makefile
etc/Makefile
data/Makefile
- librcutil/Makefile
+ libsbutil/Makefile
src/Makefile
])