aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-12-05 10:10:47 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-12-05 10:10:47 +0000
commitd1f53e5790a2fc702241b8c9c2e5a2446c53a8c6 (patch)
tree919d95ee35c28f48b28bfc197df90a52e528a326 /configure.ac
parentMore bsd fixes. (diff)
downloadsandbox-d1f53e5790a2fc702241b8c9c2e5a2446c53a8c6.tar.gz
sandbox-d1f53e5790a2fc702241b8c9c2e5a2446c53a8c6.tar.bz2
sandbox-d1f53e5790a2fc702241b8c9c2e5a2446c53a8c6.zip
Rather check for RTLD_NEXT than glibc. Some other cleanups.
Signed-off-by: Martin Schlemmer <azarah@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 12 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 3b5978e..3df677f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,29 +91,27 @@ else
AC_DEFINE([TRUNCATE_T], [off_t], [truncate arg type])
fi
-dnl Check if we have glibc or clone
-AC_MSG_CHECKING([for glibc])
+dnl Check if libc provides RTLD_NEXT
+AC_MSG_CHECKING([for RTLD_NEXT])
AC_TRY_COMPILE([
-#include <features.h>
+#define _GNU_SOURCE
+#include <dlfcn.h>
], [
-#if !defined(__GLIBC__)
-# error no glibc
+#if !defined(RTLD_NEXT)
+# error no RTLD_NEXT
#endif
-int main (void)
+int
+main (void)
{
return 0;
}
],
- [have_glibc="yes"],
- [have_glibc="no"]
+ [have_rtld_next="yes"],
+ [have_rtld_next="no"]
)
-if test x"$have_glibc" = xyes ; then
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-AM_CONDITIONAL([HAVE_GLIBC], [test x"$have_glibc" = xyes])
+AC_MSG_RESULT([$have_rtld_next])
+AM_CONDITIONAL([HAVE_RTLD_NEXT], [test x"$have_rtld_next" = xyes])
dnl we need to handle symbols differently based upon their version,
dnl but we have to know which symbols the libc supports first