aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-06 04:04:10 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-06 04:04:10 +0000
commited3d3c6e44c52ca458e3693b7ffc137279999e50 (patch)
tree96c38c967a193fc9086ef0dc2cbf05ad481a4307 /configure.ac
parentCleanup. (diff)
downloadsandbox-ed3d3c6e44c52ca458e3693b7ffc137279999e50.tar.gz
sandbox-ed3d3c6e44c52ca458e3693b7ffc137279999e50.tar.bz2
sandbox-ed3d3c6e44c52ca458e3693b7ffc137279999e50.zip
log issues with LIBC PATH a little better
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e86c0f9..b20b58e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,11 +114,12 @@ dnl we need to handle symbols differently based upon their version,
dnl but we have to know which symbols the libc supports first
AC_MSG_CHECKING([libc path])
echo "int main(void) { return 0; }" > libctest.c
-LIBC_PATH=`$CC $CFLAGS -Wl,-verbose -o libctest libctest.c 2>&1 | \
- $AWK '/attempt to open/ { if (($4 ~ /\/libc\.so/) && ($5 == "succeeded")) LIBC = $4; }; END {print LIBC}'`
+$CC $CFLAGS -Wl,-verbose -o libctest libctest.c &> libctest.log
+cat libctest.log 1>&AS_MESSAGE_LOG_FD
+LIBC_PATH=`$AWK '/attempt to open/ { if (($4 ~ /\/libc\.so/) && ($5 == "succeeded")) LIBC = $4; }; END {print LIBC}' libctest.log`
rm -f libctest*
if test "$LIBC_PATH"x = x || ! test -r "$LIBC_PATH"; then
- AC_MSG_ERROR([Unable to determine LIBC PATH])
+ AC_MSG_ERROR([Unable to determine LIBC PATH ($LIBC_PATH)])
fi
AC_MSG_RESULT([$LIBC_PATH])
AC_SUBST([LIBC_PATH])