aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlayman <layman@localhost>2015-05-21 18:48:15 +0100
committerlayman <layman@localhost>2015-05-21 18:48:15 +0100
commit01e354c4ff4b1404ab3fc884363af8b73a799c3c (patch)
treec993faa317b1d0d0ab5151025592e399752ea034
parentmedia-gfx/brlcad: fixed deps tcl/tk slots (diff)
downloadsci-01e354c4ff4b1404ab3fc884363af8b73a799c3c.tar.gz
sci-01e354c4ff4b1404ab3fc884363af8b73a799c3c.tar.bz2
sci-01e354c4ff4b1404ab3fc884363af8b73a799c3c.zip
sci-biology/salmon: add salmon
Package-Manager: portage-2.2.14-prefix
-rw-r--r--sci-biology/salmon/ChangeLog11
-rw-r--r--sci-biology/salmon/Manifest1
-rw-r--r--sci-biology/salmon/files/salmon-0.3.2-no-boost-static.patch16
-rw-r--r--sci-biology/salmon/metadata.xml9
-rw-r--r--sci-biology/salmon/salmon-0.3.2.ebuild23
-rw-r--r--sci-biology/salmon/salmon-9999.ebuild24
6 files changed, 84 insertions, 0 deletions
diff --git a/sci-biology/salmon/ChangeLog b/sci-biology/salmon/ChangeLog
new file mode 100644
index 000000000..83c1c814f
--- /dev/null
+++ b/sci-biology/salmon/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-biology/salmon
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*salmon-0.3.2 (21 May 2015)
+*salmon-9999 (21 May 2015)
+
+ 21 May 2015; Michael Schubert <mschu.dev@gmail.com>
+ +files/salmon-0.3.2-no-boost-static.patch, +metadata.xml,
+ +salmon-0.3.2.ebuild, +salmon-9999.ebuild:
+ sci-biology/salmon: add salmon
diff --git a/sci-biology/salmon/Manifest b/sci-biology/salmon/Manifest
new file mode 100644
index 000000000..cef7a9cd2
--- /dev/null
+++ b/sci-biology/salmon/Manifest
@@ -0,0 +1 @@
+DIST salmon-0.3.2.tar.gz 1674131 SHA256 e0c957f0bc612e1fd7d7c4383758396042b68ea08aeae024cadb5d63e6dd9cf2 SHA512 d9db133d8fb009a4b23251bce209a869644eb6139e0e4b9133f947999e0be4c30039f5cb8617dc4b73977cd690837abb407549a619ef82e6bb82577ff082becf WHIRLPOOL e2f8f636547c93fbf3fade454754352537bc5a9fce668b0989ca58f5f5b9ca8f2454077af5dfc948f0acf9c6c2a6bdd6995d481dc08fd0f3db938639435afc0f
diff --git a/sci-biology/salmon/files/salmon-0.3.2-no-boost-static.patch b/sci-biology/salmon/files/salmon-0.3.2-no-boost-static.patch
new file mode 100644
index 000000000..6a00ebe71
--- /dev/null
+++ b/sci-biology/salmon/files/salmon-0.3.2-no-boost-static.patch
@@ -0,0 +1,16 @@
+--- CMakeLists.txt.orig 2015-05-19 23:39:27.969165466 +0100
++++ CMakeLists.txt 2015-05-19 23:39:40.154150194 +0100
+@@ -162,13 +162,6 @@ if ( DEFINED CUSTOM_BOOST_PATH )
+ set (CMAKE_LIBRARY_PATH ${CUSTOM_BOOST_PATH}/lib ${CMAKE_LIBRARY_PATH})
+ endif ( DEFINED CUSTOM_BOOST_PATH )
+
+-##
+-# We want static, multithreaded boost libraries
+-##
+-set (Boost_USE_STATIC_LIBS ON)
+-set (Boost_USE_MULTITHREADED ON)
+-#set (Boost_USE_STATIC_RUNTIME OFF)
+-
+ find_package (ZLIB)
+ if (NOT ZLIB_FOUND)
+ message (FATAL_ERROR "zlib must be installed before configuration & building can proceed")
diff --git a/sci-biology/salmon/metadata.xml b/sci-biology/salmon/metadata.xml
new file mode 100644
index 000000000..b7551a6aa
--- /dev/null
+++ b/sci-biology/salmon/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <maintainer>
+ <email>mschu.dev@gmail.com</email>
+ <name>Michael Schubert</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-biology/salmon/salmon-0.3.2.ebuild b/sci-biology/salmon/salmon-0.3.2.ebuild
new file mode 100644
index 000000000..59ab07eb2
--- /dev/null
+++ b/sci-biology/salmon/salmon-0.3.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Transcript-level quantification from RNA-seq reads using lightweight alignments"
+HOMEPAGE="https://github.com/COMBINE-lab/salmon"
+SRC_URI="https://github.com/COMBINE-lab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-no-boost-static.patch"
+}
diff --git a/sci-biology/salmon/salmon-9999.ebuild b/sci-biology/salmon/salmon-9999.ebuild
new file mode 100644
index 000000000..e631316fe
--- /dev/null
+++ b/sci-biology/salmon/salmon-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit git-r3 cmake-utils
+
+DESCRIPTION="Transcript-level quantification from RNA-seq reads using lightweight alignments"
+HOMEPAGE="https://github.com/COMBINE-lab/salmon"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/COMBINE-lab/salmon.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.3.2-no-boost-static.patch"
+}