aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIsrael Hernandez <israel.a.hernandez@gmail.com>2023-07-10 20:52:15 -0700
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-08-17 19:08:03 +0200
commit06537eb0db6fe59195bcf8059def58763d135207 (patch)
tree6b006d87227b49ac1ab6ffbc067422f2aff02d4a
parentdev-java/scijava-table: new package, add 1.0.2, 9999 (diff)
downloadsci-06537eb0db6fe59195bcf8059def58763d135207.tar.gz
sci-06537eb0db6fe59195bcf8059def58763d135207.tar.bz2
sci-06537eb0db6fe59195bcf8059def58763d135207.zip
media-libs/imglib2: Add new package
Signed-off-by: IAHMCOL <IAHMCOL@thejabberwocky.net> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--media-libs/imglib2/Manifest1
-rw-r--r--media-libs/imglib2/imglib2-6.2.0.ebuild53
-rw-r--r--media-libs/imglib2/imglib2-9999.ebuild53
-rw-r--r--media-libs/imglib2/metadata.xml16
4 files changed, 123 insertions, 0 deletions
diff --git a/media-libs/imglib2/Manifest b/media-libs/imglib2/Manifest
new file mode 100644
index 000000000..3ce824e00
--- /dev/null
+++ b/media-libs/imglib2/Manifest
@@ -0,0 +1 @@
+DIST imglib2-6.2.0-sources.tar.gz 1088844 BLAKE2B 919b4261199415e0e575bba297900e5dc177785b70511d797a7f962675adaa61f19467d37d664c12a4dc91df3f1f6cd575309c7f508c4792706942670c6946c0 SHA512 e3381979884dac13d051f1754be0837049e430b71c382666d036fa1d3403bc233a7b39c3b0c587852b08d7d12851043111a1ab206e4049d117dedf847da687e9
diff --git a/media-libs/imglib2/imglib2-6.2.0.ebuild b/media-libs/imglib2/imglib2-6.2.0.ebuild
new file mode 100644
index 000000000..d024676c7
--- /dev/null
+++ b/media-libs/imglib2/imglib2-6.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A multidimensional, type-agnostic image processing library."
+HOMEPAGE="
+ http://imglib2.net/
+ https://github.com/imglib/imglib2
+"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/imglib/imglib2.git"
+ S="${WORKDIR}/${P}"
+ MAVEN_ID="net.imglib2:imglib2:9999"
+else
+ SRC_URI="
+ https://github.com/imglib/${PN}/archive/refs/tags/${P}.tar.gz -> ${P}-sources.tar.gz
+ "
+ S="${WORKDIR}/${PN}-${P}"
+ MAVEN_ID="net.imglib2:imglib2:6.2.0"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+# jmh-core: According to the pom version 1.36 is required,
+# however, jmh-core-1.35 is latest available in Gentoo
+BDEPEND="
+ >=virtual/jdk-1.8:*
+ test? (
+ >=dev-java/jama-1.0.3
+ >=dev-java/junit-4.13.2
+ >=dev-java/jmh-core-1.35
+ )
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_MAIN_CLASS=""
+
+JAVA_TEST_GENTOO_CLASSPATH="jama,junit-4,jmh-core"
+JAVA_TEST_SRC_DIR="src/test/java"
diff --git a/media-libs/imglib2/imglib2-9999.ebuild b/media-libs/imglib2/imglib2-9999.ebuild
new file mode 100644
index 000000000..d024676c7
--- /dev/null
+++ b/media-libs/imglib2/imglib2-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A multidimensional, type-agnostic image processing library."
+HOMEPAGE="
+ http://imglib2.net/
+ https://github.com/imglib/imglib2
+"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/imglib/imglib2.git"
+ S="${WORKDIR}/${P}"
+ MAVEN_ID="net.imglib2:imglib2:9999"
+else
+ SRC_URI="
+ https://github.com/imglib/${PN}/archive/refs/tags/${P}.tar.gz -> ${P}-sources.tar.gz
+ "
+ S="${WORKDIR}/${PN}-${P}"
+ MAVEN_ID="net.imglib2:imglib2:6.2.0"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+# jmh-core: According to the pom version 1.36 is required,
+# however, jmh-core-1.35 is latest available in Gentoo
+BDEPEND="
+ >=virtual/jdk-1.8:*
+ test? (
+ >=dev-java/jama-1.0.3
+ >=dev-java/junit-4.13.2
+ >=dev-java/jmh-core-1.35
+ )
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_MAIN_CLASS=""
+
+JAVA_TEST_GENTOO_CLASSPATH="jama,junit-4,jmh-core"
+JAVA_TEST_SRC_DIR="src/test/java"
diff --git a/media-libs/imglib2/metadata.xml b/media-libs/imglib2/metadata.xml
new file mode 100644
index 000000000..b5cf3918a
--- /dev/null
+++ b/media-libs/imglib2/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ ImgLib2 is a general-purpose, multidimensional image processing library.
+
+ It provides an interface-driven design that supports numeric and non-numeric data types (8-bit unsigned integer, 32-bit floating point, etc.) in an extensible way. It implements several data sources and sample organizations, including one single primitive array, one array per plane, N-dimensional array “cells” cached to and from disk on demand, and planes read on demand from disk.
+ </longdescription>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">imglib/imglib2</remote-id>
+ </upstream>
+</pkgmetadata>