aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-06-10 16:17:36 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-06-10 16:17:36 +0000
commit080e6060acf339b5905835405d56bf4daa1fc128 (patch)
treeab9df3f1d0f6fb5a4e4cb70437f01e18901d457e
parentadded maxima-5.9.3-r1 (diff)
downloadsci-080e6060acf339b5905835405d56bf4daa1fc128.tar.gz
sci-080e6060acf339b5905835405d56bf4daa1fc128.tar.bz2
sci-080e6060acf339b5905835405d56bf4daa1fc128.zip
added imaxima-0.94b
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@237 32389bae-6d03-0410-99cf-db05cde120eb
-rw-r--r--app-emacs/imaxima/ChangeLog27
-rw-r--r--app-emacs/imaxima/Manifest5
-rw-r--r--app-emacs/imaxima/files/50imaxima-gentoo.el4
-rw-r--r--app-emacs/imaxima/files/digest-imaxima-0.94b1
-rw-r--r--app-emacs/imaxima/imaxima-0.94b.ebuild36
-rw-r--r--app-emacs/imaxima/metadata.xml14
6 files changed, 87 insertions, 0 deletions
diff --git a/app-emacs/imaxima/ChangeLog b/app-emacs/imaxima/ChangeLog
new file mode 100644
index 000000000..aeb87e4f8
--- /dev/null
+++ b/app-emacs/imaxima/ChangeLog
@@ -0,0 +1,27 @@
+# ChangeLog for app-emacs/imaxima
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*imaxima-0.94b (10 Jun 2006)
+
+ 10 Jun 2006; Sebastien Fabbro <seb@ist.utl.pt> +metadata.xml,
+ +imaxima-0.94b.ebuild: version bump + added longdescription in
+ metadata.xml. Tested on amd64 as well. Closing #101186 and #135592.
+ Thanks to Sebastian Schubert <sebastian-schubert@gmx.de> and others.
+
+ 24 Aug 2005; Matthew Kennedy <mkennedy@gentoo.org> imaxima-0.9.ebuild:
+ Removing ~amd64.
+
+ 01 Jul 2005; Matthew Kennedy <mkennedy@gentoo.org> imaxima-0.9.ebuild:
+ Keywording ~amd64
+
+ 28 Nov 2004; Joseph Jezak <josejx@gentoo.org> imaxima-0.9.ebuild:
+ Marked ~ppc for bug #72351.
+
+*imaxima-0.9 (09 Oct 2004)
+
+ 09 Oct 2004; Mamoru KOMACHI <usata@gentoo.org> +metadata.xml,
+ +files/50imaxima-gentoo.el, +imaxima-0.9.ebuild:
+ Initial import. Ebuild submitted by Cliff Yapp <smustudent1@yahoo.com> and
+ P.L.Hayes <paul@wolfbone.ath.cx>, closing bug #60148.
+
diff --git a/app-emacs/imaxima/Manifest b/app-emacs/imaxima/Manifest
new file mode 100644
index 000000000..8b421a6dc
--- /dev/null
+++ b/app-emacs/imaxima/Manifest
@@ -0,0 +1,5 @@
+MD5 947303a9b913f81d27e5619997cb2f63 ChangeLog 983
+MD5 c3378a9a497e3336d5ecd3cd23505cfa files/50imaxima-gentoo.el 104
+MD5 1619c9103232f6fc0366eae8a28a3821 files/digest-imaxima-0.94b 71
+MD5 9f2c8b49c058da08cbfe656a011f9a95 imaxima-0.94b.ebuild 918
+MD5 6f641f776579f790a0bb18f3b3ccbd80 metadata.xml 688
diff --git a/app-emacs/imaxima/files/50imaxima-gentoo.el b/app-emacs/imaxima/files/50imaxima-gentoo.el
new file mode 100644
index 000000000..9b45317f8
--- /dev/null
+++ b/app-emacs/imaxima/files/50imaxima-gentoo.el
@@ -0,0 +1,4 @@
+
+;; imaxima Gentoo site-lisp configuration
+
+(autoload 'imaxima "imaxima" "Image support for Maxima." t)
diff --git a/app-emacs/imaxima/files/digest-imaxima-0.94b b/app-emacs/imaxima/files/digest-imaxima-0.94b
new file mode 100644
index 000000000..397faf3b1
--- /dev/null
+++ b/app-emacs/imaxima/files/digest-imaxima-0.94b
@@ -0,0 +1 @@
+MD5 2e958a1d222d0face607358032c60352 imaxima-imath-0.94b.tar.gz 167668
diff --git a/app-emacs/imaxima/imaxima-0.94b.ebuild b/app-emacs/imaxima/imaxima-0.94b.ebuild
new file mode 100644
index 000000000..f03d20091
--- /dev/null
+++ b/app-emacs/imaxima/imaxima-0.94b.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit elisp
+
+MY_P="${PN}-imath-${PV}"
+DESCRIPTION="Imaxima enables graphical output in Maxima sessions with emacs"
+HOMEPAGE="http://members3.jcom.home.ne.jp/imaxima/Site/Welcome.html"
+SRC_URI="http://members3.jcom.home.ne.jp/imaxima/Site/Download%20and%20Install_files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+DEPEND="virtual/emacs
+ virtual/tetex
+ virtual/ghostscript
+ || (>=dev-tex/breqn-0.94 app-text/texlive)
+ >=sci-mathematics/maxima-5.9.1"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ elisp-site-file-install ${FILESDIR}/50imaxima-gentoo.el
+ dodoc ChangeLog NEWS README
+ docinto imath-example
+ dodoc imath-example/*.txt
+}
diff --git a/app-emacs/imaxima/metadata.xml b/app-emacs/imaxima/metadata.xml
new file mode 100644
index 000000000..2dda3ab4e
--- /dev/null
+++ b/app-emacs/imaxima/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+ <longdescription lang="en">
+ Imaxima.el provides support for interacting with the computer
+ algebra system Maxima in an Emacs buffer. Imaxima processes the
+ output from Maxima with TeX and inserts the resulting image in the
+ buffer. The command imaxima provides a simple comint derived CLI mode. The
+ command imaxima-latex prepares a LaTeX version of the Maxima
+ buffer. Imaxima can also be hooked in to the Emacs mode included with
+ Maxima, which provides more key bindings and other conveniences.
+ </longdescription>
+</pkgmetadata>