aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-01-03 11:33:05 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2017-01-03 11:33:05 +0100
commit0b3ba056ced20ead3a07563291e0b0dc227787ae (patch)
tree5eecc012ae6b5f877f1466feab925cbe66c7d0e3
parentdev-python/nbformat: Bump to EAPI=6, fix deps and testing (diff)
downloadsci-0b3ba056.tar.gz
sci-0b3ba056.tar.bz2
sci-0b3ba056.zip
dev-python/nbdime: Update live ebuild according to 0.1.0
Package-Manager: portage-2.3.0
-rw-r--r--dev-python/nbdime/metadata.xml12
-rw-r--r--dev-python/nbdime/nbdime-9999.ebuild28
2 files changed, 33 insertions, 7 deletions
diff --git a/dev-python/nbdime/metadata.xml b/dev-python/nbdime/metadata.xml
index 979d02bd0..b2a229dc3 100644
--- a/dev-python/nbdime/metadata.xml
+++ b/dev-python/nbdime/metadata.xml
@@ -1,14 +1,24 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
<maintainer type="project">
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
<longdescription>
- nbdime contains tools for diffing and merging of Jupyter Notebooks.
+ nbdime provides tools for diffing and merging of Jupyter Notebooks.
</longdescription>
<upstream>
<remote-id type="github">jupyter/nbdime</remote-id>
+ <remote-id type="pypi">nbdime</remote-id>
</upstream>
+ <use>
+ <flag name="webtools">
+ Install web-based diff and merge tools.
+ </flag>
+</use>
</pkgmetadata>
diff --git a/dev-python/nbdime/nbdime-9999.ebuild b/dev-python/nbdime/nbdime-9999.ebuild
index 8be6e65d3..96bf5325b 100644
--- a/dev-python/nbdime/nbdime-9999.ebuild
+++ b/dev-python/nbdime/nbdime-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -14,25 +14,41 @@ EGIT_REPO_URI="https://github.com/jupyter/${PN}.git"
LICENSE="BSD"
SLOT="0"
-IUSE="test"
+IUSE="test webtools"
RDEPEND="
dev-python/nbformat[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ webtools? ( net-libs/nodejs[npm] )
"
DEPEND="${RDEPEND}
test? (
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
)
"
-# Some additional packages (e.g. commonmark, recommonmark) are required to build the docs
+# The package recommonmark is required to build the docs, not in portage yet.
# Furthermore, backports.shutil_which is required for python2_7.
+python_configure_all() {
+ if ! use webtools; then
+ mydistutilsargs=( --skip-npm )
+ fi
+}
+
python_test() {
+ # user.email and user.name are not configured in the sandbox.
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+
distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- cp -r "${S}/${PN}"/tests "${TEST_DIR}"/lib/ || die
+
py.test -l || die
}