aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-10-02 15:55:22 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-10-02 15:55:22 +0000
commit1da2c5c0b390c9c7b71fd5e948a2243cfbf0c1b3 (patch)
tree74b087b829bdc139c91c0f4c803da5303d873911
parentdev-cpp/Fastor: high performance tensor algebra framework (diff)
downloadsci-1da2c5c0.tar.gz
sci-1da2c5c0.tar.bz2
sci-1da2c5c0.zip
sci-mathematics/acl2: version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--sci-mathematics/acl2/Manifest3
-rw-r--r--sci-mathematics/acl2/acl2-8.3.ebuild51
-rw-r--r--sci-mathematics/acl2/metadata.xml14
3 files changed, 59 insertions, 9 deletions
diff --git a/sci-mathematics/acl2/Manifest b/sci-mathematics/acl2/Manifest
index 1444f00a9..4ca40a4ee 100644
--- a/sci-mathematics/acl2/Manifest
+++ b/sci-mathematics/acl2/Manifest
@@ -1 +1,2 @@
-DIST acl2-7.1.tar.gz 63345284 SHA256 1a8503095a4e1deb6a6b0f3bc51823ba65cad38466def8d6845f193d73338f9d SHA512 5875b88615930fc841cd1d7ed30ada7c04b241a391eeee22184b4e3630e57cc6304a51e445e33ca1284576c2b4110c269f9eb59c47bd2eb47659134450151e27 WHIRLPOOL 632012e3d8998c67f70cd19b8fa7c7ff8000dbdba2d87dfdd56d5b4b39ebb390503d243e051c308c8a5aea0097bb48fa4e5c510b24478886a4a8bfca2c8d0645
+DIST acl2-7.1.tar.gz 63346203 BLAKE2B 00d6c9668e1bd89bc15533fc1cf22514094f48e29bb8ab4df1e7c4ca3c969739899ad3580e3ad2c22fba1c69aef468b29044033578aaa739155e10b0a5e2f3d4 SHA512 5de9a83636d9a280e3cf17503a3dd3ef534e5303cc80e2b10492ea53f2acbfd50270674ac02e70bb86c14071fb9179ae61d692283f3bd6dd255adfe220fa45fe
+DIST acl2-8.3.tar.gz 116808616 BLAKE2B 77bba8c91231c2ae6ebae34ceeec9939101862156bfda4be2a0e3389f51cfdc183004d9cb3b27511a7494a9ead8ced5016f648a1712ab468c781dd8f8feca822 SHA512 92b59d1b31ce8d980bf043d02d4ee6ae36c69b3c2cc7be106e4d8f46e660a813e42f6e41a0903159ce65e9332dccb770cbd69472602889724f8ba724bfa301e2
diff --git a/sci-mathematics/acl2/acl2-8.3.ebuild b/sci-mathematics/acl2/acl2-8.3.ebuild
new file mode 100644
index 000000000..a360cd404
--- /dev/null
+++ b/sci-mathematics/acl2/acl2-8.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Industrial strength theorem prover"
+HOMEPAGE="http://www.cs.utexas.edu/users/moore/acl2/"
+MY_PN=${PN}-devel
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/releases/download/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="books"
+
+BDEPEND="dev-lisp/sbcl"
+DEPEND="
+ dev-lisp/sbcl:=
+ books? ( dev-lang/perl )
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake LISP="sbcl --noinform --noprint \
+ --no-sysinit --no-userinit --disable-debugger"
+
+ if use books; then
+ echo
+ einfo "Building certificates ..."
+ einfo "(this may take hours to finish)"
+ emake certify-books
+ fi
+}
+
+src_install() {
+ SAVED_NAME=saved_acl2
+ sed -e "s:${S}:/usr/share/acl2:g" -i ${SAVED_NAME} || die
+ if use books; then
+ sed -e "/5/a export ACL2_SYSTEM_BOOKS=/usr/share/acl2/books/" \
+ -i ${SAVED_NAME} || die
+ fi
+ dobin ${SAVED_NAME}
+
+ insinto /usr/share/acl2
+ doins TAGS ${SAVED_NAME}.core
+ if use books; then
+ doins -r books
+ fi
+}
diff --git a/sci-mathematics/acl2/metadata.xml b/sci-mathematics/acl2/metadata.xml
index b77817aa3..6035ff684 100644
--- a/sci-mathematics/acl2/metadata.xml
+++ b/sci-mathematics/acl2/metadata.xml
@@ -11,15 +11,13 @@
<name>Gentoo Mathematics Project</name>
</maintainer>
<longdescription>
-ACL2 is both a programming language in which you can model computer systems and
-a tool to help you prove properties of those models. ACL2 is part of the
-Boyer-Moore family of provers, for which its authors have received the 2005 ACM
-Software System Award.
-</longdescription>
+ ACL2 is both a programming language in which you can model computer systems and
+ a tool to help you prove properties of those models. ACL2 is part of the
+ Boyer-Moore family of provers, for which its authors have received the 2005 ACM
+ Software System Award.
+ </longdescription>
<use>
- <flag name="books">
-build community books, the canonical collection of open-source libraries
-</flag>
+ <flag name="books">build community books, the canonical collection of open-source libraries</flag>
</use>
<upstream>
<remote-id type="github">acl2-devel/acl2-devel</remote-id>