aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-01-30 22:23:22 -0500
committerHorea Christian <chr@chymera.eu>2023-01-30 22:23:22 -0500
commit207a85724b6526e0f3be017a8a953412fcdcf597 (patch)
tree81130fe59dabb64f3b680e2b5e12043224bf1686
parentdev-python/pynwb: drop 2.0.1-r1 (diff)
downloadsci-207a8572.tar.gz
sci-207a8572.tar.bz2
sci-207a8572.zip
dev-python/hdbscan: new package, add 0.8.26, 0.8.29
Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--dev-python/hdbscan/Manifest2
-rw-r--r--dev-python/hdbscan/hdbscan-0.8.26.ebuild33
-rw-r--r--dev-python/hdbscan/hdbscan-0.8.29.ebuild33
-rw-r--r--dev-python/hdbscan/metadata.xml28
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/hdbscan/Manifest b/dev-python/hdbscan/Manifest
new file mode 100644
index 000000000..b162353da
--- /dev/null
+++ b/dev-python/hdbscan/Manifest
@@ -0,0 +1,2 @@
+DIST hdbscan-0.8.26.tar.gz 10776639 BLAKE2B 7f1cb7b479746e3ff262cce90d48cca42dccabc131a60300ae5448455260eb27387ab2eeeee19257930ee646d06df80fa2997cf1819da18178c5522a8a27a30c SHA512 7337f4246511d22e8e11308e7776aad6929f26674daecc1e174b01673782837815a40820a6565406315b1ae14ed059c4945810ac997abfde9e24abda352de622
+DIST hdbscan-0.8.29.tar.gz 11666106 BLAKE2B de324386d7d2178f74ea958fa75e5eccb9dcdeba3d85cecce1150930e2d687caecbc79469de6ad62806c5bd860962bba57f27323c69f3abc6b0d4694a553656d SHA512 fd349c1c6c09f0288a9a2501eb7794fb03139c11261a835d90f1c9cd80955a4d8d075ff3864ddb9cfcbc204a3d0662011074bdb29b66b72d5469f76bc4f7ecca
diff --git a/dev-python/hdbscan/hdbscan-0.8.26.ebuild b/dev-python/hdbscan/hdbscan-0.8.26.ebuild
new file mode 100644
index 000000000..91e83eb87
--- /dev/null
+++ b/dev-python/hdbscan/hdbscan-0.8.26.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A high performance implementation of HDBSCAN clustering."
+HOMEPAGE="https://github.com/scikit-learn-contrib/hdbscan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test"
+# Tests fail, reported to upstream
+# https://github.com/scikit-learn-contrib/hdbscan/issues/501
+
+DEPEND=""
+RDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+"
+BDEPEND=""
+
+distutils_enable_tests pytest
diff --git a/dev-python/hdbscan/hdbscan-0.8.29.ebuild b/dev-python/hdbscan/hdbscan-0.8.29.ebuild
new file mode 100644
index 000000000..85d049d4c
--- /dev/null
+++ b/dev-python/hdbscan/hdbscan-0.8.29.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A high performance implementation of HDBSCAN clustering."
+HOMEPAGE="https://github.com/scikit-learn-contrib/hdbscan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# Reported upstream:
+# https://github.com/scikit-learn-contrib/hdbscan/issues/501
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+"
+BDEPEND=""
+
+distutils_enable_tests pytest
diff --git a/dev-python/hdbscan/metadata.xml b/dev-python/hdbscan/metadata.xml
new file mode 100644
index 000000000..b43e627e0
--- /dev/null
+++ b/dev-python/hdbscan/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ HDBSCAN - Hierarchical Density-Based Spatial Clustering of Applications with
+ Noise. Performs DBSCAN over varying epsilon values and integrates the result
+ to find a clustering that gives the best stability over epsilon. This allows
+ HDBSCAN to find clusters of varying densities (unlike DBSCAN), and be more
+ robust to parameter selection.
+
+ In practice this means that HDBSCAN returns a good clustering straight away
+ with little or no parameter tuning -- and the primary parameter, minimum
+ cluster size, is intuitive and easy to select. HDBSCAN is ideal for
+ exploratory data analysis; it's a fast and robust algorithm that you can
+ trust to return meaningful clusters (if there are any).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">scikit-learn-contrib/hdbscan</remote-id>
+ </upstream>
+</pkgmetadata>