aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2018-10-25 01:27:27 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2018-10-25 01:27:27 +0300
commit243e204391a21eb4520f069be98359de9ecac556 (patch)
tree758b17ef3e7ce011659aa7abf5ed72acc35a7278
parentsci-chemistry/gamess: remove old (diff)
downloadsci-243e2043.tar.gz
sci-243e2043.tar.bz2
sci-243e2043.zip
sci-chemistry/gamess: add memory check for USE=msucc
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--sci-chemistry/gamess/gamess-20180930.3.ebuild14
-rw-r--r--sci-chemistry/gamess/metadata.xml2
2 files changed, 14 insertions, 2 deletions
diff --git a/sci-chemistry/gamess/gamess-20180930.3.ebuild b/sci-chemistry/gamess/gamess-20180930.3.ebuild
index ce3b8eba8..fe96a626b 100644
--- a/sci-chemistry/gamess/gamess-20180930.3.ebuild
+++ b/sci-chemistry/gamess/gamess-20180930.3.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit fortran-2 flag-o-matic pax-utils toolchain-funcs
+inherit check-reqs fortran-2 flag-o-matic pax-utils toolchain-funcs
DESCRIPTION="A powerful quantum chemistry package"
HOMEPAGE="http://www.msg.chem.iastate.edu/GAMESS/GAMESS.html"
@@ -40,6 +40,17 @@ RESTRICT="fetch"
GAMESS_DOWNLOAD="http://www.msg.ameslab.gov/GAMESS/License_Agreement.html"
GAMESS_VERSION="September 30, 2018 R3"
+pre_build_checks() {
+ if use msucc; then
+ CHECKREQS_MEMORY=6G
+ check-reqs_pkg_setup
+ fi
+}
+
+pkg_pretend() {
+ pre_build_checks
+}
+
pkg_nofetch() {
echo
elog "Please download ${PN}-current.tar.gz from"
@@ -66,6 +77,7 @@ get_fcomp() {
}
pkg_setup() {
+ pre_build_checks
fortran-2_pkg_setup
get_fcomp
# currently amd64 is only supported with gfortran
diff --git a/sci-chemistry/gamess/metadata.xml b/sci-chemistry/gamess/metadata.xml
index 7c7fbea32..7f7e33d86 100644
--- a/sci-chemistry/gamess/metadata.xml
+++ b/sci-chemistry/gamess/metadata.xml
@@ -11,7 +11,7 @@
</maintainer>
<use>
<flag name="msucc">Build Michigan State University CCT3 and CCSD3A methods.
- This will increase build time and memory requirements by multiple times</flag>
+ This will increase build time and memory requirements by ~10 times</flag>
<flag name="neo">Enable NEO for nuclear basis support</flag>
<flag name="pax_kernel">Make this package work on PAX kernels</flag>
<flag name="qmmm-tinker">Enable tinker qmmm code</flag>