aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-16 22:11:53 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-16 22:11:53 +0100
commit3607f3c51c1cd6852abf539e72a8d18b429f6f8d (patch)
treeffac12e65c41fe4f4466fcf461facf7d4162f614
parentprofiles/package.mask: unmask freefem++, fixed (diff)
downloadsci-3607f3c51c1cd6852abf539e72a8d18b429f6f8d.tar.gz
sci-3607f3c51c1cd6852abf539e72a8d18b429f6f8d.tar.bz2
sci-3607f3c51c1cd6852abf539e72a8d18b429f6f8d.zip
sci-mathematics/lattE-macchiato: fix fetch, fix patch
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-mathematics/lattE-macchiato/files/buildpackages.patch4
-rw-r--r--sci-mathematics/lattE-macchiato/lattE-macchiato-0.9.3.ebuild32
2 files changed, 24 insertions, 12 deletions
diff --git a/sci-mathematics/lattE-macchiato/files/buildpackages.patch b/sci-mathematics/lattE-macchiato/files/buildpackages.patch
index f35a0fe75..48f9ba30d 100644
--- a/sci-mathematics/lattE-macchiato/files/buildpackages.patch
+++ b/sci-mathematics/lattE-macchiato/files/buildpackages.patch
@@ -1,5 +1,5 @@
---- ../latte-for-tea-too-1.2-mk-0.9.3/Makefile.am 2008-12-17 22:56:12.000000000 +0100
-+++ Makefile.am 2010-02-05 23:43:42.000000000 +0100
+--- a/Makefile.am 2008-12-17 22:56:12.000000000 +0100
++++ b/Makefile.am 2010-02-05 23:43:42.000000000 +0100
@@ -6,29 +6,7 @@
## Distribution variables.
diff --git a/sci-mathematics/lattE-macchiato/lattE-macchiato-0.9.3.ebuild b/sci-mathematics/lattE-macchiato/lattE-macchiato-0.9.3.ebuild
index 2b0505090..6ac9227f1 100644
--- a/sci-mathematics/lattE-macchiato/lattE-macchiato-0.9.3.ebuild
+++ b/sci-mathematics/lattE-macchiato/lattE-macchiato-0.9.3.ebuild
@@ -1,19 +1,22 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools eutils flag-o-matic
+inherit autotools flag-o-matic
DESCRIPTION="lattE-macchiato consists of tools for lattice point enumeration"
-HOMEPAGE="http://www.math.ucdavis.edu/~mkoeppe/latte/"
-SRC_URI="http://www.math.ucdavis.edu/~mkoeppe/latte/download/latte-for-tea-too-1.2-mk-0.9.3.tar.gz"
-# mirror://gentoo/${P}-src.tar.bz2
+HOMEPAGE="https://www.math.ucdavis.edu/~mkoeppe/latte/"
+#SRC_URI="https://www.math.ucdavis.edu/~mkoeppe/latte/download/latte-for-tea-too-1.2-mk-${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="latte-for-tea-too-1.2-mk-${PV}.tar.gz"
+# ERROR: cannot verify www.math.ucdavis.edu's certificate, issued by ‘CN=InCommon RSA Server CA,OU=InCommon,O=Internet2,L=Ann Arbor,ST=MI,C=US’:
+# Unable to locally verify the issuer's authority.
+# To connect to www.math.ucdavis.edu insecurely, use `--no-check-certificate'.
+RESTRICT="fetch"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
+KEYWORDS=""
DEPEND="
dev-libs/gmp:0=[cxx]
@@ -24,14 +27,23 @@ DEPEND="
>=sci-libs/cddlib-094f"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/latte-for-tea-too-1.2-mk-0.9.3"
+S="${WORKDIR}/latte-for-tea-too-1.2-mk-${PV}"
# For now LattE builds an internal version of Lidia.
# This will not be split off for now because it is heavily patched
# and based on a version that was not even released.
+PATCHES=(
+ "${FILESDIR}/buildpackages.patch"
+)
+
+pkg_nofetch() {
+ einfo "Please download: https://www.math.ucdavis.edu/~mkoeppe/latte/download/latte-for-tea-too-1.2-mk-${PV}.tar.gz"
+ einfo "and place it in your DISTDIR"
+}
+
src_prepare() {
- epatch "${FILESDIR}/buildpackages.patch"
+ default
eautoreconf
}