aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-12-02 23:52:44 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-12-02 23:52:44 +0100
commit38ef4fac3f1c8bfb5044571b268200a0a1488969 (patch)
tree51fe15361f8da34b81965b73ee41ef53130005ac
parentsci-biology/freebayes: note the many bundled deps we need to unbundle (diff)
downloadsci-38ef4fac.tar.gz
sci-38ef4fac.tar.bz2
sci-38ef4fac.zip
dev-perl/Bio-EnsEMBL: new package to provide EnsEMBL Perl API
This is needed by sci-biology/ensembl-tools, do not miss the official installation procedure at http://www.ensembl.org/info/docs/api/api_installation.html Package-Manager: portage-2.3.2
-rw-r--r--dev-perl/Bio-EnsEMBL/Bio-EnsEMBL-9999.ebuild35
-rw-r--r--dev-perl/Bio-EnsEMBL/Manifest1
-rw-r--r--dev-perl/Bio-EnsEMBL/metadata.xml12
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/Bio-EnsEMBL/Bio-EnsEMBL-9999.ebuild b/dev-perl/Bio-EnsEMBL/Bio-EnsEMBL-9999.ebuild
new file mode 100644
index 000000000..73e3a472e
--- /dev/null
+++ b/dev-perl/Bio-EnsEMBL/Bio-EnsEMBL-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MODULE_AUTHOR=""
+inherit perl-module
+
+DESCRIPTION="EnsEMBL Perl API aka ensembl-api exposing Bio::EnsEMBL::Registry"
+SRC_URI="ftp://ftp.ensembl.org/pub/ensembl-api.tar.gz"
+
+#LICENSE="|| ( Artistic GPL-1+ )"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_install(){
+ perl_set_version
+ insinto "${VENDOR_LIB}" # do not add "${PN}" so the the PERL path starts with Bio/
+ find . -name t | xargs rm -rf || die
+ find . -name test.pl | xargs rm -f || die
+ find . -name \*.example | xargs rm -f || die
+ find . -name \*.json | xargs rm -f || die
+ find . -name README* | xargs rm -rf || die
+ find . -name \*.conf | xargs rm -f || die
+ find . -name travisci | xargs rm -rf || die
+ find . -name sql | xargs rm -rf || die
+ find . -name modules | while read d; do pushd "$d"; doins -r *; popd; done || die
+}
diff --git a/dev-perl/Bio-EnsEMBL/Manifest b/dev-perl/Bio-EnsEMBL/Manifest
new file mode 100644
index 000000000..f3381f7c3
--- /dev/null
+++ b/dev-perl/Bio-EnsEMBL/Manifest
@@ -0,0 +1 @@
+DIST ensembl-api.tar.gz 58306750 SHA256 ca6361fd065f5a993e0c12a1fa76ddbd4a52e81db3a65c2a04e9049981392e08 SHA512 1a49175a631fced82a212cde5345c8c8d62d5aef474ae79b074a9a8c5931f4cf513f5dfc34172a6313d3899d86521a12b65aa592214b91075a55a8a44364be27 WHIRLPOOL cd4c56809fd8b57898b58bea03b5dbe011a5082b2a61f45b6dc59a81c42bc2e91b02554da3d8b3b30769a3ab2b4303f8deace1828c2ca008c2d5cb7b2a118366
diff --git a/dev-perl/Bio-EnsEMBL/metadata.xml b/dev-perl/Bio-EnsEMBL/metadata.xml
new file mode 100644
index 000000000..f68a1b6fa
--- /dev/null
+++ b/dev-perl/Bio-EnsEMBL/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+</pkgmetadata>