aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-09-02 09:33:34 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-09-02 09:33:34 +0200
commit3e0475874cc0b549f6fd77bb62d02370d5f635eb (patch)
tree094919a0d2eae7ebd1b78923663cf08796d313fd
parentdev-python/notebook: Bring back 4.0.1 (diff)
parentdev-python/ipython: remove mathjax references (diff)
downloadsci-3e047587.tar.gz
sci-3e047587.tar.bz2
sci-3e047587.zip
Merge branch 'flacjacket-notebook'
-rw-r--r--dev-python/ipython/ChangeLog3
-rw-r--r--dev-python/ipython/ipython-4.0.0-r1.ebuild2
-rw-r--r--dev-python/notebook/ChangeLog3
-rw-r--r--dev-python/notebook/notebook-9999.ebuild16
4 files changed, 22 insertions, 2 deletions
diff --git a/dev-python/ipython/ChangeLog b/dev-python/ipython/ChangeLog
index dbdd93f80..66d2f0a92 100644
--- a/dev-python/ipython/ChangeLog
+++ b/dev-python/ipython/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 01 Sep 2015; Sean Vig <sean.v.775@gmail.com>
+ dev-python/ipython: remove mathjax references
+
*ipython-4.0.0-r1 (01 Sep 2015)
01 Sep 2015; Marius Brehler <marbre@linux.sungazer.de>
diff --git a/dev-python/ipython/ipython-4.0.0-r1.ebuild b/dev-python/ipython/ipython-4.0.0-r1.ebuild
index b8d08adca..8b905053b 100644
--- a/dev-python/ipython/ipython-4.0.0-r1.ebuild
+++ b/dev-python/ipython/ipython-4.0.0-r1.ebuild
@@ -102,8 +102,6 @@ python_test() {
python_install() {
distutils-r1_python_install
- use notebook && \
- ln -sf "${EPREFIX}/usr/share/mathjax" "${D}$(python_get_sitedir)/IPython/html/static/mathjax"
# Create ipythonX.Y symlinks.
# TODO:
diff --git a/dev-python/notebook/ChangeLog b/dev-python/notebook/ChangeLog
index de63caf0f..a3cad1057 100644
--- a/dev-python/notebook/ChangeLog
+++ b/dev-python/notebook/ChangeLog
@@ -7,6 +7,9 @@
01 Sep 2015; Marius Brehler <marbre@linux.sungazer.de> +notebook-4.0.1.ebuild:
dev-python/notebook: Bring back 4.0.1
+ 01 Sep 2015; Sean Vig <sean.v.775@gmail.com> notebook-9999.ebuild:
+ dev-python/notebook: Use system mathjax
+
*notebook-4.0.4 (01 Sep 2015)
01 Sep 2015; Marius Brehler <marbre@linux.sungazer.de> +notebook-4.0.4.ebuild,
diff --git a/dev-python/notebook/notebook-9999.ebuild b/dev-python/notebook/notebook-9999.ebuild
index 7f6336a0a..5a07e9092 100644
--- a/dev-python/notebook/notebook-9999.ebuild
+++ b/dev-python/notebook/notebook-9999.ebuild
@@ -24,6 +24,7 @@ IUSE="doc test"
CDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${CDEPEND}
+ dev-libs/mathjax
dev-python/jinja[${PYTHON_USEDEP}]
>=dev-python/terminado-0.3.3[${PYTHON_USEDEP}]
>=www-servers/tornado-4.0[${PYTHON_USEDEP}]
@@ -37,6 +38,7 @@ RDEPEND="${CDEPEND}
"
DEPEND="${RDEPEND}
test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
>=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
@@ -46,6 +48,20 @@ DEPEND="${RDEPEND}
)
"
+python_prepare_all() {
+ # disable bundled mathjax
+ sed -i 's/^.*MathJax.*$//' bower.json || die
+ sed -i 's/mj(/#mj(/' setupbase.py || die
+
+ distutils-r1_python_prepare_all
+}
+
python_test() {
nosetests --with-coverage --cover-package=notebook notebook || die
}
+
+python_install() {
+ distutils-r1_python_install
+
+ ln -sf "${EPREFIX}/usr/share/mathjax" "${D}$(python_get_sitedir)/notebook/static/components/MathJax" || die
+}