aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-02-03 11:22:24 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-02-03 12:02:34 +0800
commit435cdfbb48bf8efd38cb3198230758bd599aeac3 (patch)
tree8192e115a10f184d9975f887a69701341e3e0b4b
parentsci-biology/fsl: version bump 6.0.2 (diff)
downloadsci-435cdfbb.tar.gz
sci-435cdfbb.tar.bz2
sci-435cdfbb.zip
sci-biology/amos: remove from tree.
1. No upstream development since 2011. 2. Does not support Python 3. Bug: https://bugs.gentoo.org/707558 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--sci-biology/amos/Manifest1
-rw-r--r--sci-biology/amos/amos-3.1.0-r2.ebuild76
-rw-r--r--sci-biology/amos/amos-9999.ebuild76
-rw-r--r--sci-biology/amos/files/amos-3.1.0-gcc-4.7.patch15
-rw-r--r--sci-biology/amos/files/amos-3.1.0-goBambus2.py-indent-and-cleanup.patch25
-rw-r--r--sci-biology/amos/files/amos-3.1.0-rename_to_jellyfish1.patch43
-rw-r--r--sci-biology/amos/files/amos-9999-fix-include-paths.patch13
-rw-r--r--sci-biology/amos/metadata.xml21
8 files changed, 0 insertions, 270 deletions
diff --git a/sci-biology/amos/Manifest b/sci-biology/amos/Manifest
deleted file mode 100644
index f7c93a72f..000000000
--- a/sci-biology/amos/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST amos-3.1.0.tar.gz 2094268 BLAKE2B b9fb80d4e7b7e9e7769081c2680a3cba26591f00a4d9fdb17ad602e581dea5e8e2add4b0d9d3821a7f8a4ec1a45dfd867037baf35ecd401584f030c86b2b0f83 SHA512 7a416b9a0438b47425355383b709491a58f38c8d834df29e43c942170e710c6ea7e3bc8c509a58421b1340ad6eece9ea2da357ce5cd1d41ce08375676ee30491
diff --git a/sci-biology/amos/amos-3.1.0-r2.ebuild b/sci-biology/amos/amos-3.1.0-r2.ebuild
deleted file mode 100644
index 951f12c1b..000000000
--- a/sci-biology/amos/amos-3.1.0-r2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-inherit eutils python-r1
-
-PERL_EXPORT_PHASE_FUNCTIONS=no
-inherit perl-module eutils toolchain-funcs
-
-DESCRIPTION="Whole genome assembler, Hawkeye and AMOScmp to compare multiple assemblies"
-HOMEPAGE="http://amos.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="mpi qt5"
-
-DEPEND="
- mpi? ( virtual/mpi )
- dev-libs/boost
- qt5? ( dev-qt/qtcore:5 )
- sci-biology/blat
- sci-biology/jellyfish:1"
-RDEPEND="${DEPEND}
- dev-lang/perl
- dev-perl/DBI
- dev-perl/Statistics-Descriptive
- sci-biology/mummer"
-
-MAKEOPTS+=" -j1"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gcc-4.7.patch \
- "${FILESDIR}"/${P}-goBambus2.py-indent-and-cleanup.patch \
- "${FILESDIR}"/${P}-rename_to_jellyfish1.patch
- # $ gap-links
- # ERROR: Could not open file LIBGUESTFS_PATH=/usr/share/guestfs/appliance/
- # $
- sh ./bootstrap || die
- default
- eautoreconf
- # prevent GCC 6 log pollution due to hash_map deprecation in C++11
- # shutdown gcc-8.2.0 messages too
- append-cxxflags -Wno-cpp -Wno-narrowing
-}
-
-src_configure() {
- local myconf
- use X && myconf+=( --with-x )
- econf ${myconf[@]} --with-jellyfish="${EPREFIX}"/usr/include --with-Boost-dir="${EPREFIX}"/usr/include --with-qmake-qt4=qmake --enable-all
-}
-
-src_install() {
- default
- python_replicate_script "${ED}"/usr/bin/goBambus2
- # bambus needs TIGR::FASTAreader.pm and others
- # configure --libdir sadly copies both *.a files and *.pm into /usr/lib64/AMOS/ and /usr/lib64/TIGR/, work around it
- perl_set_version
- insinto ${VENDOR_LIB}/AMOS
- doins "${D}"/usr/lib64/AMOS/*.pm
- insinto ${VENDOR_LIB}/TIGR
- doins "${D}"/usr/lib64/TIGR/*.pm
- # move also /usr/lib64/AMOS/AMOS.py to /usr/bin
- mv "${D}"/usr/lib64/AMOS/*.py "${D}"/usr/bin || die
- # zap the mis-placed files ('make install' is at fault)
- rm -f "${D}"/usr/lib64/AMOS/*.pm
- rm -rf "${D}"/usr/lib64/TIGR
- echo AMOSCONF="${EPREFIX}"/etc/amos.acf > "${S}"/99amos || die
- mkdir -p "${ED}"/etc || die
- touch "${ED}"/etc/amos.acf || die
- doenvd "${S}/99amos"
-}
diff --git a/sci-biology/amos/amos-9999.ebuild b/sci-biology/amos/amos-9999.ebuild
deleted file mode 100644
index 923ac5978..000000000
--- a/sci-biology/amos/amos-9999.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-PERL_EXPORT_PHASE_FUNCTIONS=no
-inherit perl-module eutils toolchain-funcs autotools flag-o-matic python-single-r1 qmake-utils
-
-AUTOTOOLS_AUTORECONF=true
-inherit autotools-utils git-r3
-
-DESCRIPTION="Whole genome assembler, Hawkeye and AMOScmp to compare multiple assemblies"
-HOMEPAGE="http://sourceforge.net/projects/amos"
-SRC_URI=""
-EGIT_REPO_URI="git://amos.git.sourceforge.net/gitroot/amos/amos"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS=""
-IUSE="mpi qt5 X"
-
-DEPEND="
- mpi? ( virtual/mpi )
- dev-libs/boost
- qt5? ( dev-qt/qtcore:5 )
- sci-biology/blat
- sci-biology/jellyfish:1"
-RDEPEND="${DEPEND}
- dev-perl/DBI
- dev-perl/Statistics-Descriptive
- sci-biology/mummer"
-
-# $ gap-links
-# ERROR: Could not open file LIBGUESTFS_PATH=/usr/share/guestfs/appliance/
-# $
-
-src_prepare() {
- epatch "${FILESDIR}"/"${P}"-fix-include-paths.patch
- epatch "${FILESDIR}"/amos-3.1.0-rename_to_jellyfish1.patch
- sh ./bootstrap || die
- default
- eautoreconf
-
- # prevent GCC 6 log pollution due to hash_map deprecation in C++11
- # shutdown gcc-8.2.0 messages too
- append-cxxflags -Wno-cpp -Wno-narrowing
-}
-
-src_configure() {
- local myconf
- use X && myconf+=( --with-x )
- econf ${myconf[@]} --with-jellyfish="${EPREFIX}"/usr/include --with-Boost-dir="${EPREFIX}"/usr/include --with-qmake-qt4=qmake --enable-all
-}
-
-src_install() {
- default
- python_replicate_script "${ED}"/usr/bin/goBambus2
- # bambus needs TIGR::FASTAreader.pm and others
- # configure --libdir sadly copies both *.a files and *.pm into /usr/lib64/AMOS/ and /usr/lib64/TIGR/, work around it
- perl_set_version
- insinto ${VENDOR_LIB}/AMOS
- doins "${D}"/usr/lib64/AMOS/*.pm
- insinto ${VENDOR_LIB}/TIGR
- doins "${D}"/usr/lib64/TIGR/*.pm
- # move also /usr/lib64/AMOS/AMOS.py to /usr/bin
- mv "${D}"/usr/lib64/AMOS/*.py "${D}"/usr/bin || die
- # zap the mis-placed files ('make install' is at fault)
- rm -f "${D}"/usr/lib64/AMOS/*.pm
- rm -rf "${D}"/usr/lib64/TIGR
- echo AMOSCONF="${EPREFIX}"/etc/amos.acf > "${S}"/99amos || die
- mkdir -p "${ED}"/etc || die
- touch "${ED}"/etc/amos.acf || die
- doenvd "${S}/99amos"
-}
diff --git a/sci-biology/amos/files/amos-3.1.0-gcc-4.7.patch b/sci-biology/amos/files/amos-3.1.0-gcc-4.7.patch
deleted file mode 100644
index de2a41184..000000000
--- a/sci-biology/amos/files/amos-3.1.0-gcc-4.7.patch
+++ /dev/null
@@ -1,15 +0,0 @@
- src/Align/find-tandem.cc | 1 +
- 1 files changed, 1 insertions(+), 0 deletions(-)
-
-diff --git a/src/Align/find-tandem.cc b/src/Align/find-tandem.cc
-index ddf1cab..a29e21e 100644
---- a/src/Align/find-tandem.cc
-+++ b/src/Align/find-tandem.cc
-@@ -7,6 +7,7 @@
- #include <vector>
- #include <ctime>
- #include <sys/time.h>
-+#include <unistd.h>
- using namespace std;
-
- const int OFFSET_TABLE_SIZE = 100;
diff --git a/sci-biology/amos/files/amos-3.1.0-goBambus2.py-indent-and-cleanup.patch b/sci-biology/amos/files/amos-3.1.0-goBambus2.py-indent-and-cleanup.patch
deleted file mode 100644
index 97a8f59d0..000000000
--- a/sci-biology/amos/files/amos-3.1.0-goBambus2.py-indent-and-cleanup.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- amos-3.1.0/src/Pipeline/goBambus2.py.orig 2013-09-11 01:05:29.850090457 +0200
-+++ amos-3.1.0/src/Pipeline/goBambus2.py 2013-09-11 01:07:03.250090701 +0200
-@@ -1,7 +1,7 @@
- #pipeline script for assembly + Bambus 2
- #contributed by Todd J Treangen
-
--import string, sys, os, subprocess#, spincursor
-+import sys, os, subprocess#, spincursor
-
- RED = "\033[0;31m"
- GREEN = "\033[0;32m"
-@@ -360,7 +360,7 @@
- print "\t\t%s...failed%s"%(RED,NONE)
- sys.exit(1)
-
-- p = subprocess.Popen(AMOSDIR+"OutputResults -b %s -prefix %s %s"%(amosbank, prefix+".scaff.linear"), shell=True, stdin=subprocess.PIPE, stdout=vtext, stderr=logfile)
-+ p = subprocess.Popen(AMOSDIR+"OutputResults -b %s -prefix %s %s"%(amosbank, prefix+".scaff.linear"), shell=True, stdin=subprocess.PIPE, stdout=vtext, stderr=logfile)
-
- if xopt_dict["verbose"] == 1:
- print "10) running OutputResults"
-@@ -388,4 +388,3 @@
- else:
- print "\t\t%s...failed%s"%(RED,NONE)
- sys.exit(1)
--)
diff --git a/sci-biology/amos/files/amos-3.1.0-rename_to_jellyfish1.patch b/sci-biology/amos/files/amos-3.1.0-rename_to_jellyfish1.patch
deleted file mode 100644
index 4b52c5640..000000000
--- a/sci-biology/amos/files/amos-3.1.0-rename_to_jellyfish1.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- config/amos.m4 2018-09-11 13:23:14.478444129 +0200
-+++ config/amos.m4 2018-09-11 13:36:36.697612245 +0200
-@@ -695,15 +695,15 @@
- else
- jellyfish_unspecified=no
- fi
--if ! test -f "$jellyfish_dir/jellyfish/mer_counting.hpp"; then
-+if ! test -f "$jellyfish_dir/jellyfish1/mer_counting.hpp"; then
- if test $jellyfish_unspecified = no; then
-- AC_MSG_ERROR([Could not find the file "$jellyfish_dir/jellyfish/compacted_hash.hpp"])
-+ AC_MSG_ERROR([Could not find the file "$jellyfish_dir/jellyfish1/compacted_hash.hpp"])
- fi
- JELLYFISH_LDADD=
- JELLYFISH_CPPFLAGS=
- AC_MSG_RESULT([not found])
- else
-- JELLYFISH_LDADD="-ljellyfish -lpthread"
-+ JELLYFISH_LDADD="-ljellyfish-1.1 -lpthread"
- JELLYFISH_CPPFLAGS="-I $jellyfish_dir"
- AC_DEFINE([WITH_JELLYFISH], [1], [Define to 1 if using Jellyfish])
- cppflags_save="$CPPFLAGS"
-@@ -715,7 +715,7 @@
- AC_LANG_PUSH([C++])
- AC_LINK_IFELSE([
- AC_LANG_PROGRAM([
--#include <jellyfish/mer_counting.hpp>
-+#include <jellyfish1/mer_counting.hpp>
- #include <string>
- ], [
- std::string s;
---- src/Align/kmer-cov-plot.cc 2018-09-11 13:23:15.079443556 +0200
-+++ src/Align/kmer-cov-plot.cc 2018-09-11 13:36:36.831612096 +0200
-@@ -388,8 +388,8 @@
-
- #ifdef WITH_JELLYFISH
-
--#include <jellyfish/compacted_hash.hpp>
--#include <jellyfish/mer_counting.hpp>
-+#include <jellyfish1/compacted_hash.hpp>
-+#include <jellyfish1/mer_counting.hpp>
-
- // Assert that jellyfish is using the expected kmer representation
- static void jellyfish_check()
diff --git a/sci-biology/amos/files/amos-9999-fix-include-paths.patch b/sci-biology/amos/files/amos-9999-fix-include-paths.patch
deleted file mode 100644
index a6e8dc9f0..000000000
--- a/sci-biology/amos/files/amos-9999-fix-include-paths.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/Bambus/Bundler/Makefile.am.old 2018-07-03 12:52:17.306095693 +0200
-+++ src/Bambus/Bundler/Makefile.am 2018-07-03 12:52:19.506101530 +0200
-@@ -78,8 +78,8 @@
- ##-- libBundler.a
- libBundler_a_CPPFLAGS = \
- $(BOOST_CXXFLAGS) \
-- -I$(top_builddir)/src/GNU \
-- -I$(top_builddir)/src/AMOS
-+ -I$(top_srcdir)/src/GNU \
-+ -I$(top_srcdir)/src/AMOS
- ## because some system headers will be built if necessary
- libBundler_a_LIBADD = \
- $(LIBOBJS:%=$(top_builddir)/src/GNU/%) \
diff --git a/sci-biology/amos/metadata.xml b/sci-biology/amos/metadata.xml
deleted file mode 100644
index ddba4784f..000000000
--- a/sci-biology/amos/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>mmokrejs@fold.natur.cuni.cz</email>
- <name>Martin Mokrejs</name>
- </maintainer>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
- <longdescription>
-AMOS is collection of tools and class interfaces for the assembly of DNA
-sequencing reads. The package includes a robust infrastructure, modular assembly
-pipelines, and tools for overlapping, consensus generation, contigging, and
-assembly manipulation
-</longdescription>
- <upstream>
- <remote-id type="sourceforge">amos</remote-id>
- </upstream>
-</pkgmetadata>