aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-06-25 14:21:16 +0200
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-06-25 14:21:16 +0200
commit44863d23a814e72b31f589ad412f35a024282766 (patch)
tree9c26b58ba5142007119c0d948ba07b97cfe3c7f6
parentsci-biology/salmon: drop calls to curl, fix libdir (diff)
downloadsci-44863d23a814e72b31f589ad412f35a024282766.tar.gz
sci-44863d23a814e72b31f589ad412f35a024282766.tar.bz2
sci-44863d23a814e72b31f589ad412f35a024282766.zip
sci-biology/salmon: bring -9999 in sync with 0.10.2.ebuild
The -9999 won't work as the SRC_URI section is not respected, hence is commented out. Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--sci-biology/salmon/files/salmon-9999-no-boost-static.patch18
-rw-r--r--sci-biology/salmon/salmon-9999.ebuild30
2 files changed, 10 insertions, 38 deletions
diff --git a/sci-biology/salmon/files/salmon-9999-no-boost-static.patch b/sci-biology/salmon/files/salmon-9999-no-boost-static.patch
deleted file mode 100644
index 1a9665251..000000000
--- a/sci-biology/salmon/files/salmon-9999-no-boost-static.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- salmon-9999/CMakeLists.txt 2018-06-25 10:51:47.179712781 +0200
-+++ salmon-9999/CMakeLists.txt 2018-06-25 10:52:47.951289159 +0200
-@@ -213,15 +213,6 @@
- set (CMAKE_LIBRARY_PATH ${CUSTOM_BOOST_PATH}/lib ${CMAKE_LIBRARY_PATH})
- endif ( DEFINED CUSTOM_BOOST_PATH )
-
--##
--# We want static, multithreaded boost libraries
--##
--if(CONDA_BUILD)
-- set (Boost_USE_STATIC_LIBS OFF)
--else ()
-- set (Boost_USE_STATIC_LIBS ON)
--endif(CONDA_BUILD)
--
- set (Boost_USE_MULTITHREADED ON)
- #set (Boost_USE_STATIC_RUNTIME OFF)
-
diff --git a/sci-biology/salmon/salmon-9999.ebuild b/sci-biology/salmon/salmon-9999.ebuild
index b5e748fd2..221418960 100644
--- a/sci-biology/salmon/salmon-9999.ebuild
+++ b/sci-biology/salmon/salmon-9999.ebuild
@@ -8,14 +8,21 @@ inherit multilib cmake-utils git-r3
DESCRIPTION="Transcript-level quantification from RNA-seq reads using lightweight alignments"
HOMEPAGE="https://github.com/COMBINE-lab/salmon"
EGIT_REPO_URI="https://github.com/COMBINE-lab/salmon.git"
-# SRC_URI="https://github.com/COMBINE-lab/RapMap/archive/salmon-v0.10.2.zip -> ${PN}-0.10.2_RapMap.zip"
+#SRC_URI="https://github.com/COMBINE-lab/RapMap/archive/salmon-v0.10.2.zip -> ${P}_RapMap.zip
+# https://github.com/USCiLab/cereal/archive/v1.2.2.tar.gz -> cereal-1.2.2.tar.gz
+# https://github.com/COMBINE-lab/bwa/archive/v0.7.12.5.tar.gz -> bwa-0.7.12.5.tar.gz
+# https://github.com/COMBINE-lab/libgff/archive/v1.1.tar.gz -> libgff-1.1.tgz
+# https://github.com/COMBINE-lab/staden-io_lib/archive/v1.14.8.1.tar.gz -> staden-io_lib-1.14.8.tar.gz
+# https://github.com/COMBINE-lab/spdlog/archive/v0.16.1.tar.gz -> spdlog-0.16.1.tar.gz"
LICENSE="GPL-3"
SLOT="0"
IUSE=""
-PATCHES=( "${FILESDIR}"/${P}-no-boost-static.patch
- "${FILESDIR}"/salmon-0.10.2_remove_curl_call.patch )
+PATCHES=( "${FILESDIR}"/salmon-0.10.2-no-boost-static.patch
+ "${FILESDIR}"/salmon-0.10.2_remove_curl_call.patch
+ "${FILESDIR}"/salmon-0.10.2_remove_curl_calls.patch
+ "${FILESDIR}"/salmon-0.10.2_fix_lib_dir.patch )
# budled copies of:
# sci-biology/bwa-0.7.12.5
@@ -57,20 +64,3 @@ RDEPEND="${DEPEND}"
# see the many curl executions:
# salmon-0.10.2$ find . -type f | xargs grep curl 2>/dev/null
-#
-src_configure(){
- local mycmakeargs=(
- "-DBOOST_INCLUDEDIR=${EPREFIX}/usr/include/boost/"
- "-DBOOST_LIBRARYDIR=${EPREFIX}/usr/$(get_libdir)/"
- "-DTBB_INSTALL_DIR=${EPREFIX}/usr"
- "-DCMAKE_INSTALL_PREFIX=${EPREFIX}/usr"
- )
- # BUG: the configure step runs automatically curl download of 3rd-party stuff
- # https://github.com/COMBINE-lab/salmon/issues/19
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- rm -rf "${ED}"/usr/tests || die
-}