aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-30 15:54:01 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-30 15:54:01 +0100
commit4b1645fe18182c7a4311be24baffc31ad0947f7d (patch)
tree49954a9d4b9e4e42fcc2c22aad520f809ea4cdb2
parentsci-libs/lapacke-reference: Version Bump (diff)
downloadsci-4b1645fe.tar.gz
sci-4b1645fe.tar.bz2
sci-4b1645fe.zip
Update to new cmake-utils API
Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-libs/simclist/simclist-1.6.ebuild2
-rw-r--r--media-libs/OpenMOIV/OpenMOIV-1.0.3a.ebuild2
-rw-r--r--sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild8
-rw-r--r--sci-chemistry/votca-csg/votca-csg-9999.ebuild4
-rw-r--r--sci-libs/gmsh/gmsh-2.8.5.ebuild2
-rw-r--r--sci-libs/parmetis/parmetis-4.0.3.ebuild6
-rw-r--r--sci-libs/scalapack/scalapack-2.0.2-r1.ebuild6
-rw-r--r--sci-libs/tmglib/tmglib-3.5.0.ebuild6
-rw-r--r--sci-libs/tmglib/tmglib-3.6.0.ebuild6
-rw-r--r--sci-libs/votca-tools/votca-tools-9999.ebuild2
10 files changed, 22 insertions, 22 deletions
diff --git a/dev-libs/simclist/simclist-1.6.ebuild b/dev-libs/simclist/simclist-1.6.ebuild
index 058dbd742..bea18ba9d 100644
--- a/dev-libs/simclist/simclist-1.6.ebuild
+++ b/dev-libs/simclist/simclist-1.6.ebuild
@@ -30,7 +30,7 @@ src_compile(){
src_install() {
mkdir -p "${D}"/usr/include
cp simclist.h "${D}"/usr/include/
- cd "${CMAKE_BUILD_DIR}"
+ cd "${BUILD_DIR}"
dolib libsimclist.so
cd "${S}"
if use doc; then
diff --git a/media-libs/OpenMOIV/OpenMOIV-1.0.3a.ebuild b/media-libs/OpenMOIV/OpenMOIV-1.0.3a.ebuild
index af43459d7..e543bfe35 100644
--- a/media-libs/OpenMOIV/OpenMOIV-1.0.3a.ebuild
+++ b/media-libs/OpenMOIV/OpenMOIV-1.0.3a.ebuild
@@ -31,7 +31,7 @@ src_configure() {
src_install() {
insinto "/usr/$(get_libdir)"
- doins "${CMAKE_BUILD_DIR}/libChemKit2.so"
+ doins "${BUILD_DIR}/libChemKit2.so"
insinto "/usr/include"
doins -r "${S}/include/ChemKit2"
diff --git a/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild b/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
index 0a0fee043..e61d4729d 100644
--- a/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
+++ b/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
@@ -46,18 +46,18 @@ src_compile() {
}
src_test() {
- mkdir "${CMAKE_BUILD_DIR}/$(get_libdir)/Chemistry"
+ mkdir "${BUILD_DIR}/$(get_libdir)/Chemistry"
cp \
"${CMAKE_USE_DIR}/scripts/perl/OpenBabel.pm" \
- "${CMAKE_BUILD_DIR}/$(get_libdir)/Chemistry/"
+ "${BUILD_DIR}/$(get_libdir)/Chemistry/"
for i in "${CMAKE_USE_DIR}"/scripts/perl/t/*
do
einfo "Running test: ${i}"
- perl -I"${CMAKE_BUILD_DIR}/$(get_libdir)" "${i}" || die
+ perl -I"${BUILD_DIR}/$(get_libdir)" "${i}" || die
done
}
src_install() {
- cd "${CMAKE_BUILD_DIR}"
+ cd "${BUILD_DIR}"
cmake -DCOMPONENT=bindings_perl -P cmake_install.cmake
}
diff --git a/sci-chemistry/votca-csg/votca-csg-9999.ebuild b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
index 0a099b440..25892d72d 100644
--- a/sci-chemistry/votca-csg/votca-csg-9999.ebuild
+++ b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
@@ -94,8 +94,8 @@ src_install() {
else
dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
fi
- cmake-utils_src_make -C "${CMAKE_BUILD_DIR}" html
- dohtml -r "${CMAKE_BUILD_DIR}"/share/doc/html/*
+ cmake-utils_src_make -C "${BUILD_DIR}" html
+ dohtml -r "${BUILD_DIR}"/share/doc/html/*
fi
if use examples; then
insinto "/usr/share/doc/${PF}/tutorials"
diff --git a/sci-libs/gmsh/gmsh-2.8.5.ebuild b/sci-libs/gmsh/gmsh-2.8.5.ebuild
index 368a4e8cf..879a68791 100644
--- a/sci-libs/gmsh/gmsh-2.8.5.ebuild
+++ b/sci-libs/gmsh/gmsh-2.8.5.ebuild
@@ -78,7 +78,7 @@ src_install() {
# TODO: tutorials get installed twice ATM
if use doc ; then
- cd "${CMAKE_BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
emake pdf
cd "${S}" || die
dodoc doc/texinfo/gmsh.pdf
diff --git a/sci-libs/parmetis/parmetis-4.0.3.ebuild b/sci-libs/parmetis/parmetis-4.0.3.ebuild
index b9bc9d256..60c218697 100644
--- a/sci-libs/parmetis/parmetis-4.0.3.ebuild
+++ b/sci-libs/parmetis/parmetis-4.0.3.ebuild
@@ -83,19 +83,19 @@ src_configure() {
parmetis_configure -DSHARED=ON
use static-libs && \
sed -i -e '/fPIC/d' metis/GKlib/GKlibSystem.cmake && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" parmetis_configure
+ BUILD_DIR="${WORKDIR}/${PN}_static" parmetis_configure
}
src_compile() {
cmake-utils_src_compile
use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_compile
+ BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_compile
}
src_install() {
cmake-utils_src_install
use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_install
+ BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_install
insinto /usr/include
doins metis/include/metis.h
diff --git a/sci-libs/scalapack/scalapack-2.0.2-r1.ebuild b/sci-libs/scalapack/scalapack-2.0.2-r1.ebuild
index 711975eed..283176b73 100644
--- a/sci-libs/scalapack/scalapack-2.0.2-r1.ebuild
+++ b/sci-libs/scalapack/scalapack-2.0.2-r1.ebuild
@@ -46,20 +46,20 @@ src_configure() {
scalapack_configure -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=OFF
use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" scalapack_configure \
+ BUILD_DIR="${WORKDIR}/${PN}_static" scalapack_configure \
-DBUILD_SHARED_LIBS=OFF -DBUILD_STATIC_LIBS=ON
}
src_compile() {
cmake-utils_src_compile
use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_compile
+ BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_compile
}
src_install() {
cmake-utils_src_install
use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_install
+ BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_install
insinto /usr/include/blacs
doins BLACS/SRC/*.h
diff --git a/sci-libs/tmglib/tmglib-3.5.0.ebuild b/sci-libs/tmglib/tmglib-3.5.0.ebuild
index 36512bdf7..3548eb7c2 100644
--- a/sci-libs/tmglib/tmglib-3.5.0.ebuild
+++ b/sci-libs/tmglib/tmglib-3.5.0.ebuild
@@ -49,18 +49,18 @@ src_configure() {
tmg_configure -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=OFF
use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" tmg_configure \
+ BUILD_DIR="${WORKDIR}/${PN}_static" tmg_configure \
-DBUILD_SHARED_LIBS=OFF -DBUILD_STATIC_LIBS=ON
}
src_compile() {
cmake-utils_src_compile -C TESTING/MATGEN
- use static-libs && CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" \
+ use static-libs && BUILD_DIR="${WORKDIR}/${PN}_static" \
cmake-utils_src_compile -C TESTING/MATGEN
}
src_install() {
cmake-utils_src_install -C TESTING/MATGEN
- use static-libs && CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" \
+ use static-libs && BUILD_DIR="${WORKDIR}/${PN}_static" \
cmake-utils_src_install -C TESTING/MATGEN
}
diff --git a/sci-libs/tmglib/tmglib-3.6.0.ebuild b/sci-libs/tmglib/tmglib-3.6.0.ebuild
index 4f66f4503..f403c5370 100644
--- a/sci-libs/tmglib/tmglib-3.6.0.ebuild
+++ b/sci-libs/tmglib/tmglib-3.6.0.ebuild
@@ -49,18 +49,18 @@ src_configure() {
tmg_configure -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=OFF
use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" tmg_configure \
+ BUILD_DIR="${WORKDIR}/${PN}_static" tmg_configure \
-DBUILD_SHARED_LIBS=OFF -DBUILD_STATIC_LIBS=ON
}
src_compile() {
cmake-utils_src_compile -C TESTING/MATGEN
- use static-libs && CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" \
+ use static-libs && BUILD_DIR="${WORKDIR}/${PN}_static" \
cmake-utils_src_compile -C TESTING/MATGEN
}
src_install() {
cmake-utils_src_install -C TESTING/MATGEN
use static-libs \
- && CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_install -C TESTING/MATGEN
+ && BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_install -C TESTING/MATGEN
}
diff --git a/sci-libs/votca-tools/votca-tools-9999.ebuild b/sci-libs/votca-tools/votca-tools-9999.ebuild
index 4dae0bfce..6a9b5be67 100644
--- a/sci-libs/votca-tools/votca-tools-9999.ebuild
+++ b/sci-libs/votca-tools/votca-tools-9999.ebuild
@@ -53,7 +53,7 @@ src_configure() {
src_install() {
cmake-utils_src_install
if use doc; then
- cd "${CMAKE_BUILD_DIR}"
+ cd "${BUILD_DIR}"
cmake-utils_src_make html
dohtml -r share/doc/html/*
fi