aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Mitrak <lucas@lucasmitrak.com>2021-05-30 18:47:25 -0400
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-01 11:30:25 +0200
commit4b888966f7c6ff0d86ba8b1802457d946c747bb3 (patch)
tree2cfb33a5d2936e3861aefe1eaecf0abdb855e4fe
parentsci-libs/fox: DEPEND of fortran USE flag for gcc (diff)
downloadsci-4b888966.tar.gz
sci-4b888966.tar.bz2
sci-4b888966.zip
sci-libs/fox: add inherit fortran-2
Currently, sci-libs/fox does not require a fortran compiler to be installed. If sci-libs/fox is emerged without the fortran compiler, the configure phase will check for a fortran compiler, and the configure phase will fail. For example, the hardened profile disables the fortran USE flag in sys-devel/gcc, so sci-libs/fox will fail. With this commit, sci-libs/fox will require a fortran compiler to be installed. Without this commit, sci-libs/fox will fail on any system which does not have the fortran compiler, which by default is all hardened profiles. This commit was tested in a docker image with dev-util/ebuildtester. This commit was written, tested, and submitted by Lucas Mitrak. Closes: https://bugs.gentoo.org/757771 Signed-off-by: Lucas Mitrak <lucas@lucasmitrak.com> Closes: https://github.com/gentoo/sci/pull/1083 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-libs/fox/fox-4.1.2-r2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sci-libs/fox/fox-4.1.2-r2.ebuild b/sci-libs/fox/fox-4.1.2-r2.ebuild
index 9b216657f..a8900c153 100644
--- a/sci-libs/fox/fox-4.1.2-r2.ebuild
+++ b/sci-libs/fox/fox-4.1.2-r2.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit fortran-2
+
MY_PN="FoX"
MY_P="${MY_PN}-${PV}"
@@ -28,8 +30,6 @@ S="${WORKDIR}/${MY_P}"
FORTRAN_STANDARD=90
-DEPEND="sys-devel/gcc[fortran]"
-
PATCHES=(
"${FILESDIR}"/4.1.2-r2-install-customizations.patch
)