aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-04-01 17:04:25 +0200
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-04-01 17:04:25 +0200
commit4efdba16fdc718fde4b8679fb805cb382df46fef (patch)
treec0d4a7d0e42bfa6aa282a8dc5a6f6718a85a1ab5
parentsci-biology/augustus: update file checksum (diff)
downloadsci-4efdba16.tar.gz
sci-4efdba16.tar.bz2
sci-4efdba16.zip
sci-biology/seq_crumbs: new package
The fix to setup.py to respect DESTDIR is probably not ideal. Needs a fix to avoid file collisions. Package-Manager: Portage-2.3.27, Repoman-2.3.9
-rw-r--r--sci-biology/seq_crumbs/Manifest1
-rw-r--r--sci-biology/seq_crumbs/metadata.xml12
-rw-r--r--sci-biology/seq_crumbs/seq_crumbs-0.1.9.ebuild46
3 files changed, 59 insertions, 0 deletions
diff --git a/sci-biology/seq_crumbs/Manifest b/sci-biology/seq_crumbs/Manifest
new file mode 100644
index 000000000..192c5b2f4
--- /dev/null
+++ b/sci-biology/seq_crumbs/Manifest
@@ -0,0 +1 @@
+DIST v0.1.9.tar.gz 2172379 BLAKE2B 121055a96181b5a94ef847965f4cf4be9b5e429765981d733781eb454f2f539577decf2be6923496cd8da5e8a4e3dd5cca630dbb742b940091bd0d67e0ed41d6 SHA512 075be693ce712e9b5bd6e72b02a5a0822ace9ee0363696f8fca6d07f266c99c81b5d9d099db3ad5f70548b5a98e4f2d85cc6cd4dc2fd7c06dece6c6e50d287d5
diff --git a/sci-biology/seq_crumbs/metadata.xml b/sci-biology/seq_crumbs/metadata.xml
new file mode 100644
index 000000000..f68a1b6fa
--- /dev/null
+++ b/sci-biology/seq_crumbs/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-biology/seq_crumbs/seq_crumbs-0.1.9.ebuild b/sci-biology/seq_crumbs/seq_crumbs-0.1.9.ebuild
new file mode 100644
index 000000000..94ce00a94
--- /dev/null
+++ b/sci-biology/seq_crumbs/seq_crumbs-0.1.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Filter, split and trim NGS sequence data"
+HOMEPAGE="https://github.com/JoseBlanca/seq_crumbs"
+SRC_URI="https://github.com/JoseBlanca/"${PN}"/archive/v"${PV}".tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ >=sci-biology/biopython-1.60
+ >=sci-biology/pysam-0.8
+ >=dev-python/rpy-2
+ dev-python/matplotlib
+ dev-python/configobj
+ dev-python/toolz"
+RDEPEND="${DEPEND}"
+
+# TODO fix file collisions
+# * Detected file collision(s):
+# *
+# * /usr/share/man/man1/index.1.bz2
+# * /usr/share/man/man1/install.1.bz2
+# *
+# * Searching all installed packages for file collisions...
+# *
+# * Press Ctrl-C to Stop
+# *
+# * sys-apps/coreutils-8.29:0::gentoo
+# * /usr/share/man/man1/install.1.bz2
+# *
+# * media-libs/netpbm-10.76.00:0::gentoo
+# * /usr/share/man/man1/index.1.bz2
+src_prepare(){
+ sed -e "s#sys.prefix#os.getenv('ED')+'/usr/'#" -i setup.py || die
+ default
+}