aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-03 12:21:33 +0200
committerJustin Lecher <jlec@gentoo.org>2015-06-03 12:21:33 +0200
commit4f355a29f7b7f9e40bfb8935bc16754d7db4c310 (patch)
tree409c6004532635d537c5ebfbb593d4973ad3c23f
parentClean CATs (diff)
parentsci-libs/arrayfire: Fetch tarball instead of getting src from git (diff)
downloadsci-4f355a29.tar.gz
sci-4f355a29.tar.bz2
sci-4f355a29.zip
Merge remote-tracking branch 'github/master'
* github/master: sci-libs/arrayfire: Fetch tarball instead of getting src from git sci-libs/matc: Version bump sci-libs/matc: Source moved from sf.net to github; Fix LICENSE dev-python/matplotlib2tikz: New ebuild written by me dev-python/meshpy: Version bump; Implement python_test() sci-libs/elmer-eio: Update Manifest, fixes Bug #548398 dev-python/newrelic: Version bump dev-python/pickleshare: Initial ebuild (required for >dev-python/ipython-3.1.0) dev-python/pyfftw: Copy missing data in python_test() phase dev-python/pyfftw: Implement python_test() dev-python/ptyprocess: Minor fix
-rw-r--r--dev-python/matplotlib2tikz/ChangeLog10
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
l---------dev-python/matplotlib2tikz/matplotlib2tikz-0.1.0.ebuild1
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-9999.ebuild30
-rw-r--r--dev-python/matplotlib2tikz/metadata.xml9
-rw-r--r--dev-python/meshpy/ChangeLog7
-rw-r--r--dev-python/meshpy/Manifest1
-rw-r--r--dev-python/meshpy/meshpy-2014.1.ebuild46
-rw-r--r--dev-python/newrelic/ChangeLog6
-rw-r--r--dev-python/newrelic/Manifest1
-rw-r--r--dev-python/newrelic/newrelic-2.50.0.39.ebuild40
-rw-r--r--dev-python/pickleshare/ChangeLog10
-rw-r--r--dev-python/pickleshare/Manifest1
-rw-r--r--dev-python/pickleshare/metadata.xml14
l---------dev-python/pickleshare/pickleshare-0.5.ebuild1
-rw-r--r--dev-python/pickleshare/pickleshare-9999.ebuild39
-rw-r--r--dev-python/ptyprocess/ptyprocess-9999.ebuild2
-rw-r--r--dev-python/pyfftw/ChangeLog3
-rw-r--r--dev-python/pyfftw/pyfftw-9999.ebuild9
-rw-r--r--sci-libs/arrayfire/ChangeLog4
-rw-r--r--sci-libs/arrayfire/Manifest1
-rw-r--r--sci-libs/arrayfire/arrayfire-3.0_beta.ebuild10
-rw-r--r--sci-libs/elmer-eio/Manifest2
-rw-r--r--sci-libs/matc/ChangeLog11
-rw-r--r--sci-libs/matc/Manifest5
-rw-r--r--sci-libs/matc/matc-8.0.ebuild42
-rw-r--r--sci-libs/matc/matc-9999.ebuild20
27 files changed, 301 insertions, 25 deletions
diff --git a/dev-python/matplotlib2tikz/ChangeLog b/dev-python/matplotlib2tikz/ChangeLog
new file mode 100644
index 000000000..b178e812c
--- /dev/null
+++ b/dev-python/matplotlib2tikz/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/matplotlib2tikz
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*matplotlib2tikz-0.1.0 (31 May 2015)
+*matplotlib2tikz-9999 (31 May 2015)
+
+ 31 May 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +matplotlib2tikz-0.1.0.ebuild, +matplotlib2tikz-9999.ebuild, +metadata.xml:
+ New ebuild written by me
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
new file mode 100644
index 000000000..b3bc18006
--- /dev/null
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -0,0 +1 @@
+DIST matplotlib2tikz-0.1.0.tar.gz 16369 SHA256 d1c07d8a7d5fcdba77509769f2a477a75562d6b87d1de9d50ea78ea0f1285acd SHA512 0ed25659afeeec279c0d97033b37357fa9c91d49f3547a789b1add9faa7285e73a4eec94c3cd70d1edfa7186cbad1d452256586ceb7066a8908ad2d3e73a274e WHIRLPOOL eabe83d14b1d0c362bc325e0a9b5612cd787098440df634fa4bbf828e6c5b7085ec78d00545ab9d2463e9251a3c1978b8edd866ea74ef4b1d58da251e82be0b3
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.1.0.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.1.0.ebuild
new file mode 120000
index 000000000..49bc235a9
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.1.0.ebuild
@@ -0,0 +1 @@
+matplotlib2tikz-9999.ebuild \ No newline at end of file
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-9999.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-9999.ebuild
new file mode 100644
index 000000000..6af9d49d6
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python script for converting matplotlib figures into native Pgfplots (TikZ) figures"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+
+if [ ${PV} = "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nschloe/${PN}.git git://github.com/nschloe/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/nschloe/matplotlib2tikz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-texlive/texlive-pictures"
+DEPEND="${RDEPEND}"
+ #test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
diff --git a/dev-python/matplotlib2tikz/metadata.xml b/dev-python/matplotlib2tikz/metadata.xml
new file mode 100644
index 000000000..865500b21
--- /dev/null
+++ b/dev-python/matplotlib2tikz/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/meshpy/ChangeLog b/dev-python/meshpy/ChangeLog
index 1f223ae38..084d36c0a 100644
--- a/dev-python/meshpy/ChangeLog
+++ b/dev-python/meshpy/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for dev-python/meshpy
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*meshpy-2014.1 (31 May 2015)
+
+ 31 May 2015; Marius Brehler <marbre@linux.sungazer.de> +meshpy-2014.1.ebuild:
+ Version bump; Implement python_test()
+
*meshpy-2013.1.2 (14 Jun 2013)
14 Jun 2013; Justin Lecher <jlec@gentoo.org> -meshpy-0.91.2.ebuild,
diff --git a/dev-python/meshpy/Manifest b/dev-python/meshpy/Manifest
index 62fc27c21..607e920e1 100644
--- a/dev-python/meshpy/Manifest
+++ b/dev-python/meshpy/Manifest
@@ -1 +1,2 @@
DIST MeshPy-2013.1.2.tar.gz 1885753 SHA256 425ffa0f5a7dacfc1301bbb165ff78fbe6beacb0ab6c0a8dd581f565896c6762 SHA512 6004a609fc62ff44e5770a0d041da42eea1e185def5b1efca357d4cac3dcd34a7ccb5b0ca2d2f7fb4ba81bbc0251b8c998eb64bcff828f05cfc1a0a49385b9ae WHIRLPOOL 48266e5838c6a416622fc0cc804112af1331b9d74952030e225500f8f6426c4a9679088e8f3b06dbf26169128e33e2173bae73d198e20b5ffabd02c9e7762660
+DIST MeshPy-2014.1.tar.gz 1851120 SHA256 a090729c9b99360b2741099906361b2e9ba6373b97707817c9b81f66531380b6 SHA512 d8d7823df60250382577f67bb5ffd3b6523c84729c013220eaddccfa4b227839c2e0ffb285f87e752cf0dc5292eb1e5c693d04139d2fb33a05877e0b2b1bcecc WHIRLPOOL b84442d92933c5b5745c8a91ba4f65df80a1c94fd08668d8575c154de61ce0b67605f87b638341adb3f2b43ab8d2f6c82989e9d2bfcab177dabdf0119f07ab9b
diff --git a/dev-python/meshpy/meshpy-2014.1.ebuild b/dev-python/meshpy/meshpy-2014.1.ebuild
new file mode 100644
index 000000000..9727775af
--- /dev/null
+++ b/dev-python/meshpy/meshpy-2014.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="MeshPy"
+
+DESCRIPTION="Quality triangular and tetrahedral mesh generation for Python"
+HOMEPAGE="http://mathema.tician.de/software/meshpy http://pypi.python.org/pypi/MeshPy"
+SRC_URI="mirror://pypi/M/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/boost[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ sed 's: delay = 10: delay = 1:g' -i aksetup_helper.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ mkdir "${BUILD_DIR}" || die
+ echo "BOOST_PYTHON_LIBNAME = [\'boost_${EPYTHON}-mt\']">> "${BUILD_DIR}"/siteconf.py
+ distutils-r1_python_compile
+}
+
+python_test() {
+ py.test || die
+}
diff --git a/dev-python/newrelic/ChangeLog b/dev-python/newrelic/ChangeLog
index c2eb3a987..f904df843 100644
--- a/dev-python/newrelic/ChangeLog
+++ b/dev-python/newrelic/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*newrelic-2.50.0.39 (31 May 2015)
+
+ 31 May 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +newrelic-2.50.0.39.ebuild:
+ Version bump
+
*newrelic-2.44.0.36 (03 Mar 2015)
03 Mar 2015; Marius Brehler <marbre@linux.sungazer.de> +metadata.xml,
diff --git a/dev-python/newrelic/Manifest b/dev-python/newrelic/Manifest
index eb70f7c7d..d32de2b4f 100644
--- a/dev-python/newrelic/Manifest
+++ b/dev-python/newrelic/Manifest
@@ -1 +1,2 @@
DIST newrelic-2.44.0.36.tar.gz 656605 SHA256 373d3af3e9f0c233932ddcf024f978eed3bd6ceaee9563aedb65c029f7f9b2b7 SHA512 2e9b7b6afd74c562c82813d0245822a194e151abf1e32827915b83677db811032711418ae2bd0c26b3ea4727323ca53d538862957d8cd07f7f6a2ce26630a682 WHIRLPOOL a36537b56d9e18c5143149821120296e3aae53094d9038bc0f2e4ac175820f7d6600c84d8cf17199d7a53e6dc93ef2e41885f17f2ace7de87c97a3100200149d
+DIST newrelic-2.50.0.39.tar.gz 662564 SHA256 fddd47a8d048e0c5f42eee511a8aaf35891c996d6c959553c7bec8b3ac74b3cb SHA512 935973b7897348113ab40ac4f1ea173cf31886057569a0384e4a26d96463220a43768a4dd88ac4e4a8a7db01ab4fe6fde7825860a7fbd62911ead5fc2e3f0774 WHIRLPOOL e2044913e7274703fe76368db84f2f670810653b08855e5ac067e8f009b42cb222bd8958c92a12401ac5a1630d2797f0ae77f832d85288941d56eb181efe1693
diff --git a/dev-python/newrelic/newrelic-2.50.0.39.ebuild b/dev-python/newrelic/newrelic-2.50.0.39.ebuild
new file mode 100644
index 000000000..92fd5f79a
--- /dev/null
+++ b/dev-python/newrelic/newrelic-2.50.0.39.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="newrelic"
+
+DESCRIPTION="New Relic Python Agent"
+HOMEPAGE="http://newrelic.com/docs/python/new-relic-for-python"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="newrelic"
+SLOT="0"
+
+RDEPEND="
+ || (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/cherrypy[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pylons[${PYTHON_USEDEP}]
+ dev-python/pyramid[${PYTHON_USEDEP}]
+ )"
+ #|| (
+ # dev-python/cython[${PYTHON_USEDEP}]
+ # virtual/pypy
+ # virtual/pypy3
+ #)"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ default
+ dobin scripts/newrelic-admin
+}
diff --git a/dev-python/pickleshare/ChangeLog b/dev-python/pickleshare/ChangeLog
new file mode 100644
index 000000000..1f9401c43
--- /dev/null
+++ b/dev-python/pickleshare/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pickleshare
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*pickleshare-0.5 (31 May 2015)
+*pickleshare-9999 (31 May 2015)
+
+ 31 May 2015; Marius Brehler <marbre@linux.sungazer.de> +metadata.xml,
+ +pickleshare-0.5.ebuild, +pickleshare-9999.ebuild:
+ Initial ebuild (required for >dev-python/ipython-3.1.0)
diff --git a/dev-python/pickleshare/Manifest b/dev-python/pickleshare/Manifest
new file mode 100644
index 000000000..79e862d1c
--- /dev/null
+++ b/dev-python/pickleshare/Manifest
@@ -0,0 +1 @@
+DIST pickleshare-0.5.tar.gz 4441 SHA256 c0be5745035d437dbf55a96f60b7712345b12423f7d0951bd7d8dc2141ca9286 SHA512 1021b76591b5b1d6c777e03c9544fea63602f719b786a2a2e73590f8e8275156fa69b336adf81a6e8abcaad2263eacd76ce4abf2ceff04126ff6b1ffd96cb4e3 WHIRLPOOL 07907feb8dab2dfbfc74e43d17cc076027ab450091a8dd4af197019c6c46e268eda1d5761ab22fc774e37090ab7d51212d82ba284d89018fbc0f52c38f235c62
diff --git a/dev-python/pickleshare/metadata.xml b/dev-python/pickleshare/metadata.xml
new file mode 100644
index 000000000..6cdedef5b
--- /dev/null
+++ b/dev-python/pickleshare/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ Like shelve, a PickleShareDB object acts like a normal dictionary.
+ Unlike shelve, many processes can access the database
+ simultaneously. Changing a value in database is immediately visible
+ to other processes accessing the same database.
+ Concurrency is possible because the values are stored in separate
+ files. Hence the "database" is a directory where all files are
+ governed by PickleShare.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pickleshare/pickleshare-0.5.ebuild b/dev-python/pickleshare/pickleshare-0.5.ebuild
new file mode 120000
index 000000000..16ddbe44b
--- /dev/null
+++ b/dev-python/pickleshare/pickleshare-0.5.ebuild
@@ -0,0 +1 @@
+pickleshare-9999.ebuild \ No newline at end of file
diff --git a/dev-python/pickleshare/pickleshare-9999.ebuild b/dev-python/pickleshare/pickleshare-9999.ebuild
new file mode 100644
index 000000000..5c56ccb9c
--- /dev/null
+++ b/dev-python/pickleshare/pickleshare-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A small 'shelve' like datastore with concurrency support"
+HOMEPAGE="https://github.com/pickleshare/pickleshare"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git git://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ # test_pickleshare.py is not included in the pickleshare-0.5 source
+ # we fetched from pipy
+ RESTRICT="test"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/path-py[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ cp "${S}"/test_pickleshare.py "${TEST_DIR}"/lib/ || die
+ py.test || die
+}
diff --git a/dev-python/ptyprocess/ptyprocess-9999.ebuild b/dev-python/ptyprocess/ptyprocess-9999.ebuild
index db3260e40..6d24550a5 100644
--- a/dev-python/ptyprocess/ptyprocess-9999.ebuild
+++ b/dev-python/ptyprocess/ptyprocess-9999.ebuild
@@ -11,7 +11,7 @@ inherit distutils-r1 git-r3
DESCRIPTION="Run a subprocess in a pseudo terminal"
HOMEPAGE="https://github.com/pexpect/ptyprocess"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/pexpect/${PN}.git git://github.com/pexpect/${MY_PN}.git"
+EGIT_REPO_URI="https://github.com/pexpect/${PN}.git git://github.com/pexpect/${PN}.git"
LICENSE="ISC"
SLOT="0"
diff --git a/dev-python/pyfftw/ChangeLog b/dev-python/pyfftw/ChangeLog
index 3c19f1ea4..abebe1952 100644
--- a/dev-python/pyfftw/ChangeLog
+++ b/dev-python/pyfftw/ChangeLog
@@ -1,6 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 30 May 2015; Marius Brehler <marbre@linux.sungazer.de> pyfftw-9999.ebuild:
+ Implement python_test()
+
*pyfftw-9999 (04 Feb 2015)
*pyfftw-0.9.2 (04 Feb 2015)
diff --git a/dev-python/pyfftw/pyfftw-9999.ebuild b/dev-python/pyfftw/pyfftw-9999.ebuild
index 962cf05fc..1d34389ff 100644
--- a/dev-python/pyfftw/pyfftw-9999.ebuild
+++ b/dev-python/pyfftw/pyfftw-9999.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="BSD"
SLOT="0"
+IUSE="test"
RDEPEND="
>=dev-python/numpy-1.8.0[${PYTHON_USEDEP}]
@@ -30,3 +31,11 @@ RDEPEND="
>=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ cp "${S}"/setup.py "${TEST_DIR}"/lib/ || die
+ cp -r "${S}"/test "${TEST_DIR}"/lib/ || die
+ esetup.py test || die
+}
diff --git a/sci-libs/arrayfire/ChangeLog b/sci-libs/arrayfire/ChangeLog
index 61231847c..7267d35bd 100644
--- a/sci-libs/arrayfire/ChangeLog
+++ b/sci-libs/arrayfire/ChangeLog
@@ -1,6 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 31 May 2015; Marius Brehler <marbre@linux.sungazer.de>
+ arrayfire-3.0_beta.ebuild:
+ Fetch tarball instead of getting src from git
+
23 May 2015; Marius Brehler <marbre@linux.sungazer.de>
+files/FindBoostCompute.cmake,
+files/arrayfire-3.0_beta-FindBoostCompute.patch,
diff --git a/sci-libs/arrayfire/Manifest b/sci-libs/arrayfire/Manifest
index 77f682a16..2f9794931 100644
--- a/sci-libs/arrayfire/Manifest
+++ b/sci-libs/arrayfire/Manifest
@@ -1 +1,2 @@
+DIST arrayfire-3.0_beta.tar.gz 531403 SHA256 3d80bd060b2a03e808757f7c2df3035ea357e3476a2cb69af4a3aeae826dd6af SHA512 feb6857ac65d32603739cefdd7810a0887b96cac6a3cff073aff6ff82b86b396bd94cbd60e5f4a48085813b9dd5049857e30d52d81236541f19bbcf8769db448 WHIRLPOOL 9b87a443724f7b3c77287f12debc4b268a62084895fb6196985ffd2bb184186e1eda240446c88841fe20b845169e8338832919f3cbbee0ca9d5de8e460740846
DIST gtest-1.7.0.zip 1164254 SHA256 247ca18dd83f53deb1328be17e4b1be31514cedfc1e3424f672bf11fd7e0d60d SHA512 8859369f2dd32cbc2ac01aba029aa3ff20a321f40658b9643aff442d34c33468221866b801b28c66a28af47dbcd362d26941fc98db92b6efb7e41ea5b7be1a07 WHIRLPOOL 0c31a385159551859c1afe76480b3fb1b560d666db9a0afc5cbda92bcd53bf129f85a8f902c6ded0779c2b4c49aacec59ba5a4d5ce316a07bf08174f4fc64049
diff --git a/sci-libs/arrayfire/arrayfire-3.0_beta.ebuild b/sci-libs/arrayfire/arrayfire-3.0_beta.ebuild
index 8a08c8c77..0bc42c902 100644
--- a/sci-libs/arrayfire/arrayfire-3.0_beta.ebuild
+++ b/sci-libs/arrayfire/arrayfire-3.0_beta.ebuild
@@ -4,16 +4,15 @@
EAPI=5
-inherit cmake-utils git-r3
+inherit cmake-utils
GTEST_PV="1.7.0"
DESCRIPTION="A general purpose GPU library."
HOMEPAGE="http://www.arrayfire.com/"
-EGIT_REPO_URI="https://github.com/${PN}/${PN}.git git://github.com/${PN}/${PN}.git"
-SRC_URI="test? ( https://googletest.googlecode.com/files/gtest-${GTEST_PV}.zip )"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV//_/}.tar.gz -> ${P}.tar.gz
+ test? ( https://googletest.googlecode.com/files/gtest-${GTEST_PV}.zip )"
KEYWORDS="~amd64"
-EGIT_COMMIT="v3.0beta"
LICENSE="BSD"
SLOT="0"
@@ -38,6 +37,7 @@ RDEPEND="
)"
DEPEND="${RDEPEND}"
+S="${WORKDIR}/${P//_/}"
BUILD_DIR="${S}/build"
CMAKE_BUILD_TYPE=Release
@@ -60,7 +60,7 @@ pkg_pretend() {
}
src_unpack() {
- git-r3_src_unpack
+ default
if use test; then
mkdir -p "${BUILD_DIR}"/third_party/src/ || die
diff --git a/sci-libs/elmer-eio/Manifest b/sci-libs/elmer-eio/Manifest
index 4b4383312..2fe59554f 100644
--- a/sci-libs/elmer-eio/Manifest
+++ b/sci-libs/elmer-eio/Manifest
@@ -1 +1 @@
-DIST elmer-eio-6.0_p4651.tar.gz 147064 SHA256 98979ce8f3d3ee9f0f06a1c07a9021d5ffdc7e16a739ba90724257cc21fc0c88 SHA512 744615444f131fe4a1dd789ff4197cc86d24991a21a9c04b1ea3815ca7c6346b7d211ae47bc77bf49ca2e763a5daf6b0fef3b2b1d71697ed93fbc557ca5825a7 WHIRLPOOL 207abde5b60b5527cb5ea538746a4cf7d30f76a1979f84ddad697b741dd9abb391e1ef5ceee0f461c207aec709743723fcd8846b6b76f1c09ae22ecf07eada4b
+DIST elmer-eio-6.0_p4651.tar.gz 147064 SHA256 80748e1386f03ef4b3a4c68271b1c724563a8960ffffcc36ba23e70e8519426e SHA512 52ce490810787e5100524858d41f3ad3d17ebfe5b747ea042acd8b8106028bb3aa7dd87ef80d3ce4ae2ffbf9439ad86c5f1a5f2e2c3cfb1cca5800c0fa166924 WHIRLPOOL 28837ee89756d81db5be96909f9682b1c627f31955179b668097c4d9c3efd55936a8e4c7334eda76051664dbb7043b246ad5d77a6b8950bb20f11a88ae53aa89
diff --git a/sci-libs/matc/ChangeLog b/sci-libs/matc/ChangeLog
index 37a972540..ea7705062 100644
--- a/sci-libs/matc/ChangeLog
+++ b/sci-libs/matc/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for sci-libs/matc
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*matc-8.0 (31 May 2015)
+
+ 31 May 2015; Marius Brehler <marbre@linux.sungazer.de> +matc-8.0.ebuild:
+ Version bump
+
+ 31 May 2015; Marius Brehler <marbre@linux.sungazer.de> matc-9999.ebuild:
+ Source moved from sf.net to github; Fix LICENSE
+
03 Dec 2013; Justin Lecher <jlec@gentoo.org> -matc-5.4.1.ebuild,
+matc-6.0_p4651.ebuild, matc-9999.ebuild, -files/matc-5.4.1-shared.patch,
+files/matc-6.0_p4651-shared.patch:
@@ -14,4 +22,3 @@
+metadata.xml:
Bump EAPI; fix license; fix DESCRIPTION; drop keywords from live ebuild; use
correct phase functions; simplify configure; build shared libraries
-
diff --git a/sci-libs/matc/Manifest b/sci-libs/matc/Manifest
index f4abaedf9..90b95448c 100644
--- a/sci-libs/matc/Manifest
+++ b/sci-libs/matc/Manifest
@@ -1,2 +1,3 @@
-DIST MATCManual.pdf 82222 SHA256 a32d6201021d988242e7ab193c865c1aef3e51b7c7a509978edd9360dcef7c52 SHA512 7703f05a9d23b683e9a7030fbbad0b5438de5dbfb22479a2c070e02830ef233697ea2d1f67efbdd958ada537388f1b3449dd2e73a2bd86c66338636cef0c4ea1 WHIRLPOOL 72aca6508a12cc4370e996caf60b61740ecd4aa7eab460d601cfcf5d6a0ee11a3556ef7637c85a6a747cc3d6529c5ac514f95510813720dd093054af48346893
-DIST matc-6.0_p4651.tar.gz 203543 SHA256 e49d5599231ee68f4b0e46a75d4cb2c476eab5608b881b7741aed9b125f92f8d SHA512 1675c880929031caaceb67091903ae306db30810847886fb1f56cb4c0f5e05ee4a9a11eaed8f29d3fbca4bf222268fe62ffddabc62a3b08322c362dd9ce566e0 WHIRLPOOL 73de50b2ee9cd9183b503eedc51a3cfa06eeb9e99fa3929ee610a5fc0be9a3ebb9c963553986f00e9ef9ce1f4d3ce5a17c6be9205d0eff080c4ab7240cfc0816
+DIST MATCManual.pdf 103341 SHA256 a49945c6965cdb28dfaa98f36d46813a56c7f792c4b5634d02e6afc0ae361e9c SHA512 0f9efea84ed2f6848c431b0a9647c8d300b3bcf06a83c4f6bc7cd3640ec5fc003516b442f90b022a246b3cac54f2cdac1118283e929d2c9547f5469f2b9912cb WHIRLPOOL 27eedcf4b62cedacaaa8821d87e2d2ee8a0623cf7e48f99c3310e292d0ee5a3f412546e8cbfcce34a274cf318be2b86c96af6053ff2add24c7c8569a75f670fd
+DIST matc-6.0_p4651.tar.gz 203543 SHA256 b174036ebafa2d0bff51db283831e4f9a165e6fa9798224dc3658dc2dc5e99b1 SHA512 ada3e4a1d02a0125ee5ccb7a791975d3f728d89ff21fac6461060e4458b086edb34adef058f3aa84f924f28b7d652a539d63f61d9bfce208d0b8540b812ef7be WHIRLPOOL b47b025bff1fbb88ccbabb0c42a8656c905f09ce4345c12cd83e8effb6b9c12f5cfece69741c2655fc3c60dd4e652a9867c14989d9043ae23b338815f800927a
+DIST matc-8.0.tar.gz 45051199 SHA256 ac7cb29e1dba205113ed9705a5852ee11117252495fa2b125adecd2b057c8a8f SHA512 bc34c6dbbdb2c24f2110d377e02c4515cb4886de36b30bc3caf79c9b954e5b7ba81cabedaa35fad1802287c396ab88ef074505efc904411061f7c98c9bea3497 WHIRLPOOL 99004464347f58fd388e52eb7457f2739efc3ba19fd69c328c49c2998a6131c46682417c176a39239fdb92574a4df5244b8d657e584d644fdb7c550279b8e631
diff --git a/sci-libs/matc/matc-8.0.ebuild b/sci-libs/matc/matc-8.0.ebuild
new file mode 100644
index 000000000..565962490
--- /dev/null
+++ b/sci-libs/matc/matc-8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Finite element programs, libraries, and visualization tools - math C library"
+HOMEPAGE="http://www.csc.fi/english/pages/elmer"
+SRC_URI="
+ https://github.com/ElmerCSC/elmerfem/archive/release-${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( http://www.nic.funet.fi/pub/sci/physics/elmer/doc/MATCManual.pdf )"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug static-libs"
+
+RDEPEND="
+ sys-libs/ncurses
+ sys-libs/readline:0"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/elmerfem-release-${PV}/${PN}"
+
+#PATCHES=( "${FILESDIR}"/${P}-shared.patch )
+
+src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_with debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && DOCS=( "${DISTDIR}"/MATCManual.pdf )
+ autotools-utils_src_install
+}
diff --git a/sci-libs/matc/matc-9999.ebuild b/sci-libs/matc/matc-9999.ebuild
index b787716a9..2b8aa00c6 100644
--- a/sci-libs/matc/matc-9999.ebuild
+++ b/sci-libs/matc/matc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,7 +6,7 @@ EAPI=5
AUTOTOOLS_AUTORECONF=true
-inherit autotools-utils subversion
+inherit autotools-utils git-r3
ELMER_ROOT="elmerfem"
MY_PN=${PN/elmer-/}
@@ -14,27 +14,21 @@ MY_PN=${PN/elmer-/}
DESCRIPTION="Finite element programs, libraries, and visualization tools - math C library"
HOMEPAGE="http://www.csc.fi/english/pages/elmer"
SRC_URI="doc? ( http://www.nic.funet.fi/pub/sci/physics/elmer/doc/MATCManual.pdf )"
-ESVN_REPO_URI="https://elmerfem.svn.sourceforge.net/svnroot/elmerfem/trunk/${MY_PN}"
-ESVN_PROJECT="${MY_PN}"
+EGIT_REPO_URI="https://github.com/ElmerCSC/elmerfem.git git://github.com/ElmerCSC/elmerfem.git"
-LICENSE="GPL-2"
+LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS=""
IUSE="doc debug static-libs"
RDEPEND="
sys-libs/ncurses
- sys-libs/readline"
+ sys-libs/readline:0"
DEPEND="${RDEPEND}"
-S="${WORKDIR}"/${PN}
+S="${WORKDIR}/${P}/${PN}"
-PATCHES=( "${FILESDIR}"/${PN}-6.0_p4651-shared.patch )
-
-src_prepare() {
- subversion_src_prepare
- autotools-utils_src_prepare
-}
+#PATCHES=( "${FILESDIR}"/${PN}-6.0_p4651-shared.patch )
src_configure() {
local myeconfargs=(