aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-11-15 18:59:19 +0100
committerLarry the Cow <larry@gentoo.org>2022-11-15 22:05:05 +0100
commit52d70c51717f164d07e752500cd44167a00ff437 (patch)
treef145e2248d6a6a6af11ca73bb83f28a9293675d2
parentsci-mathematics/netgen: move to media-gfx category (diff)
downloadsci-52d70c51717f164d07e752500cd44167a00ff437.tar.gz
sci-52d70c51717f164d07e752500cd44167a00ff437.tar.bz2
sci-52d70c51717f164d07e752500cd44167a00ff437.zip
net-misc/cernbox-client: add 2.11.1.8946
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Closes: https://github.com/gentoo/sci/pull/1183 Signed-off-by: Larry the Cow <larry@gentoo.org>
-rw-r--r--net-misc/cernbox-client/Manifest1
-rw-r--r--net-misc/cernbox-client/cernbox-client-2.11.1.8946.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/net-misc/cernbox-client/Manifest b/net-misc/cernbox-client/Manifest
index af2fbf942..d117605d1 100644
--- a/net-misc/cernbox-client/Manifest
+++ b/net-misc/cernbox-client/Manifest
@@ -2,3 +2,4 @@ DIST cernbox-client-2.7.1-2596.src.rpm 15434250 BLAKE2B 3ef3fcc4010b3f292aee9b6b
DIST cernbox-client-2.9.2-6339.src.rpm 6243132 BLAKE2B c73c3c338f9d3fb7fa7b22efe9b6ff1380d80f3804e2e732873f5804ed31d98fb04f9dbcdc0f614136c08081bea825d70948f94a6c0c9dddfe20eca66e41c4c1 SHA512 ec0edff177a5b77144eef173e4e3f5d549762faa6682618124f5c64e37f657c3aa00f639723cf2c48b6c4d1049373cd24b41d347cd9bf3c7bb291ab3340d6b2a
DIST ownCloud-2.10.1.7389.tar.xz 5598044 BLAKE2B 8558a8a7b7bd4b8a0685b703f0882d6b5619c4902217d40feb4cf5587555b9a85363c7f61834e4c85a84789142fca8c73910fce66544f491ec5968818c816605 SHA512 2a0893d48786b88f8210966a2b6b48f5bdada82818d4115e68ecc6c0c926ba62bc74df03c4ab35eb271aef2f3a43b36b1a6a115585efe3739fd4a6164f9c45a1
DIST ownCloud-2.11.1.8438.tar.xz 5655380 BLAKE2B da34adafabfc8c2b0bbfdff99a81b56f2d2639b5168b2165a847a6d5a4efe4e86578984c0f0c20564d0978aab18bb1a62330539bdd137f608a5cfc3ff8d84cf0 SHA512 fe38471f62e7233a7ba04f7fd2c7c7231957e6927c39d0bcf3f6f77fd6cbb1223618bbf6a8cc5fa15de10a35c7f07f2f5df0e49acbc2af5fe9333cda2eb41c92
+DIST ownCloud-2.11.1.8946.tar.xz 5654496 BLAKE2B 6b5b82730460071ae590b35d653824f4e56d506d87929c5d4ebb31eef921d0cb0141a44d7f0c996b8d1afffa5874d3e4dda75feaba740e652df2939633475fcd SHA512 b44f72e22c539a731901d9c146f00edbf0a4dabb992d6cde06be1b50506d5bc4a8aa861c6ea0207eed72aaea8c8af8651ce07f9e9154e6e44ccdecdd27e35b75
diff --git a/net-misc/cernbox-client/cernbox-client-2.11.1.8946.ebuild b/net-misc/cernbox-client/cernbox-client-2.11.1.8946.ebuild
new file mode 100644
index 000000000..c698f7562
--- /dev/null
+++ b/net-misc/cernbox-client/cernbox-client-2.11.1.8946.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake rpm xdg
+
+DESCRIPTION="Synchronize files from CERNBox EOS with your computer"
+
+# Origin is classic owncloud-client, branded for CERN during compilation.
+ORIGIN_PN="ownCloud"
+BRANDED_P="cernbox"
+BRANDED_PV="2.9.2"
+BRANDED_REL="6339"
+HOMEPAGE="https://cernbox.cern.ch/"
+SRC_URI="https://download.owncloud.com/desktop/${ORIGIN_PN}/stable/${PV}/source/${ORIGIN_PN}-${PV}.tar.xz
+ https://cernbox.cern.ch/cernbox/doc/Linux/repo/CentOS_7/src/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm
+ https://cern.ch/ofreyerm/gentoo/cernbox/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm"
+
+LICENSE="CC-BY-3.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dolphin gnome-keyring nautilus test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-db/sqlite-3.4:3
+ dev-libs/qtkeychain[gnome-keyring?,qt5(+)]
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-fs/inotify-tools
+ dolphin? (
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/kio:5
+ )
+ nautilus? ( dev-python/nautilus-python )"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-util/cmocka
+ dev-qt/qttest:5
+ )"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ kde-frameworks/extra-cmake-modules"
+
+S=${WORKDIR}/${ORIGIN_PN}-${PV}
+
+src_unpack() {
+ rpm_src_unpack ${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm || die "failed to extract branding RPM"
+ mv ${PN%-*}-${BRANDED_PV}.${BRANDED_REL}/branding "${S}" || die "failed to extract branding"
+}
+
+src_prepare() {
+ # Keep tests in ${T}
+ sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die
+
+ if ! use nautilus; then
+ pushd shell_integration > /dev/null || die
+ cmake_comment_add_subdirectory nautilus
+ popd > /dev/null || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DBUILD_SHELL_INTEGRATION_DOLPHIN=$(usex dolphin)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}