aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-07-30 02:10:03 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-07-30 02:10:03 +0200
commit53b2b237392972cb1f15086dbf5145004acf38da (patch)
tree810a885428c700781f32d22e0d89ef4cadc286cb
parentsci-biology/ensembl-tools: add another link to a HOMEPAGE (diff)
downloadsci-53b2b237392972cb1f15086dbf5145004acf38da.tar.gz
sci-53b2b237392972cb1f15086dbf5145004acf38da.tar.bz2
sci-53b2b237392972cb1f15086dbf5145004acf38da.zip
sci-biology/gbench: version bump; run configure; does not compile
Package-Manager: portage-2.3.0
-rw-r--r--sci-biology/gbench/Manifest2
-rw-r--r--sci-biology/gbench/gbench-2.10.7.ebuild (renamed from sci-biology/gbench/gbench-2.3.2.ebuild)22
2 files changed, 18 insertions, 6 deletions
diff --git a/sci-biology/gbench/Manifest b/sci-biology/gbench/Manifest
index 35596d5bd..adbc2295e 100644
--- a/sci-biology/gbench/Manifest
+++ b/sci-biology/gbench/Manifest
@@ -1 +1 @@
-DIST gbench-src-2.3.2.tgz 23329652 SHA256 ea45974d4b843a0033c587b575cb22388de96d2e300e1bedc8e16a11d9e154be SHA512 fa83a4b15e6a59f6cf6f222842a7c451fcf8c3313ada28486e90ee38fefa00dd2b05039fa9f86c394076f6e01289b9d720b3a917c14b8fb35f9c3c9ec51aefd8 WHIRLPOOL 5c3de0f10661206118c41a3dd9de5ea4bbf8375ed9eb1d4c6353ddb74874a66c376bda3b240f15838a44f6c2b13713f50228f4d9bdaf08d5b98cbb6095451af7
+DIST gbench-src-2.10.7.tgz 54878913 SHA256 62107a4c7ea84800029ccb5dbaee4a528bc447366f4829bdcdd7caa056f63773 SHA512 68864d242dfd7a6e2f777bed62d6c43db7b7d3c9d45bcdb2191f234d8eff8c39203c4346ab5e7e6b3bc3a00233e2b3185308aa98f6045321ccf1f775e4ee57d7 WHIRLPOOL b99c9099169b7092a52f072e5dc1c293821172dbb6e4f46c07840b8fb8f8728e0d03f8aa5dd9bc04a7e53fb63fec157be5bd4cfec9b48fc000baa13777df0bb4
diff --git a/sci-biology/gbench/gbench-2.3.2.ebuild b/sci-biology/gbench/gbench-2.10.7.ebuild
index abee15a91..d205c87c8 100644
--- a/sci-biology/gbench/gbench-2.3.2.ebuild
+++ b/sci-biology/gbench/gbench-2.10.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -10,7 +10,7 @@ inherit python-single-r1 wxwidgets
DESCRIPTION="View and analyze genome sequences"
HOMEPAGE="http://www.ncbi.nlm.nih.gov/projects/gbench/"
-SRC_URI="ftp://ftp.ncbi.nlm.nih.gov/toolbox/gbench/ver-2.3.2/gbench-src-"${PV}".tgz"
+SRC_URI="ftp://ftp.ncbi.nlm.nih.gov/toolbox/gbench/ver-"${PV}"/gbench-src-"${PV}".tgz"
LICENSE="public-domain"
SLOT="0"
@@ -34,13 +34,13 @@ RDEPEND="${PYTHON_DEPS}
dev-util/cppunit
media-libs/freetype
media-libs/giflib
- media-libs/glew
+ media-libs/glew:=
media-libs/tiff:0=
net-libs/gnutls
sci-libs/hdf5
sys-fs/fuse
sys-libs/db:*
- virtual/glut
+ virtual/glu
virtual/opengl
x11-libs/fltk
x11-libs/wxGTK:*
@@ -59,4 +59,16 @@ RDEPEND="${PYTHON_DEPS}
"
DEPEND="${RDEPEND}"
-# ensure in src_compile no --mandir=/usr/share/man is passed to configure, use the ebuild logic from ncbi-tools++
+# recycle ebuild logic from ncbi-tools++
+
+S="${WORKDIR}"/gbench-src-"${PV}"
+
+src_configure(){
+ # configure: error: --mandir=/usr/share/man: unknown option; use --help to show usage
+ # configure: error: --infodir=/usr/share/info: unknown option; use --help to show usage
+ # configure: error: --datadir=/usr/share: unknown option; use --help to show usage
+ # configure: error: --sysconfdir=/etc: unknown option; use --help to show usage
+ # configure: error: --localstatedir=/var/lib: unknown option; use --help to show usage
+ ./configure --prefix="${DESTDIR}"/"${EPREFIX}/usr" --libdir="${EPREFIX}/usr/$(get_libdir)" CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}