aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-01 08:53:36 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-01 08:53:36 +0100
commit5bc6928cca2630e651f601fa8fba065ef5f9471e (patch)
treebe18187b291eacd1c9cd47ffac6509f4ef48aabf
parentsci-biology/MaSuRCA: version bump 4.0.1 (diff)
downloadsci-5bc6928cca2630e651f601fa8fba065ef5f9471e.tar.gz
sci-5bc6928cca2630e651f601fa8fba065ef5f9471e.tar.bz2
sci-5bc6928cca2630e651f601fa8fba065ef5f9471e.zip
sci-biology/MochiView: fix empty ebuild
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-biology/MochiView/Manifest1
-rw-r--r--sci-biology/MochiView/MochiView-1.45.ebuild16
-rw-r--r--sci-biology/MochiView/MochiView-1.46.ebuild23
3 files changed, 24 insertions, 16 deletions
diff --git a/sci-biology/MochiView/Manifest b/sci-biology/MochiView/Manifest
new file mode 100644
index 000000000..86278527b
--- /dev/null
+++ b/sci-biology/MochiView/Manifest
@@ -0,0 +1 @@
+DIST MochiView_v146.zip 12300500 BLAKE2B a85169437bc04e420e4e483f4eb98401e3e72dab1a096a5063e51c7d6d1917b3d455a91c4deb2b51c1c4be9fea18c36b97399331737ab7f217c124493dec3fb7 SHA512 c0fb8e101b1193c973d532191521b57b20ccf4843769691850d825eb750cfd76fb7f225b6becb65839a8b57fd162143787158329a5f6b8201e03b17ffcd4fd10
diff --git a/sci-biology/MochiView/MochiView-1.45.ebuild b/sci-biology/MochiView/MochiView-1.45.ebuild
deleted file mode 100644
index 61e0be859..000000000
--- a/sci-biology/MochiView/MochiView-1.45.ebuild
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DESCRIPTION="Genome browser and analysis"
-HOMEPAGE="http://johnsonlab.ucsf.edu/mochi.html"
-SRC_URI=""
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
diff --git a/sci-biology/MochiView/MochiView-1.46.ebuild b/sci-biology/MochiView/MochiView-1.46.ebuild
new file mode 100644
index 000000000..d9db425fa
--- /dev/null
+++ b/sci-biology/MochiView/MochiView-1.46.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-utils-2
+
+DESCRIPTION="Genome browser and analysis"
+HOMEPAGE="http://johnsonlab.ucsf.edu/mochi.html"
+SRC_URI="https://www.johnsonlab.ucsf.edu/s/MochiView_v${PV//.}.zip"
+
+LICENSE="MIT LGPL-3 MPL-1.1 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=virtual/jre-1.7:*"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}_v${PV}"
+
+src_install() {
+ java-pkg_dojar INTERNAL_USE/*.jar
+}