aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-01-15 12:35:07 -0500
committerHorea Christian <chr@chymera.eu>2023-01-15 12:35:07 -0500
commit5f4c776cf50e58b9e175b2473b484293ae1167c9 (patch)
tree07e1434a44936f44f92d37d64ef73d34c4771f80
parentdev-python/panel: add 0.14.1, 0.14.2 (diff)
downloadsci-5f4c776cf50e58b9e175b2473b484293ae1167c9.tar.gz
sci-5f4c776cf50e58b9e175b2473b484293ae1167c9.tar.bz2
sci-5f4c776cf50e58b9e175b2473b484293ae1167c9.zip
dev-python/panel: Trying to use build variable instead of patch
Still won't work.. Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--dev-python/panel/panel-0.14.2.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/panel/panel-0.14.2.ebuild b/dev-python/panel/panel-0.14.2.ebuild
index ea5e77d3e..866110947 100644
--- a/dev-python/panel/panel-0.14.2.ebuild
+++ b/dev-python/panel/panel-0.14.2.ebuild
@@ -35,6 +35,9 @@ RDEPEND="${DEPEND}
PATCHES=( "${FILESDIR}/${PN}-0.14.1-disable_lite_build.patch" )
+# This does not work, need to patch..
+#export PANEL_LITE_BUILD=1
+
src_prepare() {
# Install Jupyter configuration files to "/etc" rather than "/usr/etc".
sed -i -e 's~"etc/jupyter~"/etc/jupyter~' setup.py || die
@@ -42,6 +45,12 @@ src_prepare() {
default_src_prepare
}
+# This also does not work, still need patch :(
+#src_compile() {
+# export PANEL_LITE_BUILD=1
+# distutils-r1_src_compile
+#}
+
pkg_postinst() {
panel_pkg_postinst() {
PANEL_DIR="$(${EPYTHON} -c 'import os, panel; print(os.path.dirname(panel.__file__))')"