aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-01 12:19:09 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-01 12:19:09 +0100
commit601aa9b78c9e572dd6676cf00942de9e1c0ec2b0 (patch)
tree360c634fa802033dd59b88513f29bc06f9a3f054
parentsci-biology/jigsaw: define correct compile and install phases (diff)
downloadsci-601aa9b7.tar.gz
sci-601aa9b7.tar.bz2
sci-601aa9b7.zip
sci-biology/mgblast: EAPI bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-biology/mgblast/mgblast-0.1.ebuild29
1 files changed, 9 insertions, 20 deletions
diff --git a/sci-biology/mgblast/mgblast-0.1.ebuild b/sci-biology/mgblast/mgblast-0.1.ebuild
index 354836e22..3a2d3d7a6 100644
--- a/sci-biology/mgblast/mgblast-0.1.ebuild
+++ b/sci-biology/mgblast/mgblast-0.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
DESCRIPTION="Customized version of megablast from TIGR Gene Indices project"
HOMEPAGE="http://compbio.dfci.harvard.edu/tgi/software/"
@@ -9,14 +9,12 @@ SRC_URI="ftp://occams.dfci.harvard.edu/pub/bio/tgi/software/tgicl/mgblast.tar.gz
LICENSE="Artistic"
SLOT="0"
-KEYWORDS="" # upstream binary is provided by sci-biology/tgicl currently
-#KEYWORDS="~amd64 ~x86"
-IUSE=""
+KEYWORDS=""
DEPEND="sci-biology/ncbi-tools"
RDEPEND="${DEPEND}"
-S="${WORKDIR}"
+S="${WORKDIR}/${PN}"
# mgblast needs old version of ncbi-tools unpacked and compiled during its own compilation
# from newer tools you need to include blfmtutl.h but the next error is no go for me:
@@ -26,20 +24,11 @@ S="${WORKDIR}"
src_prepare(){
# mgblast cannot be compiled against newer ncbi-tools but let's try
- mv mgblast/makefile mgblast/Makefile 2>/dev/null || true
- sed -i 's#/usr/local/projects/tgi/ncbitoolkit/ncbi#/usr#' mgblast/Makefile || die
- sed -i 's#NCBIDIR = /mylocal/src/ncbi#NCBIDIR = /usr#' mgblast/Makefile || die
- sed -i 's#NCBI_INCDIR = .*#NCBI_INCDIR = /usr/include/ncbi#' mgblast/Makefile || die
- sed -i 's#NCBI_LIBDIR = .*#NCBI_LIBDIR = /usr/lib#' mgblast/Makefile || die # a PATH to NCBI-TOOLKIT (/usr/lib) while NOT /usr/lib/ncbi-tools++ !
- sed -i "s#-I-#-iquote#" mgblast/Makefile || die
-}
-
-src_compile(){
- cd "${S}"/mgblast || die
+ mv makefile Makefile 2>/dev/null || true
+ sed -i -e 's#/usr/local/projects/tgi/ncbitoolkit/ncbi#/usr#' \
+ -e's#NCBIDIR = /mylocal/src/ncbi#NCBIDIR = /usr#' \
+ -e's#NCBI_INCDIR = .*#NCBI_INCDIR = /usr/include/ncbi#' \
+ -e 's#NCBI_LIBDIR = .*#NCBI_LIBDIR = /usr/lib#' \
+ -e "s#-I-#-iquote#" Makefile || die # a PATH to NCBI-TOOLKIT (/usr/lib) while NOT /usr/lib/ncbi-tools++ !
default
}
-
-src_install(){
- cd "${S}"/mgblast || die
- dobin mgblast
-}