aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2018-04-02 13:31:53 +0100
committerJustin Lecher <jlec@gentoo.org>2018-04-02 13:31:53 +0100
commit612d367836a2f1c93ac9ac0359887cbfe6efce4f (patch)
treeb2d7277128a8969438ef7f9e191d7341a5e6db7e
parentsci-libs/trilinos: Change USE=qt to qt5 (diff)
downloadsci-612d3678.tar.gz
sci-612d3678.tar.bz2
sci-612d3678.zip
net-misc/cernbox-client: Fix USE-deps
Drop old Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.27, Repoman-2.3.9
-rw-r--r--net-misc/cernbox-client/Manifest1
-rw-r--r--net-misc/cernbox-client/cernbox-client-2.3.1.ebuild103
-rw-r--r--net-misc/cernbox-client/cernbox-client-2.3.2.ebuild13
3 files changed, 7 insertions, 110 deletions
diff --git a/net-misc/cernbox-client/Manifest b/net-misc/cernbox-client/Manifest
index 8394f8ae9..9cc363d55 100644
--- a/net-misc/cernbox-client/Manifest
+++ b/net-misc/cernbox-client/Manifest
@@ -1,3 +1,2 @@
DIST cernbox-client-2.2.4-1.1.src.rpm 14208412 SHA256 1835b660026026a1fd30ef45c2f0d76fbf8efb2970399c24467c9e1611745838 SHA512 24b2a56eb7cc520271ea5f4900f86852cf34ff500b5339b63984b74a40288e30fe785fc9815937637211e7c3d8d7fde7f509f0319d676522641e04ef8192db1e WHIRLPOOL af3c11d30b77d6722c67bb561d1d6e3ab125824d3a25265d25227dfc0ef4f2198d0dfe733b0ca5a3098f59b6da08fbcdb2fac81d02b025ca3215196bf2a4e337
-DIST owncloudclient-2.3.1.tar.xz 12260696 BLAKE2B 11458ce573a24cf616d9190a9755f47f5f01a142c55dc671a16cfbbe8f5dd08095101e7a5fbfa26a7b8c74509f19b00a34fea29bf5e019124a2aee0d76e51ceb SHA512 2dec3d4b452faca32e15c1a461d3fec97fc1c2e85bbfe2cb02035371a5426b8458be1382ed6b4a1102a4f38241580c3d49980ea388344365297a4a84f8dc9add
DIST owncloudclient-2.3.2.tar.xz 12266008 BLAKE2B 53d08aec4971ae309b4fd07cea4e6ed9643411d4f6921c82213d55ec757abcd61ee64abc81e359ea0808b54d8447e3742fdec5394ed55b2e09805616f5430a75 SHA512 8abe071c28b365c100eb30ed91610640a25a7385f4347f5527289f4664788bda375e9618396ffa3e441c7e473da55bdaf7a5cdd99c8fd5801de78cb945fabb9c
diff --git a/net-misc/cernbox-client/cernbox-client-2.3.1.ebuild b/net-misc/cernbox-client/cernbox-client-2.3.1.ebuild
deleted file mode 100644
index 6f3ad8c70..000000000
--- a/net-misc/cernbox-client/cernbox-client-2.3.1.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils rpm
-
-DESCRIPTION="Synchronize files from CERNbox EOS with your computer"
-
-# Origin is classic owncloud-client, branded for CERN during compilation.
-ORIGIN_P="owncloudclient"
-BRANDED_P="cernbox"
-BRANDED_PV="2.2.4"
-BRANDED_REL="1.1"
-
-HOMEPAGE="https://cernbox.cern.ch/"
-SRC_URI="http://download.owncloud.com/desktop/stable/${ORIGIN_P}-${PV}.tar.xz
- https://cernbox.cern.ch/cernbox/doc/Linux/repo/CentOS_7/src/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm"
-
-LICENSE="CC-BY-3.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc dolphin nautilus samba +sftp test"
-
-COMMON_DEPEND=">=dev-db/sqlite-3.4:3
- dev-libs/qtkeychain[qt5]
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtsql:5
- dev-qt/qtwebkit:5
- sys-fs/inotify-tools
- virtual/libiconv
- dolphin? (
- kde-frameworks/kcoreaddons:5
- kde-frameworks/kio:5
- )
- nautilus? ( dev-python/nautilus-python )
- samba? ( >=net-fs/samba-3.5 )
- sftp? ( >=net-libs/libssh-0.5 )
-"
-RDEPEND="${COMMON_DEPEND}
- !net-misc/ocsync
- !net-misc/nextcloud-client
-"
-DEPEND="${COMMON_DEPEND}
- dev-qt/linguist-tools:5
- doc? (
- dev-python/sphinx
- dev-texlive/texlive-latexextra
- virtual/latex-base
- )
- dolphin? ( kde-frameworks/extra-cmake-modules )
- test? (
- dev-util/cmocka
- dev-qt/qttest:5
- )
-"
-
-S=${WORKDIR}/owncloudclient-${PV}
-
-src_unpack() {
- rpm_src_unpack ${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm
- mv ${PN/-}-${BRANDED_PV}/cernbox "${S}" || die "failed to extract branding"
-}
-
-src_prepare() {
- # Keep tests in ${T}
- sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die "sed failed"
-
- if ! use nautilus; then
- pushd shell_integration > /dev/null || die
- cmake_comment_add_subdirectory nautilus
- popd > /dev/null || die
- fi
- default
-}
-
-src_configure() {
- local mycmakeargs=(
- -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
- -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
- -DWITH_ICONV=ON
- -DWITH_DOC=$(usex doc)
- -DCMAKE_DISABLE_FIND_PACKAGE_KF5=$(usex !dolphin)
- -DBUILD_WITH_QT4=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_Libsmbclient=$(usex !samba)
- -DCMAKE_DISABLE_FIND_PACKAGE_LibSSH=$(usex !sftp)
- -DUNIT_TESTING=$(usex test)
- -DOEM_THEME_DIR=${PWD}/${BRANDED_P}/mirall
- )
-
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- if ! use doc ; then
- elog "Documentation and man pages not installed"
- elog "Enable doc USE-flag to generate them"
- fi
-}
diff --git a/net-misc/cernbox-client/cernbox-client-2.3.2.ebuild b/net-misc/cernbox-client/cernbox-client-2.3.2.ebuild
index 6f3ad8c70..9513b064b 100644
--- a/net-misc/cernbox-client/cernbox-client-2.3.2.ebuild
+++ b/net-misc/cernbox-client/cernbox-client-2.3.2.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit cmake-utils rpm
-DESCRIPTION="Synchronize files from CERNbox EOS with your computer"
-
# Origin is classic owncloud-client, branded for CERN during compilation.
ORIGIN_P="owncloudclient"
BRANDED_P="cernbox"
BRANDED_PV="2.2.4"
BRANDED_REL="1.1"
+DESCRIPTION="Synchronize files from CERNbox EOS with your computer"
HOMEPAGE="https://cernbox.cern.ch/"
-SRC_URI="http://download.owncloud.com/desktop/stable/${ORIGIN_P}-${PV}.tar.xz
+SRC_URI="
+ http://download.owncloud.com/desktop/stable/${ORIGIN_P}-${PV}.tar.xz
https://cernbox.cern.ch/cernbox/doc/Linux/repo/CentOS_7/src/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm"
LICENSE="CC-BY-3.0 GPL-2"
@@ -22,8 +22,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc dolphin nautilus samba +sftp test"
-COMMON_DEPEND=">=dev-db/sqlite-3.4:3
- dev-libs/qtkeychain[qt5]
+COMMON_DEPEND="
+ >=dev-db/sqlite-3.4:3
+ dev-libs/qtkeychain
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtdbus:5