aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-01-31 03:15:27 -0500
committerHorea Christian <chr@chymera.eu>2022-01-31 03:15:27 -0500
commit67e6080551c80d384ee79713470e20396317a8f1 (patch)
treebc507229f06a3962cef2206fef70e5e937a20879
parentdev-python/hdmf: revbump for setup.py versions (diff)
downloadsci-67e60805.tar.gz
sci-67e60805.tar.bz2
sci-67e60805.zip
dev-python/pynwb: new package (DANDI stack)
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--dev-python/pynwb/ChangeLog6
-rw-r--r--dev-python/pynwb/Manifest2
-rw-r--r--dev-python/pynwb/files/pynwb-2.0.0-versions.patch21
-rw-r--r--dev-python/pynwb/metadata.xml20
-rw-r--r--dev-python/pynwb/pynwb-2.0.0.ebuild46
-rw-r--r--dev-python/pynwb/pynwb-2.0.0_p0.ebuild47
6 files changed, 142 insertions, 0 deletions
diff --git a/dev-python/pynwb/ChangeLog b/dev-python/pynwb/ChangeLog
new file mode 100644
index 000000000..1eee46e49
--- /dev/null
+++ b/dev-python/pynwb/ChangeLog
@@ -0,0 +1,6 @@
+*pynwb-2.0.0_p0 (31 Jan 2022)
+
+ 31 Jan 2022; <chymera@gentoo.org> +files/pynwb-2.0.0-versions.patch,
+ +pynwb-2.0.0_p0.ebuild, pynwb-2.0.0.ebuild:
+ dev-python/pynwb: version bump and test skip linking skipped test reports on
+ upstream issue treacker
diff --git a/dev-python/pynwb/Manifest b/dev-python/pynwb/Manifest
new file mode 100644
index 000000000..16b7c7287
--- /dev/null
+++ b/dev-python/pynwb/Manifest
@@ -0,0 +1,2 @@
+DIST pynwb-2.0.0.post0.dev5.tar.gz 450799 BLAKE2B 02aef74992dda44139e776eebf3d29924caa46bfc2a12da400ceaadff5856295b6205c6ad230483935e713eed9dd868b9109c2d51d7c69291dc93db806ef4761 SHA512 840a33cd0a2de5c491e785530e4dab589945015b9a60384ed127a27fbfe4c527b1b10d74a9ffe2a795a29c3bba65aafd007975973a2da68fca73bf71260b7b8b
+DIST pynwb-2.0.0.tar.gz 450082 BLAKE2B 3bfd17b8cbe5f12992630bc5a97144dbc7b3d583238e1fe0d59576029ae7a30acbd05b7af18ca89d6cba389df1bf543c97e75e83e04aeb4a4e44c4cd1a26be9d SHA512 4afc319fd9cce0c1e81589236237f9a28b69dd846d96849ae5cc554287a6dd124fd421f700736dbb714cfbe6f260e79f374d1dd63ee92c2776f5173654d61f9a
diff --git a/dev-python/pynwb/files/pynwb-2.0.0-versions.patch b/dev-python/pynwb/files/pynwb-2.0.0-versions.patch
new file mode 100644
index 000000000..d09c50594
--- /dev/null
+++ b/dev-python/pynwb/files/pynwb-2.0.0-versions.patch
@@ -0,0 +1,21 @@
+diff --git a/setup.py b/tmp/setup.py
+index 39e75824..f7948f64 100755
+--- a/setup.py
++++ b/setup.py
+@@ -19,11 +19,11 @@ print('found these packages:', pkgs)
+ schema_dir = 'nwb-schema/core'
+
+ reqs = [
+- 'h5py>=2.9,<4',
+- 'hdmf>=3.1.1,<4',
+- 'numpy>=1.16,<1.22',
+- 'pandas>=1.0.5,<2',
+- 'python-dateutil>=2.7,<3',
++ 'h5py',
++ 'hdmf',
++ 'numpy',
++ 'pandas',
++ 'python-dateutil',
+ 'setuptools'
+ ]
+
diff --git a/dev-python/pynwb/metadata.xml b/dev-python/pynwb/metadata.xml
new file mode 100644
index 000000000..99512b574
--- /dev/null
+++ b/dev-python/pynwb/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ PyNWB is a Python package for working with NWB files. It provides a
+ high-level API for efficiently working with Neurodata stored in the NWB
+ format. Neurodata Without Borders: Neurophysiology (NWB:N) is a project
+ to develop a unified data format for cellular-based neurophysiology
+ data, focused on the dynamics of groups of neurons measured under a
+ large range of experimental conditions.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pynwb/pynwb-2.0.0.ebuild b/dev-python/pynwb/pynwb-2.0.0.ebuild
new file mode 100644
index 000000000..b0294a4e0
--- /dev/null
+++ b/dev-python/pynwb/pynwb-2.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python API for working with Neurodata stored in the NWB Format "
+HOMEPAGE="https://github.com/NeurodataWithoutBorders/pynwb"
+SRC_URI="https://github.com/NeurodataWithoutBorders/pynwb/releases/download/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sci-libs/hdf5[ros3]
+ dev-python/hdmf[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ "
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-versions.patch"
+ )
+
+EPYTEST_DESELECT=(
+ # Reported upsream:
+ # https://github.com/dandi/dandischema/issues/87
+ tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached
+ tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached_bad_ns
+ tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached_hdmf_common
+ tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached_ignore
+ tests/validation/test_validate.py::TestValidateScript::test_validate_file_no_cache
+ tests/validation/test_validate.py::TestValidateScript::test_validate_file_no_cache_bad_ns
+ # Reported upstream and fixed in newer version:
+ # https://github.com/NeurodataWithoutBorders/pynwb/issues/1412#issuecomment-934153799
+ tests/integration/ros3/test_ros3.py::TestRos3Streaming::test_dandi_read
+ tests/integration/ros3/test_ros3.py::TestRos3Streaming::test_read
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/pynwb/pynwb-2.0.0_p0.ebuild b/dev-python/pynwb/pynwb-2.0.0_p0.ebuild
new file mode 100644
index 000000000..fba3e6319
--- /dev/null
+++ b/dev-python/pynwb/pynwb-2.0.0_p0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}.dev5"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A Python API for working with Neurodata stored in the NWB Format "
+HOMEPAGE="https://github.com/NeurodataWithoutBorders/pynwb"
+SRC_URI="https://github.com/NeurodataWithoutBorders/pynwb/releases/download/latest/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sci-libs/hdf5[ros3]
+ dev-python/hdmf[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ "
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.0-versions.patch"
+ )
+
+S="${WORKDIR}/${MY_P}"
+
+EPYTEST_DESELECT=(
+ # Reported upsream
+ # https://github.com/dandi/dandischema/issues/87
+ tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached
+ tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached_bad_ns
+ tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached_hdmf_common
+ tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached_ignore
+ tests/validation/test_validate.py::TestValidateScript::test_validate_file_no_cache
+ tests/validation/test_validate.py::TestValidateScript::test_validate_file_no_cache_bad_ns
+)
+
+distutils_enable_tests pytest