aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-02 14:18:29 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-02 14:18:29 +0200
commit689c58f6e7b62c8569ab1bca5705e4fc0d0c7800 (patch)
tree3fe84909f211432d1a5dc6a313bf1147c925d4e5
parentsci-biology/fsl: drop dep on cuda-10 (diff)
downloadsci-689c58f6.tar.gz
sci-689c58f6.tar.bz2
sci-689c58f6.zip
sci-libs/superlu_dist: drop masked package
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--profiles/package.mask5
-rw-r--r--sci-libs/superlu_dist/Manifest1
-rw-r--r--sci-libs/superlu_dist/metadata.xml26
-rw-r--r--sci-libs/superlu_dist/superlu_dist-6.4.0.ebuild42
4 files changed, 0 insertions, 74 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index effdccc93..d39812beb 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -29,8 +29,3 @@
## app-misc/some-package
#--- END OF EXAMPLES ---
-
-# Andrew Ammerlaan <andrewammerlaan@gentoo.org> (15 Mar 2022)
-# Missing dependencies, bumping is non-trivial, requires patches to get it to
-# compile without errors or sandbox violations. Mask for removal, no revdeps
-sci-libs/superlu_dist
diff --git a/sci-libs/superlu_dist/Manifest b/sci-libs/superlu_dist/Manifest
deleted file mode 100644
index 5b7c716f7..000000000
--- a/sci-libs/superlu_dist/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST superlu_dist-6.4.0.tar.gz 1710130 BLAKE2B 82a14c8fe671bc16daa1f9ae9014dd39300566057af25acda3a9a5fd6581157a7d40baff9c9520cf6a93726418407bdfbeffe77c60dfe261fd41511d79059167 SHA512 e9de825ad65979df238cfdd5d07fefe0775ba705b247b2cca2ce6b7cd775f39c45320617553f5e0e05f39be17c5d3c8d1d40f03272fd87303a3c230b3a120172
diff --git a/sci-libs/superlu_dist/metadata.xml b/sci-libs/superlu_dist/metadata.xml
deleted file mode 100644
index 0bd32bba5..000000000
--- a/sci-libs/superlu_dist/metadata.xml
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
-SuperLU is a general purpose library for the direct solution of
-large, sparse, nonsymmetric systems of linear equations on high
-performance machines. The library is written in C and is callable
-from either C or Fortran. The library routines will perform an LU
-decomposition with partial pivoting and triangular system solves
-through forward and back substitution. The LU factorization routines
-can handle non-square matrices but the triangular solves are
-performed only for square matrices. The matrix columns may be
-preordered (before factorization) either through library or user
-supplied routines. This preordering for sparsity is completely
-separate from the factorization. Working precision iterative
-refinement subroutines are provided for improved backward
-stability. Routines are also provided to equilibrate the system,
-estimate the condition number, calculate the relative backward
-error, and estimate error bounds for the refined solutions.
-This is the distributed version (MPI based).
-</longdescription>
-</pkgmetadata>
diff --git a/sci-libs/superlu_dist/superlu_dist-6.4.0.ebuild b/sci-libs/superlu_dist/superlu_dist-6.4.0.ebuild
deleted file mode 100644
index 8c7be2874..000000000
--- a/sci-libs/superlu_dist/superlu_dist-6.4.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DOCS_BUILDER="doxygen"
-DOCS_CONFIG_NAME="DoxyConfig"
-
-inherit cmake docs
-
-MYPN=SuperLU_DIST
-
-DESCRIPTION="MPI distributed sparse LU factorization library"
-HOMEPAGE="https://portal.nersc.gov/project/sparse/superlu/ https://github.com/xiaoyeli/superlu_dist"
-SRC_URI="https://github.com/xiaoyeli/superlu_dist/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- sci-libs/parmetis[mpi(-)]
- virtual/mpi"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- local mycmakeargs=(
- -DTPL_PARMETIS_LIBRARIES="/usr/$(get_libdir)/libmetis.so"
- -DTPL_PARMETIS_INCLUDE_DIRS="/usr/include/"
- -Denable_examples=$(usex examples ON OFF)
- -Denable_tests=$(usex test ON OFF)
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- default
-}