aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-03-27 01:39:20 -0400
committerHorea Christian <chr@chymera.eu>2022-03-27 01:39:20 -0400
commit68ff89b3a469dc077d20eb6621b631631b341092 (patch)
tree0e033519eb55e90b737fa17823474016d81d6ed4
parentdev-python/pycryptodomex: new package (DANDI stack) (diff)
downloadsci-68ff89b3a469dc077d20eb6621b631631b341092.tar.gz
sci-68ff89b3a469dc077d20eb6621b631631b341092.tar.bz2
sci-68ff89b3a469dc077d20eb6621b631631b341092.zip
dev-python/pyout: new package (DANDI stack)
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--dev-python/pyout/Manifest2
-rw-r--r--dev-python/pyout/metadata.xml24
-rw-r--r--dev-python/pyout/pyout-0.7.1.ebuild32
-rw-r--r--dev-python/pyout/pyout-0.7.2.ebuild32
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/pyout/Manifest b/dev-python/pyout/Manifest
new file mode 100644
index 000000000..551424495
--- /dev/null
+++ b/dev-python/pyout/Manifest
@@ -0,0 +1,2 @@
+DIST pyout-0.7.1.tar.gz 180439 BLAKE2B b64808edfa013c8460961afacbe70caad4f3c0520d8b87656e909e278534bf111154fd31a186f95246d3084671c841ea421ed52118ddeee3f08f21106f2f80b1 SHA512 66338ce6dbf1e4ee6a187993609f762fcd2f8dddd981bc976b3240b6ecd461ba1fd47b9f08b91fc29853ce88e26158c7047de0adfcf28a0dd66869adfad5ab71
+DIST pyout-0.7.2.tar.gz 181753 BLAKE2B 780e536921151f81097e5dee7c74cfa086153f916fc9b9fd684f01008ada34102ba33ee7bdd3dd8cc4ccf89a8d9821ec0aecdbd87bc356abf25c6e4fe32d4c5a SHA512 e7be6f7829f6b09ead64c596cfdecfa45073af0a1da15401702327e141bbfae10e7968ee5e332358aa04bfc7ddf71b7b6caf2d5877aca8514e4ba544d3b1670a
diff --git a/dev-python/pyout/metadata.xml b/dev-python/pyout/metadata.xml
new file mode 100644
index 000000000..712a48169
--- /dev/null
+++ b/dev-python/pyout/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ pyout is a Python package that defines an interface for writing
+ structured records as a table in a terminal. It is being developed to
+ replace custom code for displaying tabular data in in ReproMan and
+ DataLad. See the Examples folder for how to get started. A primary
+ goal of the interface is the separation of content from style and
+ presentation.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">pyout/pyout</remote-id>
+ <remote-id type="pypi">pyout</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyout/pyout-0.7.1.ebuild b/dev-python/pyout/pyout-0.7.1.ebuild
new file mode 100644
index 000000000..6cf80ec85
--- /dev/null
+++ b/dev-python/pyout/pyout-0.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Terminal styling for structured data"
+HOMEPAGE="https://github.com/pyout/pyout"
+SRC_URI="https://github.com/pyout/pyout/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/blessings[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/pytest-runner/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/pyout/pyout-0.7.2.ebuild b/dev-python/pyout/pyout-0.7.2.ebuild
new file mode 100644
index 000000000..6cf80ec85
--- /dev/null
+++ b/dev-python/pyout/pyout-0.7.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Terminal styling for structured data"
+HOMEPAGE="https://github.com/pyout/pyout"
+SRC_URI="https://github.com/pyout/pyout/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/blessings[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/pytest-runner/d' setup.py || die
+ distutils-r1_python_prepare_all
+}