aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFoscoV <FoscoV@users.noreply.github.com>2022-10-28 19:04:42 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-31 11:20:46 +0100
commit6a6ac87d70e2657e034a1636741c82439081bfbd (patch)
treed6eef9922185c1cd5b73c8e2d8dbcaa3cefce40c
parentdev-python/wraps: removed commented patches (diff)
downloadsci-6a6ac87d.tar.gz
sci-6a6ac87d.tar.bz2
sci-6a6ac87d.zip
dev-python/xgboost: add 1.6.2, drop 1.3.1, enable py3_{10,11}, pep517
Co-authored-by: FoscoV <FoscoV@users.noreply.github.com> Closes: https://github.com/gentoo/sci/pull/1179 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/xgboost/Manifest2
-rw-r--r--dev-python/xgboost/files/xgboost-1.3.1-fix-install.patch31
-rw-r--r--dev-python/xgboost/xgboost-1.6.2.ebuild (renamed from dev-python/xgboost/xgboost-1.3.1.ebuild)10
3 files changed, 4 insertions, 39 deletions
diff --git a/dev-python/xgboost/Manifest b/dev-python/xgboost/Manifest
index 1bcc6ae18..7c74e59be 100644
--- a/dev-python/xgboost/Manifest
+++ b/dev-python/xgboost/Manifest
@@ -1 +1 @@
-DIST xgboost-1.3.1.tar.gz 764139 BLAKE2B cde5e36b07fd4e2dba4961921bc169b730c775a12d8ec98a80d3f442a894f4bcc946094122df8d9fc5e76c8f505d4c57416e2deb13fe88751a9f51d8e4e09cad SHA512 ffe5851bd600d3a2f9b92850df6a028ec2c7d5f40ce4bad8e21b24e128a251e577e4344d8ce5cc50d6c17accf23bf283ff605d93fe6e12b9bfea6b544c57f428
+DIST xgboost-1.6.2.tar.gz 790950 BLAKE2B 07c7e65f6969d75b5741e7fb0d113dd98007d7fe296eb2f62cd02d88b39ec4d87c2e51e8f866ee9fb76d9cf73fbb2e0defea3a9d4d78373d170f9298a991ca22 SHA512 6e5221cf569765848484a7476acc1d8ccc7260807c70695047d0dac839404bd191e0f521a91d9e088af2c125770aec7c6a651c4bb830059c04482c4c799bb62b
diff --git a/dev-python/xgboost/files/xgboost-1.3.1-fix-install.patch b/dev-python/xgboost/files/xgboost-1.3.1-fix-install.patch
deleted file mode 100644
index 8c2d3d180..000000000
--- a/dev-python/xgboost/files/xgboost-1.3.1-fix-install.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-The BUILD_TEMP_DIR variable is set in the build phase but is no
-longer available in the install phase. We write the variable to
-a tmp file and read it later in the install phase as a workaround
-diff --git a/setup.py b/setup.py
-index 6244066..934e7cf 100644
---- a/setup.py
-+++ b/setup.py
-@@ -137,6 +137,11 @@ class BuildExt(build_ext.build_ext): # pylint: disable=too-many-ancestors
- build_dir = self.build_temp
- global BUILD_TEMP_DIR # pylint: disable=global-statement
- BUILD_TEMP_DIR = build_dir
-+ tmp_workdir = os.environ["WORKDIR"]
-+ py_vers = os.environ["EPYTHON"]
-+ f = open(tmp_workdir + f"/build-path-{py_vers}.txt", "w")
-+ f.write(BUILD_TEMP_DIR)
-+ f.close()
- libxgboost = os.path.abspath(
- os.path.join(CURRENT_DIR, os.path.pardir, 'lib', lib_name()))
-
-@@ -229,6 +234,11 @@ class InstallLib(install_lib.install_lib):
- dst = os.path.join(self.install_dir, 'xgboost', 'lib', lib_name())
-
- global BUILD_TEMP_DIR # pylint: disable=global-statement
-+ tmp_workdir = os.environ["WORKDIR"]
-+ py_vers = os.environ["EPYTHON"]
-+ f = open(tmp_workdir + f"/build-path-{py_vers}.txt", "r")
-+ BUILD_TEMP_DIR = f.read()
-+ f.close()
- libxgboost_path = lib_name()
-
- dft_lib_dir = os.path.join(CURRENT_DIR, os.path.pardir, 'lib')
diff --git a/dev-python/xgboost/xgboost-1.3.1.ebuild b/dev-python/xgboost/xgboost-1.6.2.ebuild
index 25145f93d..e429f5741 100644
--- a/dev-python/xgboost/xgboost-1.3.1.ebuild
+++ b/dev-python/xgboost/xgboost-1.6.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="XGBoost Python Package"
@@ -15,11 +15,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-PATCHES=( "${FILESDIR}/${P}-fix-install.patch" )
-
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
"
-
-PATCHES=( "${FILESDIR}/${P}-fix-install.patch" )