aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-08-08 13:28:26 +0200
committerJustin Lecher <jlec@gentoo.org>2016-08-08 12:28:26 +0100
commit6af335f648ecc5db0d49385d2bc3213abf8a9e23 (patch)
tree182af49db496911c6302f0559118335b6179c5eb
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-6af335f6.tar.gz
sci-6af335f6.tar.bz2
sci-6af335f6.zip
Nipype - version bump and EAPI upgrade (#656)
* sci-libs/nipype: version bump Package-Manager: portage-2.3.0 * sci-libs/nipype: updted EAPI version Package-Manager: portage-2.3.0
-rw-r--r--sci-libs/nipype/Manifest1
-rw-r--r--sci-libs/nipype/nipype-0.11.0.ebuild2
-rw-r--r--sci-libs/nipype/nipype-0.12.0.ebuild2
-rw-r--r--sci-libs/nipype/nipype-0.12.1.ebuild36
-rw-r--r--sci-libs/nipype/nipype-9999.ebuild4
5 files changed, 41 insertions, 4 deletions
diff --git a/sci-libs/nipype/Manifest b/sci-libs/nipype/Manifest
index 7d2db2dca..4ad4a717a 100644
--- a/sci-libs/nipype/Manifest
+++ b/sci-libs/nipype/Manifest
@@ -1,2 +1,3 @@
DIST nipype-0.11.0.tar.gz 2837853 SHA256 b1a69fbda7ce044ec24c2536f5733dfc251d16b4a713cab65f893d7e3357b437 SHA512 2b54cb5e57081b49565644a02d319477ecddb41ce6a6689c7f72f5381850afee2ce18ea4d0097ef0cb150fdff4980e1fc6a9c04d9a37610b65179727e8d8a82f WHIRLPOOL a406e44b13df4a90557f745753c19ee949b3267cf68245fb4ab3d23300e39aa481a36c47b690cf40681a1f1c4ffe772b88f36c71827debc23526604333683539
DIST nipype-0.12.0.tar.gz 3088339 SHA256 ce4c481c8adbea50647b55f6cd7d902332b6de1ffdab4c185568f0bbe6c8b52a SHA512 cb882fb8d20ae8a12b1f333cb5812a1de608158cee0e75b367d97980c6b55e27e8217dbfbd57f5df7da980dd8ac86692c393553ac66ea0e77f7b9a232b6be728 WHIRLPOOL bc8b64f20b510d6ed1aaa84dfb4eeabe7a0420ccd7dc8075ed075f61126109c045eb79059aebb4a3e1022bd889dd0d95ce7e63045602f60d48ea0ba922054ac8
+DIST nipype-0.12.1.tar.gz 3092631 SHA256 876fc1c1331ab357d6c03f39ceeba95a3c9819c62dd5535b2b2654484e34b9b7 SHA512 feab0f71c1274a19f6861d73e7c94cd2d35858404c8ef1bf62a35da030ad5fc96ad86370043f018e919c90574b70d56051c3894709c139cecae5117cb2681527 WHIRLPOOL 8257f1bc7bb636764b91293dfa2d58fe2eb1114712bf5681475dab816c6ae851613509eb081f9624065e62e6a00e1d3adfb8ce6218456f14284b8eede47a588f
diff --git a/sci-libs/nipype/nipype-0.11.0.ebuild b/sci-libs/nipype/nipype-0.11.0.ebuild
index 7afa84181..ed497f000 100644
--- a/sci-libs/nipype/nipype-0.11.0.ebuild
+++ b/sci-libs/nipype/nipype-0.11.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
# pyamg missing py3 support
# PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
diff --git a/sci-libs/nipype/nipype-0.12.0.ebuild b/sci-libs/nipype/nipype-0.12.0.ebuild
index 7afa84181..ed497f000 100644
--- a/sci-libs/nipype/nipype-0.12.0.ebuild
+++ b/sci-libs/nipype/nipype-0.12.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
# pyamg missing py3 support
# PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
diff --git a/sci-libs/nipype/nipype-0.12.1.ebuild b/sci-libs/nipype/nipype-0.12.1.ebuild
new file mode 100644
index 000000000..ed497f000
--- /dev/null
+++ b/sci-libs/nipype/nipype-0.12.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# pyamg missing py3 support
+# PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Neuroimaging in Python: Pipelines and Interfaces"
+HOMEPAGE="http://nipy.sourceforge.net/nipype/"
+SRC_URI="https://github.com/nipy/nipype/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pydotplus[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -v || die
+}
diff --git a/sci-libs/nipype/nipype-9999.ebuild b/sci-libs/nipype/nipype-9999.ebuild
index 21eff08f0..7c8c8edd0 100644
--- a/sci-libs/nipype/nipype-9999.ebuild
+++ b/sci-libs/nipype/nipype-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
# pyamg missing py3 support
# PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )