aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-11 21:01:12 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-11 21:01:12 +0200
commit6df21099f76d9c9f49670a3bf61b12fc0edb4762 (patch)
treeb00cf0808abcb27442784c5fc10f77d30cf0259f
parentdev-python/click-didyoumean: remove duplicate (diff)
downloadsci-6df21099f76d9c9f49670a3bf61b12fc0edb4762.tar.gz
sci-6df21099f76d9c9f49670a3bf61b12fc0edb4762.tar.bz2
sci-6df21099f76d9c9f49670a3bf61b12fc0edb4762.zip
dev-python/fslpy: add 3.10.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/fslpy/Manifest1
-rw-r--r--dev-python/fslpy/fslpy-3.10.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/fslpy/Manifest b/dev-python/fslpy/Manifest
index 196e885ac..5ca063ba7 100644
--- a/dev-python/fslpy/Manifest
+++ b/dev-python/fslpy/Manifest
@@ -1 +1,2 @@
+DIST fslpy-3.10.0.tar.gz 4695461 BLAKE2B 9ce74ed6175fb84fe0f123375273a9450c03b659c977b48e3fb874509d5b3f728c75aff850931e1af4fd398fb5eda80a6eef90b2a582e8db3f2135704b4124ed SHA512 b9b12350308d2aee5d10c16582abd96f17b56893287fc32ab3942e8edce8add1f96e1f5c83cca761707be9b2442262e28d961879d5d02e1001006805a74e1cda
DIST fslpy-3.8.1.tar.gz 4698603 BLAKE2B 33740081a065b6684b864eaf50910a38e26ce7aa10d18bf8faaeaf34ee87dfa22e8f2ee3cebc5681f2356cfb519a59ba07232a3cfb81526258ef92f3ced893ea SHA512 1b5d945f6aae6557e892e5700f228170bab8a235c77d06b162fc2afc16663f3bdbe18e54e4e20dad46ac873ccbf0cdc2649e5ac1c53e17b0d78c45e91e8a1896
diff --git a/dev-python/fslpy/fslpy-3.10.0.ebuild b/dev-python/fslpy/fslpy-3.10.0.ebuild
new file mode 100644
index 000000000..7140be033
--- /dev/null
+++ b/dev-python/fslpy/fslpy-3.10.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 virtualx
+
+DESCRIPTION="The FSL Python Library"
+HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fslpy"
+SRC_URI="https://git.fmrib.ox.ac.uk/fsl/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/dill[${PYTHON_USEDEP}]
+ >=dev-python/h5py-2.9[${PYTHON_USEDEP}]
+ >=dev-python/indexed_gzip-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/trimesh-2.37.29[${PYTHON_USEDEP}]
+ =dev-python/wxpython-4*[${PYTHON_USEDEP}]
+ >=sci-libs/rtree-0.8.3[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-2.4[${PYTHON_USEDEP}]
+ >=dev-python/scipy-0.18[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
+
+python_prepare_all() {
+ # Do not depend on coverage
+ sed -i -e 's/--cov=fsl//g' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ epytest -m "not (dicomtest or longtest or fsltest)" || die "Tests failed with ${EPYTHON}"
+}