aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-07 21:09:31 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-07 21:09:31 +0200
commit6fa9b784963ad6227f124cf2601113902e06c341 (patch)
tree54e821b77207fbb122df8d3e36c547f714ec3591
parentdev-python/jupyterlab: ewarn instead of die (diff)
downloadsci-6fa9b784.tar.gz
sci-6fa9b784.tar.bz2
sci-6fa9b784.zip
dev-python/jupyterlab: depend on jupyter_packaging
to take care of the js stuff, makes life nice and easy Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/jupyterlab/jupyterlab-3.1.10-r1.ebuild (renamed from dev-python/jupyterlab/jupyterlab-3.1.10.ebuild)20
1 files changed, 5 insertions, 15 deletions
diff --git a/dev-python/jupyterlab/jupyterlab-3.1.10.ebuild b/dev-python/jupyterlab/jupyterlab-3.1.10-r1.ebuild
index 7d3603c67..3fb54861a 100644
--- a/dev-python/jupyterlab/jupyterlab-3.1.10.ebuild
+++ b/dev-python/jupyterlab/jupyterlab-3.1.10-r1.ebuild
@@ -18,6 +18,8 @@ KEYWORDS="~amd64"
# TODO: package openapi et al
RESTRICT="test"
+BDEPEND="dev-python/jupyter_packaging[${PYTHON_USEDEP}]"
+
RDEPEND="
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
@@ -33,19 +35,7 @@ distutils_enable_tests pytest
# TODO: package myst_parser
#distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
-pkg_postinst() {
- # We have to do this here because we need internet since this uses yarn
- jupyter-lab build -y || ( \
- ewarn "Failed to build jupyterlab javascript assets, please run"
- ewarn "'jupyter-lab build' manually before starting jupyter-lab."
- ewarn "Note that this will likely require network access."
- )
-}
-
-pkg_prerm() {
- jupyter-lab clean -y --static || ( \
- ewarn "Failed to clean jupyterlab javascript assets, please remove"
- ewarn "/usr/share/jupyter/lab/staging and /usr/share/jupyter/lab/static"
- ewarn "manually."
- )
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
}