aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-14 12:39:34 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-14 12:39:34 +0100
commit6ff188a81f27d09a7a6eb304d91afc3a5caea7d4 (patch)
tree59988d906a1d75f633257d30bcce0420f8fbc5c7
parentRaise eselect version requirement (diff)
downloadsci-6ff188a81f27d09a7a6eb304d91afc3a5caea7d4.tar.gz
sci-6ff188a81f27d09a7a6eb304d91afc3a5caea7d4.tar.bz2
sci-6ff188a81f27d09a7a6eb304d91afc3a5caea7d4.zip
sci-libs/atlas: Warn if incompatible kernel config is set
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=567682 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-libs/atlas/atlas-3.11.38-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sci-libs/atlas/atlas-3.11.38-r1.ebuild b/sci-libs/atlas/atlas-3.11.38-r1.ebuild
index 3c760fef6..8af15062d 100644
--- a/sci-libs/atlas/atlas-3.11.38-r1.ebuild
+++ b/sci-libs/atlas/atlas-3.11.38-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=5
FORTRAN_NEEDED=fortran
-inherit alternatives-2 eutils fortran-2 multilib numeric toolchain-funcs versionator
+inherit alternatives-2 eutils fortran-2 linux-info multilib numeric toolchain-funcs versionator
LAPACKP=lapack-3.6.0.tgz
@@ -39,6 +39,13 @@ pkg_setup() {
[[ -e /sys/devices/system/cpu/intel_pstate ]] \
&& die "Intel P-State driver detected. Please reboot with 'intel_pstate=disable' in your cmdline"
use fortran && fortran-2_pkg_setup
+ CONFIG_CHECK="
+ !~X86_P4_CLOCKMOD
+ !~X86_INTEL_PSTATE
+ "
+ ERROR_KERNEL_X86_P4_CLOCKMOD="P4 Clockmod frequency scaling influences tuning and needs to be disabled at compile time."
+ ERROR_KERNEL_X86_INTEL_PSTATE="Intel Pstate frequency scaling influences tuning and needs to be disabled at compile time."
+ linux-info_pkg_setup
}
src_configure() {