aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-28 18:49:33 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-28 18:49:33 +0100
commit708ddd341f8315b32ab21aac63ab2b16a4743bb1 (patch)
tree7ed57c08d11eeebc0769a905b36652e5d849690d
parentdev-python/traitlets: Moved to tree (diff)
downloadsci-708ddd34.tar.gz
sci-708ddd34.tar.bz2
sci-708ddd34.zip
dev-python/testpath: Moved to tree
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-python/testpath/ChangeLog4
-rw-r--r--dev-python/testpath/Manifest1
-rw-r--r--dev-python/testpath/testpath-0.2.ebuild55
3 files changed, 4 insertions, 56 deletions
diff --git a/dev-python/testpath/ChangeLog b/dev-python/testpath/ChangeLog
index 1a53cdd40..edc631fc9 100644
--- a/dev-python/testpath/ChangeLog
+++ b/dev-python/testpath/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 28 Nov 2015; Marius Brehler <marbre@linux.sungazer.de> -Manifest,
+ -testpath-0.2.ebuild:
+ dev-python/testpath: Moved to tree
+
21 Sep 2015; Marius Brehler <marbre@linux.sungazer.de> testpath-9999.ebuild:
dev-python/testpath: Add ~x86 to KEYWORDS
diff --git a/dev-python/testpath/Manifest b/dev-python/testpath/Manifest
deleted file mode 100644
index 665ec3870..000000000
--- a/dev-python/testpath/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST testpath-0.2.tar.gz 13732 SHA256 a5388cc7c8370b1f11298c1d513b3d2b9e2f390607a7c39963e6e3ba9f1b7012 SHA512 cc211bdc8f31ff4c286324e37bbce7fd84e19447d9735f396ce67f7568dd1d133be732c1fd7a08928c94566279d0f293a0caeed6a58ae6cd3dc293035fe164ea WHIRLPOOL 6b87b1c5ba590e6b19968e823dee22d7bbe0411124c1290593eb5efd78b5af06c51853d3359f339c4ca60b2842c409a1fcd0ff45c59f2e7e07f557534d78fcaa
diff --git a/dev-python/testpath/testpath-0.2.ebuild b/dev-python/testpath/testpath-0.2.ebuild
deleted file mode 100644
index a3ee76529..000000000
--- a/dev-python/testpath/testpath-0.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Test utilities for code working with files and commands"
-HOMEPAGE="http://jupyter.org"
-SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-
-DEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- virtual/python-pathlib[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- "
-
-PATCHES=(
- "${FILESDIR}/${P}"-setup.py.patch
- )
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
- fi
-
-distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
- }
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
- py.test || die
-}