aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-03-05 21:09:21 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-03-05 21:09:21 +0100
commit748a9abdd6948868e36aa058ab158d4c4506fdd2 (patch)
tree6060f58a3511e2ae782d71c769735fe3bd8f5239
parentnew package (diff)
downloadsci-748a9abd.tar.gz
sci-748a9abd.tar.bz2
sci-748a9abd.zip
added build.xml exported by author from Eclipse IDE (it doesn't work under ant eclasses in my hands)
Package-Manager: portage-2.2.15
-rw-r--r--sci-biology/fastqc/ChangeLog5
-rw-r--r--sci-biology/fastqc/fastqc-0.11.2.ebuild12
-rw-r--r--sci-biology/fastqc/files/build.xml59
3 files changed, 73 insertions, 3 deletions
diff --git a/sci-biology/fastqc/ChangeLog b/sci-biology/fastqc/ChangeLog
index 6b6cbf580..b828a60ff 100644
--- a/sci-biology/fastqc/ChangeLog
+++ b/sci-biology/fastqc/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 05 Mar 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> +files/build.xml,
+ fastqc-0.11.2.ebuild:
+ added build.xml exported by author from Eclipse IDE (it doesn't work under ant
+ eclasses in my hands)
+
*fastqc-0.11.2 (24 Feb 2015)
24 Feb 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
diff --git a/sci-biology/fastqc/fastqc-0.11.2.ebuild b/sci-biology/fastqc/fastqc-0.11.2.ebuild
index b6082662e..dadc2881d 100644
--- a/sci-biology/fastqc/fastqc-0.11.2.ebuild
+++ b/sci-biology/fastqc/fastqc-0.11.2.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit java-pkg-2 eutils
+inherit java-pkg-2 eutils java-ant-2
DESCRIPTION="Perl-based wrapper around java apps to quality control FASTA/FASTQ sequence files"
HOMEPAGE="http://www.bioinformatics.babraham.ac.uk/projects/fastqc/"
@@ -16,11 +16,17 @@ KEYWORDS=""
IUSE=""
DEPEND="sci-biology/picard
- >=virtual/jre-1.5"
-RDEPEND="${DEPEND}"
+ >=virtual/jre-1.5:*"
+RDEPEND="${DEPEND}
+ >=virtual/jdk-1.5:*
+ dev-java/ant-core"
S="${WORKDIR}"/FastQC
+src_prepare(){
+ cp "${FILESDIR}"/build.xml . || die
+}
+
src_install(){
dobin fastqc run_fastqc.bat
dodoc README.txt RELEASE_NOTES.txt
diff --git a/sci-biology/fastqc/files/build.xml b/sci-biology/fastqc/files/build.xml
new file mode 100644
index 000000000..c4a692096
--- /dev/null
+++ b/sci-biology/fastqc/files/build.xml
@@ -0,0 +1,59 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- WARNING: Eclipse auto-generated file.
+ Any modifications will be overwritten.
+ To include a user specific buildfile here, simply create one in the same
+ directory with the processing instruction <?eclipse.ant.import?>
+ as the first entry and export the buildfile again. -->
+<project basedir="." default="build" name="FastQC">
+ <property environment="env"/>
+ <property name="debuglevel" value="source,lines,vars"/>
+ <property name="target" value="1.5"/>
+ <property name="source" value="1.5"/>
+ <path id="FastQC.classpath">
+ <pathelement location="bin"/>
+ <pathelement location="jbzip2-0.9.jar"/>
+ <pathelement location="sam-1.103.jar"/>
+ <pathelement location="cisd-jhdf5.jar"/>
+ </path>
+ <target name="init">
+ <mkdir dir="bin"/>
+ <copy includeemptydirs="false" todir="bin">
+ <fileset dir=".">
+ <exclude name="**/*.launch"/>
+ <exclude name="**/*.java"/>
+ </fileset>
+ </copy>
+ </target>
+ <target name="clean">
+ <delete dir="bin"/>
+ </target>
+ <target depends="clean" name="cleanall"/>
+ <target depends="build-subprojects,build-project" name="build"/>
+ <target name="build-subprojects"/>
+ <target depends="init" name="build-project">
+ <echo message="${ant.project.name}: ${ant.file}"/>
+ <javac debug="true" debuglevel="${debuglevel}" destdir="bin" includeantruntime="false" source="${source}" target="${target}">
+ <src path="."/>
+ <classpath refid="FastQC.classpath"/>
+ </javac>
+ </target>
+ <target description="Build all projects which reference this project. Useful to propagate changes." name="build-refprojects"/>
+ <target description="copy Eclipse compiler jars to ant lib directory" name="init-eclipse-compiler">
+ <copy todir="${ant.library.dir}">
+ <fileset dir="${ECLIPSE_HOME}/plugins" includes="org.eclipse.jdt.core_*.jar"/>
+ </copy>
+ <unzip dest="${ant.library.dir}">
+ <patternset includes="jdtCompilerAdapter.jar"/>
+ <fileset dir="${ECLIPSE_HOME}/plugins" includes="org.eclipse.jdt.core_*.jar"/>
+ </unzip>
+ </target>
+ <target description="compile project with Eclipse compiler" name="build-eclipse-compiler">
+ <property name="build.compiler" value="org.eclipse.jdt.core.JDTCompilerAdapter"/>
+ <antcall target="build"/>
+ </target>
+ <target name="FastQCApplication">
+ <java classname="uk.ac.babraham.FastQC.FastQCApplication" failonerror="true" fork="yes">
+ <classpath refid="FastQC.classpath"/>
+ </java>
+ </target>
+</project>