aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jbronder@gentoo.org>2013-07-02 18:59:12 -0400
committerJustin Bronder <jbronder@gentoo.org>2013-07-02 18:59:18 -0400
commit7763eb10db6ac6942ccf59f741bc60ebb27581c6 (patch)
tree076bbfaaccd059a2d2de81941cceb89100567ca1
parentAdded missing patch. (diff)
downloadsci-7763eb10db6ac6942ccf59f741bc60ebb27581c6.tar.gz
sci-7763eb10db6ac6942ccf59f741bc60ebb27581c6.tar.bz2
sci-7763eb10db6ac6942ccf59f741bc60ebb27581c6.zip
Update patch per sandbox team, link to upstream tickets.
Package-Manager: portage-2.1.12.2
-rw-r--r--sys-cluster/openmpi/ChangeLog4
-rw-r--r--sys-cluster/openmpi/files/hooks-disable-malloc-override-inside-of-Gentoo-sandb.patch8
2 files changed, 8 insertions, 4 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 9b844ff43..54e1caade 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 02 Jul 2013; Justin Bronder <jsbronder@gentoo.org>
+ files/hooks-disable-malloc-override-inside-of-Gentoo-sandb.patch:
+ Update patch per sandbox team
+
02 Jul 2013; Justin Bronder <jsbronder@gentoo.org> -openmpi-1.6.4.ebuild:
Remove old
diff --git a/sys-cluster/openmpi/files/hooks-disable-malloc-override-inside-of-Gentoo-sandb.patch b/sys-cluster/openmpi/files/hooks-disable-malloc-override-inside-of-Gentoo-sandb.patch
index 5683c81b4..197430aee 100644
--- a/sys-cluster/openmpi/files/hooks-disable-malloc-override-inside-of-Gentoo-sandb.patch
+++ b/sys-cluster/openmpi/files/hooks-disable-malloc-override-inside-of-Gentoo-sandb.patch
@@ -1,4 +1,4 @@
-From 094de74dc5e518a931c495692143ea3282553674 Mon Sep 17 00:00:00 2001
+From 3bd5897c7ca8ab61fb024957aeae891e204b3e3f Mon Sep 17 00:00:00 2001
From: Justin Bronder <jsbronder@gmail.com>
Date: Mon, 1 Jul 2013 20:37:17 -0400
Subject: [PATCH] hooks: disable malloc override inside of Gentoo sandbox
@@ -15,7 +15,7 @@ See https://bugs.gentoo.org/show_bug.cgi?id=462602
1 file changed, 9 insertions(+), 2 deletions(-)
diff --git a/opal/mca/memory/linux/hooks.c b/opal/mca/memory/linux/hooks.c
-index 6a1646f..ce91e76 100644
+index 6a1646f..5ded08c 100644
--- a/opal/mca/memory/linux/hooks.c
+++ b/opal/mca/memory/linux/hooks.c
@@ -747,9 +747,16 @@ static void opal_memory_linux_malloc_init_hook(void)
@@ -27,13 +27,13 @@ index 6a1646f..ce91e76 100644
+
+ This is also an issue when using Gentoo's version of 'fakeroot',
+ sandbox v2.5. Sandbox environments can also be detected fairly
-+ easily by looking for SANDBOX_PID.
++ easily by looking for SANDBOX_ON.
+ */
+
if (getenv("FAKEROOTKEY") != NULL ||
- getenv("FAKED_MODE") != NULL) {
+ getenv("FAKED_MODE") != NULL ||
-+ getenv("SANDBOX_PID") != NULL ) {
++ getenv("SANDBOX_ON") != NULL ) {
return;
}