aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormschubert <mschu.dev@gmail.com>2016-01-23 21:59:18 +0000
committerJustin Lecher <jlec@gentoo.org>2016-02-28 10:43:14 +0000
commit78cab883d2457b52fb12f8a72ec7ce29c0d51950 (patch)
tree066b658cdaa9b264a5102d73bf801787f00bde9c
parentsci-biology/salmon: bump EAPI=6 (diff)
downloadsci-78cab883.tar.gz
sci-78cab883.tar.bz2
sci-78cab883.zip
sci-biology/sailfish: add ebuild
Package-Manager: portage-2.2.20-prefix
-rw-r--r--sci-biology/sailfish/Manifest1
-rw-r--r--sci-biology/sailfish/files/sailfish-0.9.1-no-boost-static.patch20
-rw-r--r--sci-biology/sailfish/metadata.xml15
-rw-r--r--sci-biology/sailfish/sailfish-0.9.1.ebuild28
-rw-r--r--sci-biology/sailfish/sailfish-9999.ebuild28
5 files changed, 92 insertions, 0 deletions
diff --git a/sci-biology/sailfish/Manifest b/sci-biology/sailfish/Manifest
new file mode 100644
index 000000000..022dbb249
--- /dev/null
+++ b/sci-biology/sailfish/Manifest
@@ -0,0 +1 @@
+DIST sailfish-0.9.1.tar.gz 1616817 SHA256 c3e74bb95501618ba34883395ac84f07504e038200936b5c03cab269ab60f1de SHA512 3765ddb7ba64d34757cb71e0a7255759f7c6e53ee1d45ac744ed12f98f9025e9a05d9b49a681c6e90b265d2e08b6591444b575d0933b2737d01f417602f5010e WHIRLPOOL 7614e9d6bb72718ee63648ef698484b378d0945f2da44dc560f0a5f5bea5336dfe358fbd801e9254cbc2d4fdf0bbd3a4ea82adae4e90e3cdcda26d93295a381d
diff --git a/sci-biology/sailfish/files/sailfish-0.9.1-no-boost-static.patch b/sci-biology/sailfish/files/sailfish-0.9.1-no-boost-static.patch
new file mode 100644
index 000000000..7ac3d0882
--- /dev/null
+++ b/sci-biology/sailfish/files/sailfish-0.9.1-no-boost-static.patch
@@ -0,0 +1,20 @@
+Do not force static and multithreaded boost libs, use what is available
+
+Patch by Michael Schubert
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -162,13 +162,6 @@ if ( DEFINED CUSTOM_BOOST_PATH )
+ set (CMAKE_LIBRARY_PATH ${CUSTOM_BOOST_PATH}/lib ${CMAKE_LIBRARY_PATH})
+ endif ( DEFINED CUSTOM_BOOST_PATH )
+
+-##
+-# We want static, multithreaded boost libraries
+-##
+-set (Boost_USE_STATIC_LIBS ON)
+-set (Boost_USE_MULTITHREADED ON)
+-#set (Boost_USE_STATIC_RUNTIME OFF)
+-
+ find_package (ZLIB)
+ if (NOT ZLIB_FOUND)
+ message (FATAL_ERROR "zlib must be installed before configuration & building can proceed")
diff --git a/sci-biology/sailfish/metadata.xml b/sci-biology/sailfish/metadata.xml
new file mode 100644
index 000000000..2831ceb14
--- /dev/null
+++ b/sci-biology/sailfish/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mschu.dev@gmail.com</email>
+ <name>Michael Schubert</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kingsfordgroup/sailfish</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-biology/sailfish/sailfish-0.9.1.ebuild b/sci-biology/sailfish/sailfish-0.9.1.ebuild
new file mode 100644
index 000000000..c17ea2988
--- /dev/null
+++ b/sci-biology/sailfish/sailfish-0.9.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Rapid Mapping-based Isoform Quantification from RNA-Seq Reads"
+HOMEPAGE="http://www.cs.cmu.edu/~ckingsf/software/sailfish/"
+SRC_URI="https://github.com/kingsfordgroup/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.1-no-boost-static.patch )
+
+DEPEND="dev-libs/boost:0
+ dev-libs/jemalloc
+ dev-cpp/tbb"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake-utils_src_install
+ rm -r "${ED}"/usr/tests || die
+}
diff --git a/sci-biology/sailfish/sailfish-9999.ebuild b/sci-biology/sailfish/sailfish-9999.ebuild
new file mode 100644
index 000000000..2d60e34cb
--- /dev/null
+++ b/sci-biology/sailfish/sailfish-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="Rapid Mapping-based Isoform Quantification from RNA-Seq Reads"
+HOMEPAGE="http://www.cs.cmu.edu/~ckingsf/software/sailfish/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/kingsfordgroup/sailfish.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.1-no-boost-static.patch )
+
+DEPEND="dev-libs/boost:0
+ dev-libs/jemalloc
+ dev-cpp/tbb"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake-utils_src_install
+ rm -r "${ED}"/usr/tests || die
+}