aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2018-01-24 22:08:39 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2018-01-24 22:08:39 +0100
commit7964a3e5fde9e6f2c47e62f8c44d8570a90572f7 (patch)
treefd2578a68e0f0f912877a2b59365a36b29c4722f
parentsci-biology/nanopolish: update compile procedure and deps (diff)
downloadsci-7964a3e5.tar.gz
sci-7964a3e5.tar.bz2
sci-7964a3e5.zip
sci-libs/fast5: version bump, fix compile paths for hdf5
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--sci-libs/fast5/Manifest2
-rw-r--r--sci-libs/fast5/fast5-0.6.4.ebuild (renamed from sci-libs/fast5/fast5-0.6.2.ebuild)8
-rw-r--r--sci-libs/fast5/fast5-9999.ebuild6
3 files changed, 8 insertions, 8 deletions
diff --git a/sci-libs/fast5/Manifest b/sci-libs/fast5/Manifest
index b44be38ff..cc50f8f31 100644
--- a/sci-libs/fast5/Manifest
+++ b/sci-libs/fast5/Manifest
@@ -1 +1 @@
-DIST fast5-0.6.2.tar.gz 63779 BLAKE2B 1949b43eb16bcddb96131773fb990259d99476163789ec2e0c4240dd86abd43ac5e830b21dfa7224e551eef5569ad42b4b830f7ccb88c0332b108949f2ec88a3 SHA512 e5ba4ce6196713287302d5926839584e01beb6b8918032c0a831db3ee8f51e48617e42ce0726ecaf39cf86b8c2c33fa8041db7aec0218d66fa48bfa8889d3425
+DIST fast5-0.6.4.tar.gz 93660 BLAKE2B 8f7fd749fa90d6b5d4a530401b1f07a7ff05914fdd7b957e6555ac6e513cfa38529c3ea2973eea04228b9ff6332bfa0688fc65d6a032936fe05852c0a181efa6 SHA512 e3489cdc55f13bf12ae31759eaebea17128506999c3ea3dbd7e40418180dd5cb6e1d27f26f769f9edcf7a39390b6a84bd2832495f17fa3367065168760a0deaf
diff --git a/sci-libs/fast5/fast5-0.6.2.ebuild b/sci-libs/fast5/fast5-0.6.4.ebuild
index 186c157d4..181c2e593 100644
--- a/sci-libs/fast5/fast5-0.6.2.ebuild
+++ b/sci-libs/fast5/fast5-0.6.4.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4} )
-inherit distutils-r1
+inherit distutils-r1 multilib
DESCRIPTION="C++ header-only library for reading Oxford Nanopore Fast5 files"
HOMEPAGE="https://github.com/mateidavid/fast5"
-SRC_URI="https://github.com/mateidavid/fast5/archive/v0.6.2.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/mateidavid/fast5/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -25,7 +25,7 @@ DEPEND="
RDEPEND="${DEPEND}"
src_compile(){
- emake -C python develop-user
+ emake -C python develop-user HDF5_DIR="${EPREFIX}"/usr HDF5_LIB_DIR="${EPREFIX}"/usr/$(get_libdir)
}
src_install(){
diff --git a/sci-libs/fast5/fast5-9999.ebuild b/sci-libs/fast5/fast5-9999.ebuild
index a36740179..c3b044e61 100644
--- a/sci-libs/fast5/fast5-9999.ebuild
+++ b/sci-libs/fast5/fast5-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4} )
-inherit distutils-r1 git-r3
+inherit distutils-r1 multilib git-r3
DESCRIPTION="C++ header-only library for reading Oxford Nanopore Fast5 files"
HOMEPAGE="https://github.com/mateidavid/fast5"
@@ -22,5 +22,5 @@ DEPEND="
RDEPEND="${DEPEND}"
src_compile(){
- emake -C python develop-user
+ emake -C python develop-user HDF5_DIR="${EPREFIX}"/usr HDF5_LIB_DIR="${EPREFIX}"/usr/$(get_libdir)
}