aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-11-29 11:13:09 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2016-11-29 11:15:17 +0100
commit7bb33356e38e27c166e9521f7f3744096877aa4d (patch)
tree6be0e896f9c0288dfc74637f4502a582be139a83
parentdev-python/arrayfire-python: Drop old (diff)
downloadsci-7bb33356.tar.gz
sci-7bb33356.tar.bz2
sci-7bb33356.zip
sci-libs/arrayfire: Version bump to 3.4.1
Package-Manager: portage-2.3.0
-rw-r--r--sci-libs/arrayfire/Manifest1
-rw-r--r--sci-libs/arrayfire/arrayfire-3.4.1.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/sci-libs/arrayfire/Manifest b/sci-libs/arrayfire/Manifest
index 59dbac2b7..edb1f86be 100644
--- a/sci-libs/arrayfire/Manifest
+++ b/sci-libs/arrayfire/Manifest
@@ -1,4 +1,5 @@
DIST arrayfire-3.1.3.tar.bz2 23740458 SHA256 72cf094fec4366d2ee4d87a064a8beece9b1460a0340d739291208f8a001093f SHA512 500fd7652494fed5891f0c8bc31ca3ab87cc0c8587f13793621bb5f8c348c3dddccfc1805b99360251c87998765e0c3221e55c49fa4ac2eb3a1c06c1aeb680ee WHIRLPOOL 384d94bdeb5c993559df9524d63e55ef757898c2d7ef370feaaf2733ffe8d3a9543f1c7bcda67d14622a29adf4e6b7bc2dcacde4471291a07bc6e8f79c9e5ea1
DIST arrayfire-3.2.2.tar.bz2 30359885 SHA256 7bcc13ff29bdfb647813ee0e9830ce8387217953427abe0d9904de671e600831 SHA512 ff897eb24d85d83bf844a7507181f2091ac7d902260b9f4b4b2d4aea898c3e818a4694eb57dfff67aaeeabc6180b5e6e1e295eab5ccdab639e280fa62b5e0945 WHIRLPOOL 427a0f97e8934990f63e38d312792706c16fc6a7d6473e05ed49bfa0a71892ed0114df3f295ccaaa9632a03241ac20eefa1cee7e929bfbb2445f8e0cf50f3e98
DIST arrayfire-3.3.2.tar.bz2 34100522 SHA256 354d4cf2811718d4e73170f0116b2ac4518402f2a627c9169ba107a89abda158 SHA512 0f7101af887d52eea537c8cbe41e26676f3acb26d2af903e2e6152433ecceb5349633b5f6e8a677854839fbc5ff5a64e88d31d85e80c4c55cab9836ccba579fb WHIRLPOOL b7f0044039b15fc399837883b391026e8040494fb2934736a62cec68269446305bddc480f73070d8a2dcde0b36209413841a1d0b33ad71f13074e324bbb90434
+DIST arrayfire-3.4.1.tar.bz2 33229490 SHA256 aaca6e4f7c8110da5358c54e5cb9941bc034870b1b5c82d34c2f670b2ef01d48 SHA512 f18e8d7278901666cf33431c821c661306a73e5887c1efe9d8fbe5a9de24bb98820422d36836a42566a3a9799cd6f8397bae544a9f9a0aa19ef31537d72d069e WHIRLPOOL d5779770914178df976e667c8c9ef955caf8215d156c846ac1e580687cbd7be318aac0d6259c9185d7823b962987e0325d4a4eaab096c0329a0876a982100c83
DIST gtest-1.7.0.zip 1164254 SHA256 247ca18dd83f53deb1328be17e4b1be31514cedfc1e3424f672bf11fd7e0d60d SHA512 8859369f2dd32cbc2ac01aba029aa3ff20a321f40658b9643aff442d34c33468221866b801b28c66a28af47dbcd362d26941fc98db92b6efb7e41ea5b7be1a07 WHIRLPOOL 0c31a385159551859c1afe76480b3fb1b560d666db9a0afc5cbda92bcd53bf129f85a8f902c6ded0779c2b4c49aacec59ba5a4d5ce316a07bf08174f4fc64049
diff --git a/sci-libs/arrayfire/arrayfire-3.4.1.ebuild b/sci-libs/arrayfire/arrayfire-3.4.1.ebuild
new file mode 100644
index 000000000..8c80bc34b
--- /dev/null
+++ b/sci-libs/arrayfire/arrayfire-3.4.1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils multilib
+
+GTEST_PV="1.7.0"
+
+DESCRIPTION="A general purpose GPU library"
+HOMEPAGE="http://www.arrayfire.com/"
+SRC_URI="http://arrayfire.com/arrayfire_source/${PN}-full-${PV}.tar.bz2 -> ${P}.tar.bz2
+test? ( https://github.com/google/googletest/archive/release-${GTEST_PV}.zip -> gtest-${GTEST_PV}.zip )"
+KEYWORDS="~amd64"
+
+LICENSE="BSD
+ nonfree? ( OpenSIFT )"
+SLOT="0"
+IUSE="+examples +cpu cuda nonfree opencl test unified graphics"
+
+RDEPEND="
+ >=sys-devel/gcc-4.7:*
+ media-libs/freeimage
+ cuda? (
+ >=dev-util/nvidia-cuda-toolkit-8.0.44
+ dev-libs/boost
+ )
+ cpu? (
+ virtual/blas
+ virtual/cblas
+ virtual/lapacke
+ sci-libs/fftw:3.0
+ )
+ opencl? (
+ virtual/blas
+ virtual/cblas
+ virtual/lapacke
+ >=sci-libs/clblas-2.4
+ >=sci-libs/clfft-2.6.1
+ >=dev-libs/boost-1.61.0
+ dev-libs/opencl-clhpp
+ )
+ graphics? (
+ media-libs/glbinding
+ >=media-libs/glfw-3.1.1
+ =sci-visualization/forge-0.9.0
+ )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-full-${PV}"
+BUILD_DIR="${S}/build"
+CMAKE_BUILD_TYPE=Release
+
+# We need write acccess /dev/nvidiactl, /dev/nvidia0 and /dev/nvidia-uvm and the portage
+# user is (usually) not in the video group
+RESTRICT="userpriv"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]] ) ; then
+ die "Compilation with gcc older than 4.7 is not supported."
+ fi
+ fi
+}
+
+src_unpack() {
+ default
+
+ if ! use nonfree; then
+ find "${WORKDIR}" -name "*_nonfree*" -delete || die
+ fi
+
+ if use test; then
+ mkdir -p "${BUILD_DIR}"/third_party/src/ || die
+ mv "${WORKDIR}"/gtest-"${GTEST_PV}" "${BUILD_DIR}"/third_party/src/googletest || die
+ fi
+}
+
+src_configure() {
+ if use cuda; then
+ addwrite /dev/nvidiactl
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidia-uvm
+ fi
+
+ local mycmakeargs=(
+ -DBUILD_CPU="$(usex cpu)"
+ -DBUILD_CUDA="$(usex cuda)"
+ -DBUILD_OPENCL="$(usex opencl)"
+ -DBUILD_EXAMPLES="$(usex examples)"
+ -DBUILD_TEST="$(usex test)"
+ -DBUILD_GRAPHICS="$(usex graphics)"
+ -DBUILD_NONFREE="$(usex nonfree)"
+ -DBUILD_UNIFIED="$(usex unified)"
+ -DUSE_SYSTEM_BOOST_COMPUTE=ON
+ -DUSE_SYSTEM_CL2HPP=ON
+ -DUSE_SYSTEM_CLBLAS=ON
+ -DUSE_SYSTEM_CLFFT=ON
+ -DUSE_SYSTEM_FORGE=ON
+ -DUSE_SYSTEM_GLBINDING=ON
+ -DAF_INSTALL_CMAKE_DIR=/usr/$(get_libdir)/cmake/ArrayFire
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dobin "${BUILD_DIR}/bin2cpp"
+}