aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-02-07 11:39:33 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-02-07 11:46:35 +0100
commit7d34668536aa674a52943ee44e63baf1bb99eb1f (patch)
treefcb6bdfe5ece5bce051a8236313ee0bba87b7434
parentsci-physics/abinit: Add missing, drop useless dies (diff)
downloadsci-7d34668536aa674a52943ee44e63baf1bb99eb1f.tar.gz
sci-7d34668536aa674a52943ee44e63baf1bb99eb1f.tar.bz2
sci-7d34668536aa674a52943ee44e63baf1bb99eb1f.zip
sci-mathematics/giac-1.1.0: Add missing, drop useless dies
-rw-r--r--sci-mathematics/giac/giac-1.1.0.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/sci-mathematics/giac/giac-1.1.0.ebuild b/sci-mathematics/giac/giac-1.1.0.ebuild
index f04fc2d8a..34d059c6a 100644
--- a/sci-mathematics/giac/giac-1.1.0.ebuild
+++ b/sci-mathematics/giac/giac-1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -29,9 +29,9 @@ src_prepare(){
-e "s:config.h \$(includedir)/giac:config.h \$(DESTDIR)\$(includedir)/giac:g" \
-e "s:\$(DESTDIR)\$(DESTDIR):\$(DESTDIR):g" \
-e "s:\$(DESTDIR)/\$(DESTDIR):\$(DESTDIR):g" \
- -i `find -name Makefile\*`
+ -i `find -name Makefile\*` || die
if use !fltk; then
- sed -e "s: gl2ps\.[chlo]*::g" -i src/Makefile.*
+ sed -e "s: gl2ps\.[chlo]*::g" -i src/Makefile.* || die
fi
}
@@ -40,36 +40,36 @@ src_configure(){
then
append-cppflags -I$(fltk-config --includedir)
append-lfs-flags
- append-libs $(fltk-config --ldflags | sed -e 's/\(-L\S*\)\s.*/\1/')
+ append-libs $(fltk-config --ldflags | sed -e 's/\(-L\S*\)\s.*/\1/') || die
fi
local myeconfargs=(
$(use_enable fltk gui)
)
- autotools-utils_src_configure || die "configuring failed"
+ autotools-utils_src_configure
}
src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- mv "${D}"/usr/bin/{aide,giac-help}
- rm "${D}"/usr/bin/*cas_help
+ emake install DESTDIR="${D}"
+ mv "${D}"/usr/bin/{aide,giac-help} || die
+ rm "${D}"/usr/bin/*cas_help || die
dodoc AUTHORS ChangeLog INSTALL NEWS README TROUBLES
if use !fltk; then
- rm "${D}"/usr/bin/x*
+ rm "${D}"/usr/bin/x* || die
elif host-is-pax; then
pax-mark -m "${D}"/usr/bin/x*
fi
if use !doc; then
- rm -R "${D}"/usr/share/doc/giac "${D}"/usr/share/giac/doc/
+ rm -R "${D}"/usr/share/doc/giac "${D}"/usr/share/giac/doc/ || die
else
for LANG in el en es fr pt; do
if echo ${LINGUAS} | grep -v "$LANG" &> /dev/null; then
rm -R "${D}"/usr/share/giac/doc/"$LANG"
else
- ln "${D}"/usr/share/giac/doc/aide_cas "${D}"/usr/share/giac/doc/"$LANG"/aide_cas
+ ln "${D}"/usr/share/giac/doc/aide_cas "${D}"/usr/share/giac/doc/"$LANG"/aide_cas || die
fi
done
fi
if use !examples; then
- rm -R "${D}"/usr/share/giac/examples
+ rm -R "${D}"/usr/share/giac/examples || die
fi
}