aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-08-29 19:52:06 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-08-29 19:52:29 -0500
commit7d46fb1d005394c121a9fab2585d50b13660e74e (patch)
tree973868e93d96d222739586bb51965d46bec6c825
parentsys-cluster/mpich: fixed another typo (diff)
downloadsci-7d46fb1d.tar.gz
sci-7d46fb1d.tar.bz2
sci-7d46fb1d.zip
sci-mathematics/petsc: version bump to 3.7.3
Package-Manager: portage-2.2.28
-rw-r--r--sci-mathematics/petsc/Manifest1
-rw-r--r--sci-mathematics/petsc/petsc-3.7.3.ebuild255
2 files changed, 256 insertions, 0 deletions
diff --git a/sci-mathematics/petsc/Manifest b/sci-mathematics/petsc/Manifest
index 9abc71abf..022b9f04b 100644
--- a/sci-mathematics/petsc/Manifest
+++ b/sci-mathematics/petsc/Manifest
@@ -2,3 +2,4 @@ DIST petsc-3.4.2.tar.gz 18658689 SHA256 f13b0dc978fe0dcc1df032f8142a2fd345217f02
DIST petsc-3.5.4.tar.gz 20750322 SHA256 a85febf92c9ed2dd9a8f4305f31cd51f9514c01d3c31fb9fb69fb6f22bd3a960 SHA512 248b0c7d6c0076f65d66a325265baa20b8846d4f6902044c4fcd16ecfc586618075c4b0f470d2a674eaa954b8b7e08afadcea783bb84ae276091728607323204 WHIRLPOOL 42e3cb00778cebb7de08b7410ff5ea3fa48964679413959f56aff10b46d436cb9d9e2317d7314bd4501fdd4fb9f964f4e572f07b58a197f3d435b6f625d91c41
DIST petsc-3.6.4.tar.gz 21792990 SHA256 eb09925a139b52b4dd5a071b3da4fe2165f1d6e8f71d410479603c9976c940f0 SHA512 3e0a69b35424c519c9af43e2323b14f5ba650bf8fc653985769fe65d618223418ebd03c166bca0b7d3affaffa51b907a50b5d9cf714f2f94d044e9c592a84965 WHIRLPOOL b94faf0140e948cb01962fd9e240e5470858e76e7d26f007056001750cc6579724fcc01cab88bfa6cbb66ced8b177ec7d7fecd171c047df0b7c03454b2ecb250
DIST petsc-3.7.2.tar.gz 23111802 SHA256 36681dd0df97e0d5cd182d902e89f527eb8f441f05271159dac5340acb4cf0ec SHA512 f598b7312c3e9321c30f0665a3692991e977c3fc1659656cfa3329c31be0c18393e21db1d9d6f674bcb9045dad8bbfbc744ea996bd858e91f63a58aeaad556e8 WHIRLPOOL aa328f3715ead98fd546e072c51fc93c2ff2ce8698da7128abdcdf46f07706752012e21f8516f94db589d7c6d78036de38b6b54e04bddcff62360d39fd0815a4
+DIST petsc-3.7.3.tar.gz 23172670 SHA256 35657f5b9b8b89c6c1e0a1f5b91b94ef65ec00f7942960dd6f7a4cc79742cd1b SHA512 e6686f14d1ef57f1732b8b380611669ae3be278c546334354a17f536f307d452c98b652dfda5fdd42c52b4c2cc0b2f84f4bd53d258dea60786cee3c5ba387868 WHIRLPOOL 6cc2642d2c958bfacecfdc7a84d2d7c2c0fb41808a91ebb9f4c6b718b95dddf55b199669e3992553dc1105436e8a93bf4c72a222c9689f834aac5458a417f871
diff --git a/sci-mathematics/petsc/petsc-3.7.3.ebuild b/sci-mathematics/petsc/petsc-3.7.3.ebuild
new file mode 100644
index 000000000..357189f9e
--- /dev/null
+++ b/sci-mathematics/petsc/petsc-3.7.3.ebuild
@@ -0,0 +1,255 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils flag-o-matic fortran-2 python-any-r1 toolchain-funcs versionator
+
+MY_P="${PN}-$(replace_version_separator _ -)"
+
+DESCRIPTION="Portable, Extensible Toolkit for Scientific Computation"
+HOMEPAGE="http://www.mcs.anl.gov/petsc/"
+SRC_URI="http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/${MY_P}.tar.gz"
+
+LICENSE="petsc"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="afterimage boost complex-scalars cxx debug doc fftw
+ fortran hdf5 hypre mpi mumps scotch sparse superlu threads X"
+# Failed: imagemagick metis
+
+# hypre and superlu curretly exclude each other due to missing linking to hypre
+# if both are enabled
+REQUIRED_USE="
+ afterimage? ( X )
+ hdf5? ( mpi )
+ hypre? ( cxx mpi )
+ mumps? ( mpi scotch )
+ scotch? ( mpi )
+ ^^ ( hypre superlu )
+"
+# imagemagick? ( X )
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ afterimage? ( media-libs/libafterimage )
+ boost? ( dev-libs/boost )
+ fftw? ( sci-libs/fftw:3.0[mpi?] )
+ hdf5? ( sci-libs/hdf5[mpi?] )
+ hypre? ( >=sci-libs/hypre-2.8.0b[mpi?] )
+ mpi? ( virtual/mpi[cxx?,fortran?] )
+ mumps? ( sci-libs/mumps[mpi?] sci-libs/scalapack )
+ scotch? ( sci-libs/scotch[mpi?] )
+ sparse? ( sci-libs/suitesparse >=sci-libs/cholmod-1.7.0 )
+ superlu? ( sci-libs/superlu )
+ X? ( x11-libs/libX11 )
+"
+# metis? ( sci-libs/parmetis )
+# imagemagick? ( media-gfx/imagemagick )
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ dev-util/cmake
+"
+# cmake is used for parallel building
+# in some configuration setups, legacy build is used (slow)
+
+#
+# PETSc does not want its Makefiles to be invoked with anything higher than
+# -j1. The underlying build system does automatically invoke a parallel
+# build. This might not be what you want, but *hey* not your choice.
+#
+# V=1 enables verbose output with full compiler and linker invocation
+#
+MAKEOPTS="${MAKEOPTS} -j1 V=1"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-3.7.0-disable-rpath.patch \
+ "${FILESDIR}"/${PN}-3.7.0-fix_sandbox_violation.patch
+
+ sed -i -e 's%/usr/bin/env python%/usr/bin/env python2%' configure || die
+}
+
+src_configure() {
+ # bug 548498
+ # PETSc runs mpi processes during configure that result in a sandbox
+ # violation by trying to open /proc/mtrr rw. This is not easy to
+ # mitigate because it happens in libpciaccess.so called by libhwloc.so,
+ # which is used by libmpi.so.
+ addpredict /proc/mtrr
+
+ # petsc uses --with-blah=1 and --with-blah=0 to en/disable options
+ petsc_enable() {
+ use "$1" && echo "--with-${2:-$1}=1" || echo "--with-${2:-$1}=0"
+ }
+ # add external library:
+ # petsc_with use_flag libname libdir
+ # petsc_with use_flag libname include linking_libs
+ petsc_with() {
+ local myuse p=${2:-${1}}
+ if use ${1}; then
+ myuse="--with-${p}=1"
+ if [[ $# -ge 4 ]]; then
+ myuse="${myuse} --with-${p}-include=${EPREFIX}${3}"
+ shift 3
+ myuse="${myuse} --with-${p}-lib=$@"
+ else
+ myuse="${myuse} --with-${p}-dir=${EPREFIX}${3:-/usr}"
+ fi
+ else
+ myuse="--with-${p}=0"
+ fi
+ echo ${myuse}
+ }
+
+ # select between configure options depending on use flag
+ petsc_select() {
+ use "$1" && echo "--with-$2=$3" || echo "--with-$2=$4"
+ }
+
+ local mylang
+ local myopt
+
+ use cxx && mylang="cxx" || mylang="c"
+ use debug && myopt="debug" || myopt="opt"
+
+ # environmental variables expected by petsc during build
+ export PETSC_DIR="${S}"
+ export PETSC_ARCH="linux-gnu-${mylang}-${myopt}"
+
+ if use debug; then
+ strip-flags
+ filter-flags -O*
+ fi
+
+ # C Support on Cxx builds is enabled if possible
+ # i.e. when not using complex scalars
+ # (no complex type for both available at the same time)
+
+ # run petsc configure script
+ econf \
+ scrollOutput=1 \
+ FFLAGS="${FFLAGS} -fPIC" \
+ CFLAGS="${CFLAGS} -fPIC" \
+ CXXFLAGS="${CXXFLAGS} -fPIC" \
+ LDFLAGS="${LDFLAGS}" \
+ --with-shared-libraries \
+ --with-single-library \
+ --with-clanguage=${mylang} \
+ $(use cxx && ! use complex-scalars && echo "with-c-support=1") \
+ --with-petsc-arch=${PETSC_ARCH} \
+ --with-precision=double \
+ --with-gnu-compilers \
+ --with-blas-lapack-lib="$($(tc-getPKG_CONFIG) --libs lapack)" \
+ $(petsc_enable debug debugging) \
+ $(petsc_enable mpi) \
+ $(petsc_select mpi cc mpicc $(tc-getCC)) \
+ $(petsc_select mpi cxx mpicxx $(tc-getCXX)) \
+ $(petsc_enable fortran) \
+ $(use fortran && echo "$(petsc_select mpi fc mpif77 $(tc-getF77))") \
+ $(petsc_enable mpi mpi-compilers) \
+ $(petsc_select complex-scalars scalar-type complex real) \
+ --with-windows-graphics=0 \
+ --with-matlab=0 \
+ --with-cmake=cmake \
+ $(petsc_enable threads pthread) \
+ $(petsc_with afterimage afterimage \
+ /usr/include/libAfterImage -lAfterImage) \
+ $(petsc_with hdf5) \
+ $(petsc_with hypre hypre \
+ /usr/include/hypre -lHYPRE) \
+ $(petsc_with sparse suitesparse) \
+ $(petsc_with superlu superlu \
+ /usr/include/superlu -lsuperlu) \
+ $(petsc_with X x) \
+ $(petsc_with X x11) \
+ $(petsc_with scotch ptscotch \
+ /usr/include/scotch \
+ [-lptesmumps,-lptscotch,-lptscotcherr,-lscotch,-lscotcherr]) \
+ $(petsc_with mumps scalapack \
+ /usr/include/scalapack -lscalapack) \
+ $(petsc_with mumps mumps \
+ /usr/include \
+ [-lcmumps,-ldmumps,-lsmumps,-lzmumps,-lmumps_common,-lpord]) \
+ --with-imagemagick=0 \
+ --with-python=0 \
+ $(petsc_with boost) \
+ $(petsc_with fftw)
+
+# not yet tested:
+# python bindings, netcdf, fftw
+
+# failed dependencies, perhaps fixed in upstream soon:
+# $(petsc_with metis parmetis) \ # needs metis too (>=5.0.2)
+# $(petsc_with imagemagick imagemagick \
+# /usr/include/ImageMagick $($(tc-getPKG_CONFIG) --libs MagickCore)) \
+# $(petsc_enable threads pthreadclasses) \
+}
+
+src_install() {
+ # petsc install structure is very different from
+ # installing headers to /usr/include/petsc and lib to /usr/lib
+ # it also installs many unneeded executables and scripts
+ # so manual install is easier than cleanup after "emake install"
+ insinto /usr/include/${PN}
+ doins include/*.h*
+ insinto /usr/include/${PN}/${PETSC_ARCH}/include
+ doins ${PETSC_ARCH}/include/*
+ if use fortran; then
+ insinto /usr/include/${PN}/finclude
+ doins -r include/${PN}/finclude/*
+ fi
+ if ! use mpi ; then
+ insinto /usr/include/${PN}/mpiuni
+ doins include/mpiuni/*.h
+ fi
+ insinto /usr/include/${PN}/conf
+ doins lib/${PN}/conf/{variables,rules,test}
+ insinto /usr/include/${PN}/${PETSC_ARCH}/conf
+ doins ${PETSC_ARCH}/lib/${PN}/conf/{petscrules,petscvariables,RDict.db}
+ insinto /usr/include/${PN}/private
+ doins include/${PN}/private/*.h
+
+ # fix configuration files: replace "${S}" by installed location
+ sed -i \
+ -e "s:"${S}"::g" \
+ "${ED}"/usr/include/${PN}/${PETSC_ARCH}/include/petscconf.h \
+ "${ED}"/usr/include/${PN}/${PETSC_ARCH}/conf/petscvariables || die
+ sed -i \
+ -e "s:-I/include:-I${EPREFIX}/usr/include/${PN}:g" \
+ -e "s:-I/linux-gnu-cxx-opt/include:-I${EPREFIX}/usr/include/${PN}/${PETSC_ARCH}/include/:g" \
+ "${ED}"/usr/include/${PN}/${PETSC_ARCH}/conf/petscvariables || die
+ sed -i \
+ -e "s:usr/lib:usr/$(get_libdir):g" \
+ "${ED}"/usr/include/${PN}/${PETSC_ARCH}/include/petscconf.h || die
+
+ # fix the include path of petscvariables in lib/${PN}/conf/variables
+ # bug #559172
+ sed -i -e 's#lib/petsc/conf/#conf/#g' \
+ "${ED}"/usr/include/${PN}/conf/variables || die
+
+ # add information about installation directory and
+ # PETSC_ARCH to environmental variables
+ cat >> 99petsc <<- EOF
+ PETSC_ARCH=${PETSC_ARCH}
+ PETSC_DIR=${EPREFIX}/usr/include/${PN}
+ EOF
+ doenvd 99petsc
+
+ dolib.so ${PETSC_ARCH}/lib/*.so
+ dolib.so ${PETSC_ARCH}/lib/*.so.*
+
+ if use doc ; then
+ einfo "installing documentation (this could take a while)"
+ dodoc docs/manual.pdf
+ dohtml -r docs/*.html docs/changes docs/manualpages
+ fi
+}